link icon
Ask The Community

Commercial use - Connection time out



  • Hi, the problem is that after updating to the new version 15.0.8397, it is no longer possible to connect with relatives or friends' PCs, "Commercial Use Detected", I cannot connect even with another PC of mine in the same network.
    I read in the forums that the problem is the same for many other users who have done the update.
    It is very frustrating. Will anyone intervene to solve the problem quickly?
    thanks bye

  • bazbsg
    bazbsg Posts: 103 ✭✭

    oh bleep. (there I censored my own comment)

    TV on the remote PC must have upgraded itself to version 15 overnight. Now I have to upgrade my side before it will let me connect. Does anyone know if this will bring any new nightmares to us?

  • Im really frustrated!

    I have an account and to this account there are 3 pc 's and a android tv box connected. 1 pc and the tv box  is mine, 1 pc is for my parents and 1 pc for my mothers cousin. I use it to help them remotely solve problems on their pc because they are no experts. And to reach my tv box to do updates on it.

    Now teamviewer says every time I am using it commercially, denies connections for 5 or 10 minutes. That is really bothering. Also it keeps asking for password to connect my parents pc, although I am logged in on that pc with my tw account, and it starts automatically. So why does it asks for the password when i see th pc on list???????? It should join without typing in the password. 
    This program is getting worse and worse... 

  • Same thing happend to me today. I have 1 personal computer that I use and access remotely. Now I am getting kicked out after 30 secs and have to wait to try and connect again. Looking at all the others that have the same issue and the bad customer suppoort respsonse, is making me look into other alternatives. I am going to try **Third Party Product** and I am open to other suggestions as well. There is no way I am paying $50 a month to access 1 pc a few times a day at most.

  • I've used TeamViewer for 5+ years after a competitor eliminated their free tier. Until recently, TeamViewer was mostly reliable . . . until the software started to falsely -- and without any level of detail for evidence -- accuse me of commercial use. I carefully reviewed the largely ambiguous description of "Commerical Use" (use your favorite search engine to find it) that TeamViewer provides and my use did not match any of the three (3!) examples provided.

    From the sheer number of complaints I've read on this forum, it's obvious to me that TeamViewer has either:

    1. a severe bug in the v14 or v15 software stack or backend analytics, or
    2. TeamViewer has essentially decided to abandon the free use of their software

    Regardless, the sheer volume of recurring issues, the glacial customer service response time, and the fact that the false accusations continue should indicate the obvious:

    • TeamViewer really isn't interested in fixing this issue for non-revenue customers

    The sad part about this obvious conclusion is that it undermines any incentive to actually pay for the product. [Removed per Community Guidelines] what evidence exists that software quality/reliability and customer support would be any better? I would suggest: NONE.

    Here's what I did:

    1. deleted all the family and friends' computers from my account
    2. used my favorite search engine to find a list of competing free personal use products that allow me to remotely help my elderly parents and techphobic friends
    3. tried out a few, finally settling on one that I used to uninstall TeamViewer on every remote PC

    In summary, TeamViewer was good while it lasted, but the company has lost my confidence. I can't think of one reason for recommending it to anyone for business use based on the utterly opaque and disrespectful level of service shown.

    Good riddance, TeamViewer!

  • CbMe
    CbMe Posts: 1

    Well I guess I fell better in that I'm not alone.   Just logged in as my 92 year-old grandmother emailed me about some issue with her computer and I got the "you are using this commercially" message.   **bleep**??   I have only ever used it to connect to 3 parents, 1 grandparent and one nephew, 5 total PC's, that I maybe use one a month to address an issue. 
    So now I have to find a relative that is closer to her and that has basic computer knowledge to go over and help her out.   Guess it is my fault for not having a backup remote assistance application running just in case this went weird. 

  • Hi Brighter45,

    Well said!

    I agree - look at the volume and consistency of the complaints.

    I am now doing the same thing - I have found and am testing a replacement.  TeamViewer was a good product, but it is eliminating itself from the field.

  • jbarnett12
    jbarnett12 Posts: 11 ✭✭

    I have had exactly the same problem. Coupled with the issue around commercial and private use which is on going for me I have given up and moved to another free prouduct where I am not having these challenges. I am tired of battling some of the issues I have recently seen with Teamviewer and finally had to surrender

  • Hello,

    I have been using Team Viewer for personal use for years, and loved every bit of it.

    but now, it is saying commercial use detected and won't let me log into my laptop at home.

    I have had this issue before last year, and it was solved. and now it is happening again.

    please can someone help.

  • It is getting really annoying,,,

    I love team viewer. but I can't take the connection issues.

    within the 1 minute intervals, every 10 minuts that you can connect, I ended up installing **third party product**.

    It is not as slick as team viewer, but it works. and is free. 

    if they fix my account, I will go back to team viewer, but at the moment, it is unusable.

  • I have the same issue.  I'm not using it commercially.  How do I get them to fix my account?

  • I heard the fiscal numbers within TeamViewer are not doing so well. This is the result of the crazy action. I have used teamviewer for almost 9 years on my personal devices and today I got the same message. What a joke, $749 for a business use when I use it on 3 devices (my desktop, my laptop and my finance laptop.) Teamviewer did go public in biggest German tech IPO since dot-com boom on Sep. 25, 2019. Stock's are wavy for them. 

    *uninstalls TeamViewer and installs a better 3rd party app

  • @EyesOnThaPrize 

    The reason they're having financial issues is because of their bizarre pricing. There's nothing between free and $600/yr.

    If they had a limited use free version (so many minutes use per month, or even per session), and a personal use version for around $50/yr, I imagine that a good portion of their current free user base would upgrade.

    I switched to another remote utilities for Windows application, and while I'm well within their license terms for free usage, I'm strongly considering buying their license [removed as per Community Guidelines] because I actually really like the application. It seems better, faster, and more reliable than TeamViewer.

    [Removed as per Community Guidelines] I can't justify those kind of $$$, particularly when support is so awful.

    I understand that free users are a drain on their resources. A free user certainly isn't free to TeamViewer. But they should be trying to turn them into paying customers, not forcing them to look elsewhere.

    In theory, there's no difference between theory and practice. In practice, there is.
  • Greetings.

    Today, I tried to connect to my PERSONAL computers AT HOME from my work computers, from my PERSONAL laptop via mobile hotspot AND from the app on my phone. I was DENIED several times and received an error message telling me that COMMERCIAL USE WAS DETECTED. And, I couldnt switch back and forth between devices. These folks want me to BUY A LICENSE to connect to devices ON MY ACCOUNT! Oh well...

    I've been using Teamviewer for YEARS. Im going to a different provider now.

    SEEYA! Wouldnt wanna be ya!

    Oh yeah. I did call customer service and the level or "Customer Service" was appalling!Yeah...

  • I am strictly using TeamViewer privately to help my partner & friends with whatever PC-problems they have and to connect to my own home-PC to start queueing for WoW Classic.

    Yet this problem has appeared just recently and it's preventing me from using this application.

    35 dollars a month is a bit hefty considering my usage pattern...



  • same problem with me, i tried to call customer service but they refered me to this site.. so frustrated

  • I filled it in a month ago and still getting flagged.  I service several elderly friends and my brother in a nursing home and they are all CONSTANTLY having small issues as none of them really know how to use a computer very well.  I am not paid for any of my services and it is NOT commercial use.  I have heard the wait can be up to 3 months or more for any reply from TV.  Sad.

  • Ha!  Instead of the moderator "removing the competitor link" from this message, how about removing the "commercial use" flag from everyone's free versions of TV instead?

  • Hi Josh - I've filled out the form TWICE now in that past 2 months and I'm still getting the message about suspected commercial use and bumped off my connection.  I help several elderly people for free and my brother in a nursing home.  NOT commercial!  Please offer a REAL immediate solution to this problem.  Thanks.

    ID **Please do not post TeamViewer IDs** (please UNFLAG ME!)

  • I have filled out the same form and I never got a response or any solution to my problem.... I would really appreciate a reply from TeamViewer I have been waiting for over a month for a solution for this problem!!!! @TeamViewer 

    this has to be the worst support so far I've received for a product and worst way of getting in contact with anyone who can help!

  • They never reply too. Almost the same issue.

  • Hallo Community,

    bei mir hat auch die kommerzielle Nutzung "zugeschlagen". Ich administriere einen einzelnen Rechner, meinen privaten. Auf den verbinde ich mich via App am Handy, Tablet oder einem anderen Rechner. Über das Formular wurde meine ID auf free resettet am 29.10.19, da ich Privatanwender bin. Leider kommt beim Zugriff auf den Rechner via App etc. immer noch "kommerzielle Nutzung festgestellt". Ich habe hier gelesen das man sowohl die App als auch den Client neu installieren soll (deinstallieren mit löschen aller einstellungen hab ich gemacht) --> Immer noch "kommerzielle Nutzung" nach Neuinstallation und erneutem Zugriffsversuch. 

    Ausserdem steht hier:**Please do not post TeamViewer IDs** 

    "Außerdem sind Verbindungen auf Geräte, die als kommerziell markiert sind, nicht möglich. Dies gilt auch dann, wenn Ihr Gerät für den privaten Gebrauch zurückgesetzt wurde."

    -->  Habe ich einen Denkfehler ? Das würde ja bedeuten das ich von keinem Gerät auf dem versehentlich kommerzielle Nutzung festgestellt wurde, mehr auf meinen PC zugreifen kann, obwohl ich nur Privatnutzer bin ? Würde bedeuten ich müsste mir z.B. ein neues Handy kaufen um auf den PC zuzugreifen, weil das alte auf einer Blacklist steht ? Das kann doch nicht sein oder ?

    Viele Grüße


  • I tried reaching out to support but they havent gotten back to me. I dont know what to do to fix it. I didnt even set it up as a business account either.

  • -Lo-
    -Lo- Posts: 2

    I keep getting this statement when trying to use the app. I'm connecting to my home PC from my iPad. I have complained previously but no response coming back to me at all. Can anyone point me in the right direction. 

  • T8or
    T8or Posts: 1

    I am getting this too all of a sudden after years of free usage. It looks like TeamViewer is starting to charge their free users as a money grab scheme. If this doesn't get resolved, I'm going to look for another software

  • Bump

  • Bump

  • I submitted a form to have my computer reset more than 7 business days ago. I have yet to hear anything back by email. Is there a way to get someone to look into it and tell me how long I need to wait.  I use it on my home computer and my mobile. So your detection value is a little wonky. 

  • .-. why dont they respond

  • Have you found any? I'm having the same issue