Commercial use - Connection time out



  • anyone?
  • bazbsg
    bazbsg Posts: 112 ✭✭

    I hate to say it but if you read the 103 pages of this post you will see it's not likely that this problem will be fixed any time soon. It's been going on for years. Many people just gave up and moved to another product / service. I think that's what Teamviewer wants and just doesn't want to tell us. Sorry to say it.

  • Bonzadog
    Bonzadog Posts: 28 ✭✭
    I agree with you. TeamViewer will not change this policy so one is forced to find an alternative. Perhaps a much faster way of registering the ID's. I wonder which method TV uses to determine whether one is a commercial user.
  • maxh7
    maxh7 Posts: 1

    I installed the commercial version by mistake now I cannot access it I have already uninstalled it and even when I install it again it goes to the demo account [translated by Google]

  • Guido777
    Guido777 Posts: 1

    My TeamViewer account was flagged as commercial which is not true as I do not use TeamViewer in business or any form to get any revenue. Especially now due to Covid19 I remote between two personal computers in different Provinces in South Africa becuase we are not allowed to move cross border. 

    Now I cannot use it at all due to a mistake on the system

    Can TeamViewer support fix this Or?

  • Brandolf
    Brandolf Posts: 1

    For some reasons teamviewer decided that both of my computer which one of them is with my fiancee cannot be accessed. We are only using our computers and said that we are using it commercially how come? we only have 3 computers registered and this is the 2nd time this happens and i dont know who to contact or where to address this problem.

    thank you

  • I have the same issue for the first time.  I only use to access laptops inside my home and it says it has detected one of the 3 laptops is a work related laptop and I must buy an expensive licence

  • Dietmar3
    Dietmar3 Posts: 1

    I have the same problem. i phoned them and was told to request a account reset.. I'm still waiting for that to happen. Hopefully this year. I need to help my family.

  • I am trying another software. With TV every TOT time happens like this and then it takes a lot of time to unlock it. I'm starting to get tired. If I continue to feel comfortable with the new software, I abandon TV.

  • lyles43
    lyles43 Posts: 7 ✭✭

    "3.4. Scope of use for Free Version.

    The use of the Free Version is solely permitted for the Customer’s own, private, non-commercial purposes (e.g. free computer support for a spouse/partner). The use of the Free Version for the exercise of the Customer’s own trade or profession or the use for purposes for which the Customer directly or indirectly receives compensation (e.g. team work with colleagues, free support provided to third parties which have bought software of the Customer) does not qualify as private use."

    This speaks of the Customer's compensation, not the recipient's. If the Customer receives no compensation, directly or indirectly, helping someone else is a legitimate free use. 

  • Hello! Like I wrote here:
    I get a "Connection blocked after reaching the maximum time"
    I use team viewer to help my parents (we live 1000 km away!) and to do something on my home pc if I am away from home and forgot to do something.
    I use TV on my pcs: one desktop at my own, one notebook (office computer, but in this case used to connect for personal use) and sometimes from iphone or ipad.
    If it is blocked so suddenly, when I have to help my father, as happened today, I am not able.
    My father is old, if TV crashes unexpectedly, I prefer to know it and change software to avoid risking this possibility.
  • Thw0rted
    Thw0rted Posts: 14 ✭✭

    I think every so often, the TV Team needs to make another post in this thread instructing everybody to go back and carefully read the first page.  There are a couple of important points:

    • Individual computers are flagged as "commercial suspected", not accounts
    • There is a formal process to get the computer un-flagged, you fill out the form at , sign it, and submit.  This takes time.  (I've been waiting about a week for mine.)
    • There is no point in posting a story about how you use TeamViewer here in the forum.  The form includes a place to explain how you use TV, and why that use is not commercial.

    The last, and IMHO most important part: you are making demands about a free service that TV provides to you.  They have never made any money directly from me, though I do suggest TV to friends and colleagues pretty often, and maybe that led to commercial sales, which I'm sure is why the free version exists in the first place.  But I'm not paying them, so they don't owe me support.

    I would love if they provided a way for me to pay them a reasonable amount for the way that I use it -- maybe a $50-60 one-time purchase, or around $30/year for a "premium user" tier, just so I could expect a little bit of support from their team.  But that's not the model they chose to use, they only offer free/personal or paid/professional, and the latter is clearly targeted at businesses that would derive at least $30/mo or so worth of value from it.

    All that said, I came to this thread to see if other users are having success using the "reset management" link.  I filed my form about a week ago.  If anybody watching this thread has gotten their computer un-flagged, how long did it take?

  • Yershov
    Yershov Posts: 11 ✭✭

    BRAVO Team!


  • This has happened to me in the past, but it takes a while to unlock the account. Now that it happened again, I filled it in, but still no results. In the meantime, I am testing alternative software which seems to work pretty well. Since with TV it has already happened several times, I can't risk not being able to access my father's pc just because TV has woken up badly!
  • Hi, I have reported the false flag of commercial use (I only use for 2 elderly family members) but no response. There is nothing on the form page to follow up. How do I get action for non-responsiveness to this issue that has completely shut down my TeamViewer???

  • Ernest4
    Ernest4 Posts: 2 ✭✭

    Good day 

    Am trying to connect to a friend's PC and am getting "Commercial use detected" am only connecting for few seconds and kicked out. 

    This has been going on since last night, I tried uninstalling but it didnt work out

    Am using Teamviewer for personal use. Help!


  • RenéKe
    RenéKe Posts: 1

    Hello mocherif,

    As many developers do, you could implement location services to TeamViewer and TeamViewer QS to keep the application running in the background. 

    Kind regards,


  • sudburyKC
    sudburyKC Posts: 2 ✭✭

    @cubesmi I agee with you.  How can teamveiwer claim that they support ios when this limitation exists.  I cannot troubleshoot a device in 1 minute ( my use).  Which makes this feature unusable. Great concept but pull the app until you can make a workaround.  It should have never been released.. and the claim that support for ios is available should have never been claimed.  I am disappointed at the very least. 

  • mrersin
    mrersin Posts: 1


    When i open a meeting session sometimes it works for 8 hrs sometimes it's getting time out after 30 seconds. what is reason for this? All TW apps up to date. I cant find any solution. 

    App using  personally.

  • Ryan01
    Ryan01 Posts: 1

    It's up to the server to correlate the unique session identifier sent by the browser with your individual identity, context, settings, and preferences. This is usually stored in a database of some kind, keyed by your session identifier. For performance reasons, some chunk of session information also ends up in the server's memory; there's no need to reach all the way out to the database the next twenty-six times you obsessively refresh your Facebook profile page.

  • I have filled out the reset form and click the 'Generate PDF' button, repeatedly (and tried this whole process multiple times) but nothing happens when I press the button. Is there a problem with the form? If not, how do I proceed?

    Thanks for any help you can give :)

  • I got the similar issue yesterday. 

    I installed in on my personal machine. It is personal use. I think TeamView wants to get more money! Look like they want to sale license to personal use.

    I submit a ticket on line yesterday. However need to take 7 business days.

    However the lisence is too expersive. For personal use, if they want to sale lisence, the price should not more than 10 euro per month.

  • NeilCM
    NeilCM Posts: 1


    Today I have started getting a - Unable to connect - 
    Reason given is "You reached the maximum seesion duration to this treamviewer ID"

    Connection to this teamviewer ID will be blocked until ??:??

    The time keeps increasing.

    ANy Ideas? 

    I only use it for personal use.

    Thank You

  • Try to reactive my TV id.

    Nothing happened when I clicked 'Generate PDF' file.

  • I tried the form again and the Generate PDF worked!

  • I was classified as a business user by mistake. ? ?


  • Novice1994
    Novice1994 Posts: 1


    I'm new to TV and was running a remote session of TV Free with my elderly mother on the other end.  Both of our TVs were up to date, but the session kept timing out on us roughly every 10 minutes.  Can someone confirm if there is indeed a time limit?  My mother has a very slow connection, so perhaps that may be a cause as well.

    Thanks in advance!

  • Esther
    Esther Posts: 4,052 Former Community Manager

    Hi @Novice1994 ,

    Welcome to TeamViewer ?

    No, there is not such a time limit.

    I guess it is indeed more related to the internet connection as you mentioned.

    Best, Esther

    Former Community Manager

  • DanLopz
    DanLopz Posts: 1

    Today you just decide that my account is commercial but I only use it to control my notebook from my desktop PC.
    Thank you, guys. I already discovered new tools with great features thanks to that.

  • GonzoB
    GonzoB Posts: 1

    Looks like I'm in the same boat as a bunch of people here. I don't know why it's deteted "Commercial" use and how they judge it and no I didn't select personal & commercial use, I only selected personal. I'm not even employed right now, there's absolutley no way I can use it for commercial use. I don't even use it in to connect from an outside IP - I just like it better than windows RDP.

    Has anybody made this go away successfully? It sounds like any attempts to contact customer support doesn't go very well.