Commercial use - Connection time out



  • jonpb
    jonpb Posts: 1

    I just submitted a signed PDF to get my Teamviewer ID's reactivated.

    Let's see what happens in the next 2 days otherwise I may need to find another solution. Personally I find the whole ordeal annoying and insulting. Just becaue I own more than 1 computer at home doesn't automatically mean it's commercial use.

  • JumpingJack
    JumpingJack Posts: 1

    Hi. On local PC I get message at session start telling me remote version needs updating. So I connect intending to update, but "Check new version" says remote is already at latest version. Then after 5 mins session times out.

  • jniska
    jniska Posts: 1

    anyone ?

  • ejpankowski
    ejpankowski Posts: 2 ✭✭

    One of my PC is now qualified as a pro conenction when I'm attempting to connect on it with TV 15.

    This PC is in my personal perimeter and I do not understand why it has been qualified this way (may be I have forgottent to cancel a connection that was lasting long).

    How can I turn back this PC Id in my equipments ?

    Thanks @TeamViewer 

  • jjw813
    jjw813 Posts: 1

    For seven times, now, five of them in a row, I keep trying to use Teamviewer in non-commercial license mode, but every time I try to use it, I get the message "Commercial Use Detected". I appeal it, and have successfully appealed it every single time but nonetheless, as I said, every time I try to use it, I get the message "Commercial Use Detected".

    The only thing that's changed recently is that I uninstalled OpenSuse 15.2 on one machine, and installed Ubuntu (desktop) 20.02.1, and I installed Apache Server 2, but as I've explained to TV tech support, I installed it so I could learn how to use it, for my own self-education purposes. I am not hosting any commercial websites on it, only a non-profit group's site as a backup server, and probably later on, putting my own personal website, and the website of my very retired scientist father; remember, I've successfully appealed "Commercial Use Detected" every single time, so having the Apache Webserver software can't possibly be the issue.

    Furthermore, it doesn't matter which computer I try and remote access, they all trigger the same reaction: "Commercial Use Detected". Anyone know why this keeps happening? Is the company trying to force me to pony up for a license by making this happen over and over again?


    John Weintraub



  • Sunstead
    Sunstead Posts: 1

    I would like to know if anyone has been successfully unblocked as well.  I have been trying for two months to get my free version reactivated.  I have yet to hear from TeamViewer at all.  I have filled out and submitted forms.  The last one said I should hear from them in two days.  That was a week ago.  My niece has been helping me with stuff on my computer but now she can't get it and I can't get any help.

    I used to recommend TeamViewer and praise them but that will no longer happen.  I feel like they don't care about any of their free customers.

  • gustinn2
    gustinn2 Posts: 40 ✭✭


    I have been in this problem now for over a month, people here have been trying to help but nothing has happend in fact. Like you i have been so happy for over 6 years with teamviewer software and the service and always had good words over the staff and thanked for all.

    Its so sad when they seem to not be able to open up, they send e mail they accept after undersigned document from me and say they accept my private use of teamviewer but still i cant get connect to remote computer for only one minute at each time and message about i use it for commercial use.  I Really am hoping all can be good again and i can be able to use it again. And i want to thank all from staff that have tried helping me.

    Just dont understand why it is so difficult, i mean if anything is needed they have to tell people it direct so it can be fixed. Hope the best for you, hope we all get help here.

    with best regards

  • Ben_TL
    Ben_TL Posts: 1

    I am using the free version on a remote PC running Vista. When I attempt to connect I get a notification that the remote computer needs to be updated to the latest version of TeamViewer. When I attempt to update TeamViewer on the remote machine it tells me it is running the most recent version. I could deal with the notifications except it also times out after 5 minutes which is a pain. Any help would be appreciated.

  • PhillMorris
    PhillMorris Posts: 1

    I have the pop-up message saying that TeamViewer suspects me as 'commercial user'.
    I am most definitely not a commercial user (I mostly only access my brothers PC to help him - we are both retired - he is 73 years old !)

    I have filled in the details to have my account reset via  (I did this 8 day’s back) but I have heard nothing at all from TeamViewer (not even an acknowledgement).

    As I have followed the reset request process on the TeamViewer website (, but nothing has happened, can you advise what I can now do to get it reset?

    Many thanks.

    Phill (in the UK)

  • Oferu
    Oferu Posts: 1

    I had the same problem, even though I had the latest version installed on my computer sessions were limited for a duration of 5 minutes.

    Check if your partner's computer has the same (latest) version, it solved the problem for me. 


  • SalmanZ01
    SalmanZ01 Posts: 5 ✭✭

    I used to work with Teamviewer at home for personal use.
    Recently, after connecting my computer, I can't keep my remote connections active, while I only use it for personal use.
    Is there a "declaration of private use" form? that I can submit online?

  • FormerMazda
    FormerMazda Posts: 1

    Yes, I do realize that this most certainly is already a topic, but it seems like TeamViewer won´t recognize it. So the more we post it, the higher the chance that it gets fixed.

    This is my second or third time I've been flagged as commercial user, although I´m not. And this time I haven´t really used it for a long time and suddenly flagged again.
    Is there a way to keep using it as private without this hassle? 

    I am seriusly considering changeing program for this. Since I can´t really use it..

  • ChrisThornhill
    ChrisThornhill Posts: 2 ✭✭

    Same problem - I have elderly parents on both sides of the family I do remote IT support for and thanks to this stupid problem I cant. As if there isnt enough stress and drama in the world at the moment, the **bleep** clowns at Team Viewer think its a smart idea to try and force people into commercial licenses. I am happy to pay for quality systems with organisations that are respectful of their user community - as it stands I wouldnt recommend TeamViewer to ANYONE.  Guess what TeamViewer - you aint the only show in town -  [removed per Community Guidelines]

  • Jessie4869
    Jessie4869 Posts: 1

    I was using the free version all the time since last year. I'm a PhD student and connected to the computer in my office to do the research and never used TeamViewer on commercial activities. Today I couldn't do the connection and it said commercial detected. How could I fix it? Thanks.

  • fsaintl
    fsaintl Posts: 1

    Good luck getting this resolved.  I've been dealing with tghis for almost a year. They sent an email message saying my account had been fixed and set to Private Use, but it still doesn't work.  Now when I connect, it still tells me commercial use detected, then tells me I cannot connect until a certain time, and that time is always 1 minute in the future.  

    I'm becoming convinved that TeamViewer Free Use support is actually an advertising campaign for **Third Party Product**. 



  • Veinbergs
    Veinbergs Posts: 1

    I have tryed to sor out my daughter's laptop and teamviewer blocked me as comercial use has been detected? Is this an Joke?

  • vtello
    vtello Posts: 1

    Seems like there was an updated on 9/17/20 to version 15 and all of a sudden today I cannot get in to my remote desktop. I have been using this for personal use (free use) for over 1 year. Today I had multiple error messages:

    - Too many logins, blocked.

    - Must upgrade license in order to access.

    - Partner does not have TeamViewer running.

    I got in 2 times, but then was kicked out after 3 minutes each. I submitted a request today to state I am not using for commercial use, but I never got a message about this, so I don't know if this will fix the issue. I have been having a hard time trying to even submit this message for help, which I hope someone sees here.

    I need to get access back to my remote desktop. I am NOT using TeamViewer for commercial use and I still want to use the free personal use license. Please help!

  • kellygeefx
    kellygeefx Posts: 1

    They do that sometimes just randomly. The error cannot be corrected. I have 10 computers that are mining rigs and currently getting the same message. Will have to have multiple accounts to deal with the issue. They need to start checking IP addresses to figure out commercial uses. Dumb engineers...

  • zack8691
    zack8691 Posts: 1

    I have submitted the form to re-activate my account multiple times but am not receiving a response even after a month. I believe the issue is that I logged into my personal media server from my company provided laptop just because it's what I had in front of me. I didn't realize it would mess with my free account and will not do that again. Can soeone please help get my account re-enabled?

  • morph1
    morph1 Posts: 1

    same thing happened to me today, what is going on with the software ???

  • tbird888
    tbird888 Posts: 1

    The same just happened to me. I have been through this once before because they thought my VPN was a commercial VPN (it isn't). Now the only thing I can think of is I moved a piece of software I built on my personal machine, for my personal machines through their file share. I have never used that process before so I have no idea if that's a red flag for them or not.

  • crazyserb
    crazyserb Posts: 1

    They either have extremely **bleep** engineers who cannot figure out how to ACTUALLY detect proper commercial activity and are flagging anyone and everyone with Free account as false-positive commercial activity... OR it's an order from the top to make the Free accounts' lives miserable by flagging them all with this commercial activity **bleep** in an effort to get them to pay up and subscribe to paid plans.

    It's annoying as **bleep** either way you look at it, and extremely disappointing that we have to submit a stupid form with all the IDs to whitelist and reset our account, wait a week or so for an actual human to look at it and approve it, only to be flagged again the minute we try and establish a connection to one of our machines, and rinse and repeat the process.

    If anything this dumb decision making on their part is just driving people away from their software onto alternatives and competing companies... ugh.

  • WCruickshank
    WCruickshank Posts: 1

    I also have the same issue of Teamviewer disconnecting after 5 minutes. Like others, this started with the latest version of teamviewer.  I tried to follow the message stating, the remote version of teamview is out of date and need to be updated. I followed the prompt click on Action -> Remote update. The remote says, Your version of teamviewer is up-to-date. There is no new version of teamviewer, then disconnects after 5 minutes. 
    This is not an isolated incident. 5 minutes is not enought time to get most support completed.   I would not mind getting a license to avoid issue when I really need it.  BUT, I cannot justify paying $49/mnt continuously for software I used about once  a month when my parents need some support. This is not commercial use. 

  • FroZz
    FroZz Posts: 1

    Hello, I have an iPhone , my Tim Viewer when connected to a PC tells me that I use for commercial purposes, but this is not true, only personal use, what to do? The ID doesn't change when i reinstall it on my iphone, how do I change the ID?
    my ID IOS Team Viewer: **Please Do Not Post IDs**

  • romdawg
    romdawg Posts: 1

    I've only used teamviewer between my 2 desktops for personal stuff for years. I suddenly started getting the "Commecial Use Detected" pop-up which ends my sessions within 30secs.  I've sent the self-declaration of private use PDF to teamviewer and they told me in an email that my TeamViewer ID's have been successfully reset.  However I'm still getting the "commercial use detected" pop-up.  How do I fix this problem?


  • Hex50
    Hex50 Posts: 1

    I have been using the free version for years today i have been blocked on my IPAD.  I use it to just monitor my desktop i hav e running in my basement with software that can only run there (investment platforms).  I access it from my home wireless network from a different floor.  It's not being used as commercial ...what gives?

  • JamesHall937
    JamesHall937 Posts: 2 ✭✭

    They flagged me as well, I created a post but nothing from support yet. I have used TV for years for personal use, remoting to my laptop from my desktop so I can just leave it up on one monitor kind of thing. 

    really makes no sense.

  • JamesHall937
    JamesHall937 Posts: 2 ✭✭

    Where does one find this PDF, and how did you send it to them? Via email?

  • JonnyGators
    JonnyGators Posts: 2 ✭✭

    I use teamviewer for personal use only on several devices.  I use a lot of devices, I change a lot of devices, I do OS reinstalls frequently.  I don't know what triggered this, but my personal use has been completely blocked due to false detection.  I have done nothing wrong, and have kept to the license agreement - to completely block my access without review or verification is completely unfair and unprofessional!

    This has completely thrown a wrench into my personal use.  Perhaps this isn't my livlihood or costing me financially due to it being personal use, but that doesn't make this any less important to me!

    The company I work for does use teamviewer commercially, but that is completely separate, and I have taken every effort to make sure those uses are completely separate.  My corporate login is only used on company equipment, and I only ever use company equipment with my company login to conduct work.  My personal account is only used on personal equipment.  The two enivornments stay completely separated.  I do not know if this has played a role, but I welcome any review of my equipment to verify that my personal account is strictly for personal use.

    However, I've found no way to resolve this situation.  I've submitted a form, but there is no response on it.  I call ,but there is no option for help for personal accounts.  I went through to pay support, they refused to talk to me and told me I have to wait weeks for review.  

    To completely cut my support for unfounded accusations and make me go to the effort to submit a form and wait with all use completely restricted for a service I've come to rely on for my home personal use is completely unfair and unreasonable!

    Can anyone recommend methods to quickly resolve this issue?