link icon
Ask The Community

Commercial use - Connection time out



  • KGUD-Production
    KGUD-Production Posts: 3 ✭✭

    We use Teamviewer so 2 of the 3 volunteers at a small radio station can do the content programming for the station.  I, the IT guy for the station, also use it for system support.  We are extremely hampered by this problem:

    Teamviewer has been working for some time and the configuration (below) has not changed.   We are getting the "upgrade to current" message even though we are as current as out platform allows but we are still enduring the 5 minute session timeout "motivator".  Today, our primary user was *successfully connected*, then he had the session time out, and when tried to immediately reconnect but now gets "unable to connect (unknown reason)".

    None of the other devices I use to connect are successful either with slightly different wording.

    I rebooted the remote system and checked for internet capability.  Teamviewer does not work for me with the same kinds of messages.  It doesn't work even when I am on the same wifi subnet as the remote machine.

    The one computer that the 2 volunteers remotely connect to is a Windows XP system.  Recall that I said it was working through a session earlier today.  We get the "you must upgrade to the current version" (for our platform) and we get the message that "your version of Teamviewer is the most current" -- so there is no newer version (for Windows XP).

    The clients that fail are Mac, a Windows 7 PC, 2 different Android tablets, and an Android smartphone.

  • breese
    breese Posts: 4

    Really? In the middle of this virus???Really? In the middle of this virus???


    Still happening!!

    I have been using this application to support family members for years and now in the middle of this Virus this starts happening?


  • A number of days ago I went to do some updates to my home PCs and started getting the commercial use message, causing my connection to abort after a minute of use.  10-15 connections later I was finally able to finish the updates.  I then filled out the 'usage reset' form to have the commercial flag cleared, which was successful.   2 days later I attempted to connect to my PC again and received a Connection Blocked "Your connection has been blocked because of very high activity level" response.  2 days after that message first appeared (with obviously no usage, since TV won't let me connect) I'm trying to connect again and still getting the same error.

    I filled out the 'commercial reset' form after the first occurrence, just in case, to no avail.  (I've received the reset confirmation email both times I submitted the reset PDF)

    I've logged in to the web UI and cleared out all listed sessions (prompting my computer to log back in), as well as cleared all trusts, except for the system I'm trying to connect to.  The issue still exists.

    Has anyone else ran into this, and does anyone know how to clear this (or connect to an actual support rep that can)?

  • Hi Esther,

    I use TV exclusively to help my 89 year old Dad in Poland, about twice a week. After getting the "commercial use suspected" message I diligently followed the support instructions and completed the Declaration of Private Use form. It was submitted a whole month ago and there has been absolutely no response from support since. I've trawled the knowledge base and community posts for means of contacting support by phone but this seems impossible for users of the free version of TV so what else can I do to get a response from support to my submission please?

    The case number for my submission is TV:**Please do not post TeamViewer IDs** in case that helps to get it moved forward.

    Your help or advice would  be greatly appreciated as in these Covid times my Dad is extremely isolated without my ability to help him remotely.

    Thanks and warmest regards.

    Dr George Zolkiewski CEng, FIMechE

  • IrvSp
    IrvSp Posts: 7

    @George1957 wrote:

    After getting the "commercial use suspected" message I diligently followed the support instructions and completed the Declaration of Private Use form.

    Well, I did too, first the ON-LINE RESET and then the FORM. Both came back as RESET, but I still can't use it...

    Something else is happening here to stop us I suspect?

  • IrvSp
    IrvSp Posts: 7

    @MikeyGee wrote:

    Go here and plead your case...

    WASTE of time! I did both the form and on-line reset request. Today I got the last one back. Both said my ID was RESET. After each reply of a RESET I tried using TV. Failed with the same error message each time.

    They either can't reset it, there is something else in the TV network stopping it, or there are other steps I must take to make it work.

    Looking for other free alternative and did find one that seems it could be used. Still, I don't understand why TV doesn't work after a RESET they claim they did?

  • IrvSp
    IrvSp Posts: 7


    I saw in e-mail a post to me was made. Can't access it, they are 'censoring' this thread I guess.

    [removed per Community Guidelines]

  • stk1987
    stk1987 Posts: 1

    Hello, I have a problem with one of my PC's using TeamViewer Free. Its a win 10 Enterprise and i cant really use it for long because it sees it as a commercial PC but it is not. The PC is my personal computer. The pc came with enterprise installed. How can i fix this with out changing the windows addition?

  • rsaybe
    rsaybe Posts: 1

    Hello, it looks like my situation is quite common with this remote application. I never realized this untill I saw the many other posts. Also seems like many of the free users are not receiving resolutions in a timely manner.

    In any event, I have also fallen victum of this. I'm not able to log onto my personal home computer anymore using teamviewer. I have a few computers at home belonging to several of our family members. My children and spouse including mine.

    Using teamviewer to log onto our personal home computers have been helpful. Up untill yesterday, one of my computers is not allowing me to log onto that device using team viewer. I keep recieving the following error message;

    "It seems there might be a licensing problem with your connection partner. Connecting to this device requires a valid Teamviewer license for your connection partner".

    This device that I'm connecting to is not a commercially used computer but rather our personal home computer. Not sure why the system would detect this as such and inadvertantly flag our system as being anything other than personal home use.

    Nonetheless, I would appreciatte any assitance towards having this resloved. It seems as if the device I'm unable to connect to now has been blacklisted or disabled by teamviewer. So it seems.

    There are many other free option alternatives out there however I have used this application for some time now and enjoyed the ease of use it has offered in terms of being able to remotly connect to our personal home computers and or transfer random files as necessary.

    Hope to hear back from some support personal that can further assist me with this stituation. Thanks again in advance.


  • Josette
    Josette Posts: 15

    After being censored for offering suggestions for other software out there, I managed to get a MOD in PM. I passed on how I, like all of us, have:

    1. Suddenly been told that I am using TM commecialy.

    2. Told that I have been flagged for hours, so I must be using TM commercially.

    3. Filled out their form to reset.

    4. Included all my I.D.s.

    5. Received a confirmation email that I am using TV for personal use and that my I.D. have been reset.

    6. Three seconds later go to TV and received the same Commercial Use messge.

    After five days of back and forth, and reitterating that I already told her that I did what she suggested, I received this below. We are all on our own. TV is a thing of the past and we all need to use other software. They don't want or care about us.

    "Hi Josette,

    I understand your frustration and I am sorry for any inconvenience.

    The forms are the only route we can offer you as we do not have any access to unblock you. It can only be done by a specific team who only responds to those forms.
    There is no alternate contact method for this issue.

    However, please note that you need to make sure you submit all relevant ID's as if you only submit one and the other device is detected, even if one is unblocked, connections to another blocked device is not possible.

    You need to make sure you submit all ID's:
    This is the best advice we can provide.

    I am sorry but I cannot discuss such a case in a private message. If you have any other questions, please feel free to post in the community so you can get ideas from users.

    Best regards,



  • I  use my free account to watch my son in remote learning since he has learned how to not focus on virtual learning due to distraction on the PC.  I got a pop up that said I am using the account commercially and it auto enrolled me to a commercial account.  The account is stuck saying thank you for upgrading.  I am not using my free account commercially.  How can I regain access to my free account and reverse the payment

  • Yes, indeed. It's an unashamed attempt to move us all to paid licenses, otherwise they'd have taken notice of the hundreds of clearly personal users who have posted about this issue :-(

  • Josette
    Josette Posts: 15

    Hooray! Your lovely reply has made mine.

  • waco_john
    waco_john Posts: 9 ✭✭

    Same here.  Filled out the declaration and signed it and emailed it back.  Not a word since.

  • jonathanhiron
    jonathanhiron Posts: 2 ✭✭

    I am having the same issue and the won't allow me to generate the PDF to complete the form. I have tried IE11, Edge, FireFox and Chrome to no avail.   

    Not sure what to do to complete the reset form and appreciate any guidance.  I would like to submit my case for an account reset but so far am unable to.

    All support greatly appreciated.

  • jonathanhiron
    jonathanhiron Posts: 2 ✭✭

    I forgot to mention that on the reset form it doesn't allow me to enter my full teamviewer ID.  My ID is 13 characters and it only allows me to enter 12.  I have tried logging in with just the 12 characters and that fails.  I can only log in with my 13 character ID but the reset form only allows 12.

    As well, I may have forgotten to mention the other problem with the form is that it won't generate a PDF.  As indicated, have tried various browsers to no avail.  

    So I have 2 issues with the reset form.  

    1) not being able to enter my 13 character teamviewer ID

    2) not being able to generate the PDF so that I may upload it in the next step

    Appreciate all advice on how to successfully submit my reset form.

  • Josette
    Josette Posts: 15

    Unfortunately, even when you send them the PDF and they email back that your IDs have been reset, it still doesn't work. They are really resetting anything. I've done it 8 times and it makes no difference. They also are not responding on the boards or answering the phone.

  • I have a free version and I suddenly changed from free to commercial use.  I help family remotely in their homes - no charge, so I am not commercial.  I have not installed the Win 10 20H October update.  Rebootint both systems did not resolve the problem.

  • I am using teamviewer from Starbucks internet and connecting to my home computer. I am only using it for personal use but it keeps terminating my session and doesn't let me log in. I am not using it for commercial only for my personal use. Please help on how I can fix this.

  • waco_john
    waco_john Posts: 9 ✭✭

    I did and I love it.  I'm ust trying to get TV to 'do the right thing'.  They have gone completely bonkers.

  • TeamViewer works great so I can check my home pc but all of a sudden  it some how thinks I'm using it commercially and kills connection after 5 minutes kinda annoying is there a fix for this?

  • I'm unable to fill out a second reset request form after having the first one approved. It displays this message:

    "Your request has already been submitted and is pending further review. Thank you for your patience as we process your request."

    I'm using the instructions I received in my first request's approval, which say we can do this if another personal computer is incorrectly detected as commercial:

    "repeat the process and fill out an additional form for this/these TeamViewer ID(s)"

  • Josette
    Josette Posts: 15

    Unfortunately, it doesn't matter how many times you send in the reset form. It still doesn't work. I did it 6 times to no avail. There are thousands of us who aren't getting any support with this problem. It looks like they have discontinued the Free Version and haven't bothered to tell us.

  • Josette
    Josette Posts: 15

    Support will not respond. They have done this to every one of us on the Free Version. It looks like they discontinued the Free Version and didn't bother to take a moment to inform everyone. Instead they have us on a hamster wheel continuously submitting reset forms that never do anything.   

  • waco_john
    waco_john Posts: 9 ✭✭

    @Josette wrote:

    Support will not respond. They have done this to every used of the Free Version. It looks like they discontinued the Free Version and didn't bother to take a moment to inform everyone. Instead they have us on a hamster wheel continuously submitting reset forms that never do anything.   

    yep.  time to google Teamviewer Review and let everyon know

  • Josette
    Josette Posts: 15

    YES and on Twitter @TeamViewer and @TeamViewer_help.

  • I updated one of my computers to the Win 10 20H2 version two days ago, and not when I tried to connect to that computer I'm given a pop-up of suspected commercial use and am limited to only a 5 min connection with no re-connect possible. ??? Nothing else has changed. I previously had a Business account, and I'm wondering if my free account via another email is being linked to my former account that was closed this Summer (at least, as far as I know! That account was paid for by a non-profit that I supported for about three years until they got a grant to hire an internal, local IT person.)

  • I'm not going to get into it again here.  There is a thread with 5400+ posts already about this topic. I'm just posting this to say it's pretty lousy that 5400+ posts later this is STILL HAPPENING.  

    I'm done with teamviewer.  You guys can continue to ignore the forms I sent in 2 weeks ago if you like, I've deleted the software and moved on.  I would like to point out that this is one of the worst "customer service" experiences I've had with a software company though, and will make sure everyone I talk to knows it.

  • MarkThomas
    MarkThomas Posts: 2 ✭✭

    The form at
    IS NOT WORKING.. I have tried Firefox, Chrome and IE, and none of them will "Generate the PDF you have to Generate, in order to upload your request to have your "Commercial Use" evaluated..

    I am not a Commercial user.. I only access PC's on my own local Private At Home Network...
    But, I can not submit the form, because, the "Generate PDF" to upload is not working...
    I would like to Prove I am not a commercial user and continue to use the "Personal Version" , and continue to recommend Team Viewer to anyone I meet who uses programs like this...

  • JoshP
    JoshP Posts: 844 Senior Moderator

    Hello @MarkThomas 

    Thanks for your post.

    I was unable to replicate any issue with the Generate PDF button - once all requested info was entered, the button responded and proceeded to the next page, to download and re-upload the PDF. This was done in Firefox, as well as Chrome.

    Please verify the boxes in the form, make sure there is no error shown, and try again. If there is an issue with the data entered, the error should appear right below the text box containing the error.

    Josh P.
    Senior Community Moderator


    Did my response answer your question? Help out others and select it as the Accepted Answer