Commercial use - Connection time out



  • ashokj
    ashokj Posts: 1

    I am having the same problems but I see no solutions on the forum.

    If there is a solution please guide me to it.

    I am purely using it for personal use only

  • GeneB
    GeneB Posts: 1
    edited February 2021

    My connection has been blocked because of high activity level. Why? What's the limit on activity. I have the free version and do not use it commercially. I help Seniors for free. Sometimes it takes a long time or many times to help them. How many people am I allowed to help? How often? How long?

  • garycase
    garycase Posts: 7 ✭✭

    Nice to know I'm not alone, but nevertheless this is really frustrating. I haven't been able to help my friends and family in nearly 6 months because of this issue -- it's NOT the "commercial use detected" issue; it's just an automatic time-out in less than a minute with no indication of why this is happening except the "time out" message.

    And Teamviewer is of no help -- I submitted a ticket describing this is early January; and when I checked the status last week it simply showed "this ticket has been closed"... but no action was taken and the issue hasn't gone away.

    Anyone know of a good alternative for this?

  • Captain_Haddock

    I don't know if anyone posted this link or not. may be it will help to someone.

  • mike1262
    mike1262 Posts: 0

    I can not connect to one of my family members computers and I used to be able to. I connect but only for about 30 seconds and then it tines out. If I try to reconnect I get a message


  • Kristo123
    Kristo123 Posts: 1

    I'm in the same boat, and they said the reset it in October, i tried to use it recently and it doesn't work

  • beck2ham
    beck2ham Posts: 1
    edited February 2021


    I started using Teamviewer to be able to play an afk game on my home laptop from my work laptop. My usual daily workflow would go like this:

    1. Reach office; log into the home laptop from work laptop using teamviewer; save the game to game server from home laptop; close the teamviewer remote session with home laptop; open game on work laptop.
    2. Before leaving office, save the game to game server from work laptop; close the game on work laptop; log into home laptop from work laptop; load the game progress on home laptop from game server; close the teamviewer remote session; shutdown work laptop.
    3. I also installed the teamviewer app on my mobile so as to be able to interact with the game running in my home laptop during the commute time between my home and my workplace.

    I could maintain this workflow for like 3-4 days after which my sessions with my home laptop started being disconnected with the message "Your Teamviewer session has timed out and will be closed".

    Going through the post titled "Thank you for playing fair" by Esther, I realized that:

    1. this constituted commercial use since the session is between a work computer and a home computer and hence, teamviewer might be closing my sessions abruptly
    2. that this, however, also constitutes a private use since it is purely for self-use for accessing game on my home laptop.

    So I wanted to report this as a false positive on the "Reset Management" webpage and be able to resume using Teamviewer. However, in this regard, I have the following questions:

    1. Even if I get the IDs reset for my work and my home laptops, would my workflow again be detected as commercial use (given that the workflow entails session initiation from my work laptop)?
    2. Accessing the home laptop from my workplace from my private mobile's teamviewer app, using my private cellular connection mobile data, won't constitute commercial usage, right?
    3. My mobile's teamviewer app doesn't display any ID. So how can I get the restriction lifted from my mobile's teamviewer app? If the restriction is lifted from my mobile, I may be able to access the home laptop at least from my mobile, using my private cellular connection mobile data.
    4. if using my mobile's teamviewer app from workplace using my private cellular connection mobile date would constitute commercial usage, any suggestions on how I can access my home laptop while at work?

  • bemcbee
    bemcbee Posts: 0

    I use TV to connect with 4 different friends/relatives, one particular PC drops the connection almost immediately, saying session has timed out and connection will be terminated. What can cause only one PC to have this problem. The same problem and same PC happened recently.

  • littlegw23
    littlegw23 Posts: 0

    I used my personal computer via a corporate TV account but I know longer provide support with that company anymore. I think my TV session still thinks i am a commercial user. I just want to be able to manage my home computer with my remote laptop. I now work out of town. Non commercial use. What do i need to do to make this happen? Is there a regedit that needs tweaking.

  • allenm28
    allenm28 Posts: 1

    How do I get the Declaration of personal Use document and where do I submit it?

  • angeltechguy

    block after connecting remotely why

  • mstanzak
    mstanzak Posts: 0

  • GDeuel49
    GDeuel49 Posts: 2 ✭✭

    Same problem here. For several years I have helped support 3 senior citizen friends with their Windows PCs. Like many others have reported, my session times out in 1 minute or less.

  • ahswp
    ahswp Posts: 4 ✭✭

    My teamviewer times out after 1 minute and then does not let me log back in for another minute. When I try to log back in, it tells me I have to wait another minute. I can't get back in.

    I've tried uninstalling and reinstalling. Any suggestions?

  • AlanArmstrong

    I have a free license and use it to occasionally help an older friend with her computer issues. I also use TV to connect to my home desktop when out of the house so can check emails and such.

    I had not used TV for a while and recently had to log onto my friends computer to help her with an problem. Got logged in OK, but after only about a minute, connection terminated and when tried to log back on received following dialog:

    "Your license limits the maximum session duration to a partner, immediate reconnections are blocked. Please try later..."

    I was only in session for less than a minute... So, waited for timeout and tried again, only to have the same thing happen. I do not understand what is happening. TV was working fine the last time I used it (several months ago). FYI: I do have an account and was logged in to it.


  • inspectorG4dget


    I am pretty much the only technical person in the family, and use my TeamViewer account to tech support everyone (including many of my friends). I think that this has been detected as commercial use (as I have more than 3 contacts), even though I am not at all a commercial user.

    So now, any connection attempt terminates in one minute with a message saying that I should try again in [one minute. When I retry after a minute (usually after more than just one minute), I get the same message and am unable to log into the remote computer.

    I'd appreciate some help with this since I am unable to provide tech support for my family and friends

    Thank you

  • RHaggard
    RHaggard Posts: 0

    I sporadically use the free version of TeamViewer. Lately, any attempt to use it results in a short connection followed by a disconnect and a message box saying "Unable to connect" "Connection blocked after timeout. You license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license."

    Is this normal? If not, any idea why connections are being blocked?

  • unnikrishnanbm

    Hi I use the latest TeamViewer version on Mac big sur, facing difficulties for three days with my sessions ending abruptly (for multiple partners) with the message Your session timed out, maximum time with partner. Thanks in advance

  • ahswp
    ahswp Posts: 4 ✭✭

    My teamviewer on my PC keeps timing out after 1 minute and then won't let me log back in. I have tried to uninstall and reinstall and it does not fix the problem. Any suggestions?

  • spassman001
    spassman001 Posts: 1

    I have the same issue. I think maybe I have been flagged for commercial use, so I started the process to ensure I am unblocked if that is the case. If you find out what the issue is, let me know!

  • ahswp
    ahswp Posts: 4 ✭✭

    I dont think this is right. My account was flagged and I had it removed. I even tried setting up a second account and the same thing happens the first time i used it.

  • EMCD14
    EMCD14 Posts: 1
    edited February 2021

    I use the free version on a MacAir running BigSur. I use the program to control my 86 year old mother's computer when she has problems. I have never had any issues until recently. Yesterday, 2-14-21 I tried to connect and was notified that the program thought I was a commercial user. I used the FAQ for the problem and reset my password, etc. I was able to connect to her Windows machine but only for about a minute, and then it would lock me out.

    I tried again today with the same results. Connected, then booted, then blocked.

    Please help.

    Thank you,


    [The personal info has been removed as per the community guidelines.]

  • ahswp
    ahswp Posts: 4 ✭✭

    My teamviewer on my PC keeps timing out after 1 minute and then won't let me log back in. I have tried to uninstall and reinstall and it does not fix the problem. Any suggestions?

  • randyre
    randyre Posts: 0

    look back at this thread, this has been going on for months and months. Reeks of the whole Photobucket fiasco.

  • sassriverrat

    Good Afternoon,

    Seemingly randomly, I'm getting some new errors from Teamviewer on my PC that I've not had before.

    "Connection blocked after timeout.

    Your license limited the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license.

    Connections to this partner will be blocked until 12:18"

    This has just started happening on my personal laptop, trying to connect back to my home desktop (well a VM in the desktop). I've uninstalled and re-installed teamviewer on the laptop to no avail. I am currently connected on a friend's wifi (residential). I can connect back to the vm at home without issue through my phone....


  • Arnor
    Arnor Posts: 0

    I'm getting this message when I connect to a remote computer (well, it's sitting next to my desk, just testing)

    It then times out after about 60 seconds with:

    I use TeamViewer once in a while when my other remote software doesn't work for some reason. TV is too expensive for me to purchase so I have used the free version for years.

    I don't know if I should try to uninstall it on this computer or if this is now the norm for Teamviewer - free is only 60 seconds...

  • Rayvn72
    Rayvn72 Posts: 1

    I have two personal computers that I used to connect to with my work business account. They no longer use Teamviewer so I created a free account to access my personal computer. But now since it was a connected to by a business account it won't allow me to connect with my personal account. It is requiring a license/ invoice be paid before accessing. How do i disassociate a personal non domain computer so that i can access it with my free account? More information available if needed. Thanks in advance.

  • Loko
    Loko Posts: 0

    I'm also using the free version, but TV thinks I'm using it for commercial use. I literally only use it 3 or 4 times per year to help my mom. How can a free user contact tech support?

  • Loko
    Loko Posts: 0

    Try emailing Perhaps that will get you somewhere. You could also try their LinkedIn:

  • Bob_69
    Bob_69 Posts: 0

    Why do my remote support sessions time out after only a few seconds?