link icon
Ask The Community

Commercial use - Connection time out



  • aznric3boi
    aznric3boi Posts: 0 Newbie

    What part of the app is triggering this timeout? There isn't any explainations.

  • Icemat
    Icemat Posts: 1 Newbie

    And how you solve it

  • GodzillA
    GodzillA Posts: 1
    edited March 2021

    I dont use TeamViewer for commercial

  • St3v3C
    St3v3C Posts: 0

    I have the same problem. My home computer is 1000km away from my travel laptop. I don't do any commercial use. The remote times out in 1 minute. I only use TeamViewer to access files on my own computer. I don't get a "commercial use" message on either computer. The remote just times out. TeamViewer team PLEASE HELP!

  • Heebs
    Heebs Posts: 2 ✭✭
    edited March 2021

    Having exact same issue here - If anone gets solution let us know

    In the meantime I will play around with **Information removed as per Community Guidelines** and see if that does what I need

  • ab56128
    ab56128 Posts: 2 ✭✭

    I dont know if I have resolved it, but i opened this webpage:

    You have to make a pdf, where you state that you do not use the program comercially, and the you must sign that and upload it. And they will contact you within 2 work days. So I hope I solved it :-)


  • PDL4404
    PDL4404 Posts: 0 Newbie

    Having the same issue. I have not used the app for a couple of weeks sue to this problem. Is there a way to correct?

  • Jeremy_W
    Jeremy_W Posts: 0 Newbie

    This must surely be a technical issue - any hope of an answer on this from support?

  • Jeremy_W
    Jeremy_W Posts: 0 Newbie

    This must surely be a technical issue - any hope of an answer on this from support?

  • spruceymaine
    spruceymaine Posts: 0 Newbie

    I'm also having this problem. I use team viewer from two computers in my house to connect to another computer in my house which is hard to access directly. Interestingly, the timeout problem seems to only happen when connecting to 'computer #3' from 'computer #1'. 'Computer #2' doesn't seem to time out. The only difference is that 'computer #2' is logged on under a local windows account than #2 and #3. I checked the settings on the remote computer where the management sessions are timing out and it's set to not timeout. I'm not receiving any indications that TV thinks I'm using this for commercial purposes.

    I've been using TV personal for several years and this problem just started a few weeks ago. It's a great product, but not currently useable for my purposes. Help?

  • spruceymaine
    spruceymaine Posts: 0 Newbie

    BTW- Is this monitored by TeamViewer support? If not, I'm not sure what use this support forum is.

  • spruceymaine
    spruceymaine Posts: 0 Newbie

    One more thing: TV creates a log file which is accessible from the 'extras' menu selection.

    My log shows these entries indicating a timeout, but without any reason.

    2021/03/27 11:07:48.022 7828 2588 S0  SessionControl::TerminateSession: Session termination reason SessionTimeout

  • baughmom
    baughmom Posts: 1

    I am having the same problem

  • Joesatriani
    Joesatriani Posts: 1 Newbie

    Hi, everyday teamviewer disconnets me because with this message "you are using it for commercial use". It's not true because I use it to connect to my mother phone and my father computer.

    Why? What possible do?

  • Silverio
    Silverio Posts: 0 Newbie
    edited March 2021

    Good afternoon,

    I'm register user that for years has used TeamViewer in educational area (University) and also to help relatives and friends with their computer.

    Recently (and once more) the teamviewer cut down the communication at 1 minute appx. I am not using it for commercial use.

    Please, could be so kindly to allow me to continue using it?

    Thank you,


  • Heebs
    Heebs Posts: 2 ✭✭

    I found a solution on youtube that worked for me

    I cannot post links - but search "How To Fix "Connection blocked after timeout" On Teamviewer (2020)"

    The process took 20-30 minutes but so far I have been connected thru teamviewer for 45 minutes now with no issues (Before this I could only stay connected 10-20 seconds.

    I don't know how long this will work, will I have to re-do it occasionally? Not sure.

  • G_Rex
    G_Rex Posts: 0 Newbie

    TeamViewer has "sort of" acknowledged the issue. My suspicion is they've made a change that has caught plenty of abuse but also created "false positives".

    Explanation and solution are here:

    tl;dr - you need to fill out a form and send it to them to request your ID be "reset" - it takes a couple of days (sigh) but really isn't that hard. You give them your TeamViewer IDs and tell them how you're using T.V.

  • Skylar
    Skylar Posts: 1 Newbie

    I needed to reactivate my team viewer ID because I am getting a timed out message. I followed the steps of going through the reset management. I am at the point where I have to download the PDF form, sign it, and scan it back in. However, when I click to download the PDF it gives me error message and the PDF cannot be downloaded. I switched browsers to see if it was a browser issue. Any support? Thanks!

  • Harold_Yonkin
    Harold_Yonkin Posts: 1 Newbie

    Anyone else having disconnect after a few minutes online with a remote? I'm using the free version

  • dav43w3w
    dav43w3w Posts: 1 Newbie
    edited March 2021

    i am having the same problem and i open ticket as well, not yet responded. can anybody help me please how to fix this ? i already cleaned and reinstalled.

  • Glenn_Maffe
    Glenn_Maffe Posts: 0 Newbie

    same here

    free version disconnects after a few seconds. i only connect to one pc

  • devilmedic
    devilmedic Posts: 2 ✭✭

    i was flagged for commerical got that fixed now dc after about 20 seconds

  • 8thgen
    8thgen Posts: 0 Newbie

    Hi - I also just started having this issue also, I am connecting to one of my personal computers.

  • Harold_Yonkin
    Harold_Yonkin Posts: 1 Newbie

    I was not flagged as a commercial account, Just a timeout a few minutes into a session

  • devilmedic
    devilmedic Posts: 2 ✭✭
    edited March 2021

    yea i was under commercial got that fixed now 2 days later it times out after 1-2 mins. its only personal and family computers i connect to

  • Robial
    Robial Posts: 2 ✭✭

    Same here. Trying to help my 99 year old grandmother with her computer and it won't let me connect. How do I even talk to support here?

  • ursoouindio
    ursoouindio Posts: 0 Newbie

    Same here. I have a free account that I use only to check on my home computer from my work computer.

    I did not had any "commercial use" message, it justs ends the remote access after a few seconds. The message is "Your TeamViewer session has timed out and will be closed.". If I try again i get a different message, sayigin that connection was blocked after timeout and I had to wait until a certain time to try again. But I actually need to wait much longer, in order to connect again, and then just for a few seconds again.

  • Me too has anyone gotten this fixed?

  • Brandoaz
    Brandoaz Posts: 12 ✭✭
    edited March 2021

    @veryounique they are looking for the ID that is a NUMBER

    Open teamviewer , on the left side click "remote control."

    In the Box on the left is Your ID( below that is a password)

  • Brandoaz
    Brandoaz Posts: 12 ✭✭

    install the remote app onthe remote machine or local, or both?