Commercial use - Connection time out



  • Heebs
    Heebs Posts: 2 ✭✭

    I found a solution on youtube that worked for me

    I cannot post links - but search "How To Fix "Connection blocked after timeout" On Teamviewer (2020)"

    The process took 20-30 minutes but so far I have been connected thru teamviewer for 45 minutes now with no issues (Before this I could only stay connected 10-20 seconds.

    I don't know how long this will work, will I have to re-do it occasionally? Not sure.

  • G_Rex
    G_Rex Posts: 0 Newbie

    TeamViewer has "sort of" acknowledged the issue. My suspicion is they've made a change that has caught plenty of abuse but also created "false positives".

    Explanation and solution are here:

    tl;dr - you need to fill out a form and send it to them to request your ID be "reset" - it takes a couple of days (sigh) but really isn't that hard. You give them your TeamViewer IDs and tell them how you're using T.V.

  • Skylar
    Skylar Posts: 1 Newbie

    I needed to reactivate my team viewer ID because I am getting a timed out message. I followed the steps of going through the reset management. I am at the point where I have to download the PDF form, sign it, and scan it back in. However, when I click to download the PDF it gives me error message and the PDF cannot be downloaded. I switched browsers to see if it was a browser issue. Any support? Thanks!

  • Harold_Yonkin
    Harold_Yonkin Posts: 1 Newbie

    Anyone else having disconnect after a few minutes online with a remote? I'm using the free version

  • dav43w3w
    dav43w3w Posts: 1 Newbie
    edited March 2021

    i am having the same problem and i open ticket as well, not yet responded. can anybody help me please how to fix this ? i already cleaned and reinstalled.

  • Glenn_Maffe
    Glenn_Maffe Posts: 0 Newbie

    same here

    free version disconnects after a few seconds. i only connect to one pc

  • devilmedic
    devilmedic Posts: 2 ✭✭

    i was flagged for commerical got that fixed now dc after about 20 seconds

  • 8thgen
    8thgen Posts: 0 Newbie

    Hi - I also just started having this issue also, I am connecting to one of my personal computers.

  • Harold_Yonkin
    Harold_Yonkin Posts: 1 Newbie

    I was not flagged as a commercial account, Just a timeout a few minutes into a session

  • devilmedic
    devilmedic Posts: 2 ✭✭
    edited March 2021

    yea i was under commercial got that fixed now 2 days later it times out after 1-2 mins. its only personal and family computers i connect to

  • Robial
    Robial Posts: 2 ✭✭

    Same here. Trying to help my 99 year old grandmother with her computer and it won't let me connect. How do I even talk to support here?

  • ursoouindio
    ursoouindio Posts: 0 Newbie

    Same here. I have a free account that I use only to check on my home computer from my work computer.

    I did not had any "commercial use" message, it justs ends the remote access after a few seconds. The message is "Your TeamViewer session has timed out and will be closed.". If I try again i get a different message, sayigin that connection was blocked after timeout and I had to wait until a certain time to try again. But I actually need to wait much longer, in order to connect again, and then just for a few seconds again.

  • Me too has anyone gotten this fixed?

  • Brandoaz
    Brandoaz Posts: 12 ✭✭
    edited March 2021

    @veryounique they are looking for the ID that is a NUMBER

    Open teamviewer , on the left side click "remote control."

    In the Box on the left is Your ID( below that is a password)

  • Brandoaz
    Brandoaz Posts: 12 ✭✭

    install the remote app onthe remote machine or local, or both?

  • Brandoaz
    Brandoaz Posts: 12 ✭✭

    i have all that information, the issue is i cannot add that ID or start another ticket so to speak because the system is recognizing ME being logged into teamviewer and already submitted( with my ID)

  • St3v3C
    St3v3C Posts: 0

    I had the problem of 1 minute timeout. Never saw a message about "commercial use" on either the host or remote but I filled out the PDF form and sent it in. In less than 24 hours TeamViewer reset the remote license and now it works again at least for a 5 minute test. Hopefully the fix stays.

    After many years of using TeamViewer for personal use I still love it and I hope everyone is able to get their problem reset and continue to use the program!

  • I have started the PDF upload process to prove I am a non for profit user but the PDF button doesn't activate. I have the pdf on my desktop.

  • ChiTown_Dizzy
    ChiTown_Dizzy Posts: 5 ✭✭

    The YouTube video just suggests a complete uninstall and deleting the TV directory in Windows. It doesn't work for me. Guess I'll try resetting my account ID.... again... for the 3rd time in about 12 months.

    If policing "private use" causes nothing but issues then just abandon it. Seriously, why even bother? It fails regularly, and just makes the whole platform look flawed. Who would want to spend money on something that unreliable?

  • ChiTown_Dizzy
    ChiTown_Dizzy Posts: 5 ✭✭
    Answer ✓

    Something seriously crippled the whole platform since March 23rd or 24th. Tons of people are having this problem. Seems to be no reason or fix for it. TV is basically useless now.

  • ChiTown_Dizzy
    ChiTown_Dizzy Posts: 5 ✭✭

    It seems as though this released coincides with a LOT of users getting "Session Timed Out" errors within 60 seconds of connecting to the host machine, and often much sooner than that. The support forums are flooded with people having this issue, all suddenly within the last few days, including myself. I used remote connect just fine on March 21st, but the last 3 days TV has been utterly useless. Is this just a coincidence? No one is answering any questions in the forums.

  • JasonEoff
    JasonEoff Posts: 0 Newbie

    I am having the same problem too. Connecting to Androids and other Windows PCs I get disconnected in about one minute.

  • MGrover
    MGrover Posts: 0

    I use TVfree once every few months to help out my 97yr Dad.

    Today, after doing a couple of reboots, it is limiting my sessions and connects.



  • Harold_Yonkin
    Harold_Yonkin Posts: 1 Newbie

    Wake up Team Viewer. You have a serious problem with your service, free or not if you can't use it, it's worthless.

  • GIbbsies
    GIbbsies Posts: 1

    I have been using teamviewer to manage my server that I use for my FoundryVTT D&D 5e game, mostly I just use the file transfer to copy images that might be nice for my next game with my friends.

    However it is not working today, I get a message that the maximum session duration is reached after less than a minute.

    This made me want to subscribe, figuring the cost would be like $5 a year to link two computers together, then I discovered it was $50 a month!

    So I am obviously not the intended user of this product.... my workplace is all linux anyway. Unless this is a mistake, I think I will finding some other alternative.

  • mgchurchvideo
    mgchurchvideo Posts: 2

    Any one help with this it keeps popping up. I'll wait and then be able to get back in but then it kicks me out again. I have free account.

  • KenHill
    KenHill Posts: 2

    I live in a seniors' community and have been using Team Viewer for many years helping residents. All that I do is volunteer and I do not receive a dime. Today I have tried three times to connect to a senior resident and all three times I have been disconnected within 15 seconds of establishing a remote connection. As I recall, this same thing happened a couple of years ago and it was because Team Viewer thought that I was doing it commercially. I would appreciate help. Thank you. Ken

  • Howdy
    Howdy Posts: 1

    I cam connect to desktop from my laptop. I recently went back to work from being remote for one year and I can not stay connect to my desktop at home.

  • why am i timing out after less then 30 seconds. Then I have to wait 1 minute continuously.

  • RhondaPye
    RhondaPye Posts: 2 ✭✭

    Has anyone had a problem with Teamviewer x64 throwing them out of a remote connection, after about 5 minutes or when you scroll the mouse?