Commercial use - Connection time out



  • BentleyD
    BentleyD Posts: 0

    I am connecting to my mom's android phone remotely and it works most times but every few days after just a few seconds of use it come up with

    "Connection blocked after timeout.

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license.

    Connections to this partner will be blocked until 16:09."

    This error happened at 16:09. If I re-connect after 16:09 (several minutes later( the time to be unblocked has been increased to now. I had only been using it for a few seconds. It had not been used for days. It is not commercial use. It is not happening for other devices including the android phone for my mother in law.

  • BigRD
    BigRD Posts: 0
    edited April 2021

    I've started getting this message and I've no idea why. I've tried rebooting both PCs without success although I can connect via Android tablet.

    I have a free account and both PCs are in the same house on the same network the remote PC is aa headless unit and used to control a motorised telescope.

    Any help is appreciated.

  • georgepaulx
    georgepaulx Posts: 0

    I am another free user with the same issue I even signed a TV statement that I am a personal user.

    What else can we do?

    Thank you

  • JoelRPutnam
    JoelRPutnam Posts: 1

    I just ran into this timeout issue myself for the first time. I've done two things that might be significant since the last time I ran TeamViewer succesfully, and I'm wondering if one of them might be the cause:

    1) I used CCleaner's Registry Cleanup utility. It's possible that might have messed up or deleted some anti-piracy registry setting.

    2) I enabled Crucial Storage Executive's Momentum Cache feature. I've heard anecdotally from gamers that having that enabled creates false-positives on cheat detection software sometimes.

    Anyone else also done something similar before running into this problem?

  • pk77777
    pk77777 Posts: 2 ✭✭

    I have been successfully using TV for years in order to assist my 91-year old mother in her "use" of her laptop. What that really means is that we communicate by Skype and her medical condition does not allow her to use a mouse anymore so I connect with TV and answer my own Skype call as it comes in on her laptop. It has worked well for years but tonight the TV session times out after just a few minutes and then that annoying "sponsored session" popup blocks her view of my beautiful face on Skype! Is there any way to either 1) stop the frequent timeouts that just started happening tonight or 2) eliminate the "sponsored session" popup from appearing when TV stops? Just to be clear: I am not seeing an indication that TV suspects commercial usage. I just get a simple timeout stoppage. I use TV almost exclusively to connect with Mom and rarely for any other use. Could it have anything to do with the fact that I am connecting with her on a daily basis now because of Covid?

  • Cook2son
    Cook2son Posts: 2 ✭✭

    I've been using the Free version (non-commercial) and tonight after I connected to my friends computer, it logged me out and says "Your TeamViewer session has timed out and will be closed". I click on OK and am presented with another dialog box which states, "Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are block. Please try later or upgrade your license. Connections to this partner will be blocked until 20:41". The time is always one minute from the current time. I wait for the required time to try again. Same thing happens with the next login time a minute or two away. I even waited 10 minutes and at least got the regular login screen and entered the password but again was timed out. This is something new. Just two days ago, everything was working just fine. Anything change? I'm running a Mac mini and just had the OS updated to Big Sur 11.2.3. Any other Mac users having a problem? Any light shed on this problem would be greatly appreciated. Thanks in advance!

  • Nabil_Nahas
    Nabil_Nahas Posts: 0

    Hi, I have noticed few days back, that as soon as I connect to one of my remote computer, it disconnect automatically after few seconds, and give me the following message:

    Session Time-out: Your TeamViewer session has timed out and will be closed.

    When I try to re-connect, it gives me that my connection is blocked after timeout.

    "Your License limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license.

    Is this a new policy on the free license?

    If not, how should I solve it?

  • Bmarchand
    Bmarchand Posts: 1

    I have the free license, when I remote in, it blocks me a minute or 2 later and says blocked for certain period of time, looks like it thinks the session duration is too long, but its not

    When I try and reconnect it says blocked until and gives a time a few minutes later

    When I try after that time it gives me another time a few minutes later

    cycle continues

    Any help would be appreciated

  • LightWallBouze
    LightWallBouze Posts: 1


    Teamviewer Incorrectly Thinks I'm using for commercial use and won't let me connect to my PC, how do I tell them it's not commercial?


  • BeeCee
    BeeCee Posts: 1

    Why does it keep kicking me out after a minute and Reads connection blocked after time out. Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try again later.

    It's been like this for an hour. I uninstalled and reinstalled and activated my trusted devices and it is still disconnecting me after a minute. I timed it.

  • tangpho
    tangpho Posts: 1

    Having the exact same issue.

  • nhedgespeth
    nhedgespeth Posts: 0

    Same here

  • BeeCee
    BeeCee Posts: 1

    Well it looks like I'm not the only with this issue. Ok, teamviewer experts, tell us what we need to do. Please!

  • bebovard
    bebovard Posts: 1

    Using free edition, non-commercial . . . exact same problem this morning after not using TeamViewer for over a month or two.😟

  • thunder597
    thunder597 Posts: 1
    edited March 2022

    Hmm hopefully it might just be a glitch today and they will fix it. But after reading other complaints it looks like they are just trying to make us buy it. I have been using this non-commercial for years now. I have no need to pay out the **bleep** when I don't even use it all the time just not worth it. It was great while it lasted. If they are just trying to make us pay at least say tell us that. If it is just a glitch fix it for crying out load. PS: Teamviewer your customer support **bleep**

  • BeeCee
    BeeCee Posts: 1

    Well hopefully it is just a glitch for today. I’ve been using team viewer for several years and this is the first time I’ve had any problems. I use the free version also.

  • AR88
    AR88 Posts: 0


  • Kline
    Kline Posts: 1

    I've been using TV for years, but it has recently started dropping my connection after about a minute. Has the company changed there policy regarding the free license?

  • kucer
    kucer Posts: 0

    The reset page does not work. I put in my ID and it is more than 8 but less than 11 letters but it just highlights that field in red like I have it wrong. I have OCD and it takes me 30-60 minutes to leave for work because I keep having to go back and check the stove, etc. With teamviewer I can just leave OBS up connected to my cameras and TV in to my pc to verify that no, my house is not on fire. It also allows me to view my emotional support animal. You think this is no big deal but it causes me a ton of anxiety. And I cannot even put in a ticket or chat/call/email with a real human being to get this resolved. Did some awful company buy teamviewer? You used to be the best but this is just a massive swerve downhill.

  • bradmich
    bradmich Posts: 1

    Recently I have tried to connect with another one of my computers and after about 2 minutes I get blocked and the mesaage that I have exceeded maximum duration. I only use TEAM Viewer about once every month or less and have had no blocks so far yet now I am getting this message and issue?

    What is going on??

  • ktr239
    ktr239 Posts: 1

    Seriously - I cannot connect to anything, why am i being penalised for not paying for a FREE account?

  • PeteQuestion
    PeteQuestion Posts: 0

    I have also just started getting this problem. While connecting my Mac to my Ubuntu computer.

    Connecting from my phone to my Mac seems to work and doesn't time out. So I don't think this is an account or licensing problem.

    I reinstalled Teamviewer on mac and my Ubuntu machines. Still getting the same error.

    This is what I get when trying to reconnect:

  • mgchurchvideo
    mgchurchvideo Posts: 2 ✭✭

    I recently summited a request to get my ID rest as I was flagged I use teamviewer to connect to my church computer to organize I do this on my own time and I'm not paid. This is very frustrating. I would love to talk to anyone on phone just give me a number. NOT HAPPY

  • HaVoK
    HaVoK Posts: 0

    I am travelling and trying to remote to my home PC but teamviewer keeps timing out over and over. How can I fix this? I am using the free version. Thanks!

  • Supawoo
    Supawoo Posts: 1
    edited April 2021

    Just save yourself a headache with these **bleep** **bleep** and switch to **Third Party Product**. You're welcome!

  • rchan
    rchan Posts: 1

    I'm trying to connect to my Father's computer to get some files to help him file his taxes.

    I haven't connected to this computer in a while.

    I connect on to his computer and in about a minute or so. I get kicked out and I try to reconnect and get this:

    Connection blocked after timeout.

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license

    Connections to this partner will be blocked until 21:35

    I'm using version 15.16.8 (32-bit)

  • clee1978
    clee1978 Posts: 0

    I am having the exact same issue. All I am trying to do is assist my friend with some computer issues that he is having; however, I don't stay connected for more than thirty seconds, and I am kicked out. I do not use this software for financial gain, only to help my friends and family when they need computer assistance, be it macOS, Windows, Linux, etc. When I visit the TeamViewer site and on the application itself, it states that I am using the free account. I am using version 15.16.8 64 bit and the behavior is the same on macOS, Windows 10 build 20H2v2 and Linux. Please assist us, TeamViewer! Thank you.

  • Sunhee
    Sunhee Posts: 0

    Hello, I am Sunhee.

    Recently I have been blocked when I was using Teamviewer.

    The program said I need a commercial license.

    But I am in the academic field and used TeamViewer with my friend for coding the program or R.

    Could you permit my Teamviewer access?


  • rikosheavr4
    rikosheavr4 Posts: 1


    I have been using Teamviewer for a long time around 8 years. I have three PC's at my home that all have it installed. One of them is using a VPN and has no screen. I use this PC for my Onedrive storage and media. Anytime I connect to this PC for remote control after a minute TV kicks me out and won't let me reconnect for a certain period. Why is this? How do I fix it?



  • lazza79
    lazza79 Posts: 1

    I have 4 PCs in my TeamViewer account and recently I am being kicked out after about one minute.

    Could you please help?

    I have a free license and I don't use the PC for commercial purposes.

    Thank you!