teamviewer.com link icon
or
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?


Download the new version and let us know what you think about it! 👉 Please click here 👈

LAN Remote Control between Win10 and Fedora31(Host) works only until reset

Levis
Levis Posts: 2 ✭✭

I have two laptops, on one of them I have Fdora installed to learn Linux for university.

When I'm home I prefer working from my main rig though (comfort reasons)(Windows 10) without installing Fedora on it (low storage space), so I decided TW might be the best option.

So first time I tried it I was very excited it works with all it's features like shared clipboard, but the next day it refused to connect. On Windows when I try to connect, the green dot turns yellow "Connecting...", on host nothing seems to happen, and then from yellow it turns to green "Ready to connect" like nothing happened. Only then does it turn yellow on the host Fedora "Incoming connection..." and not much later red "Protocol negotiation failed. Please try again!"

Apparently after a reset on Fedora it stops working, before that I can start sessions on LAN even if I restart the TW service.
I tried older versions, made no difference.
I tried other networks, thinking it might be the router or something, made no difference.

I found a temporary fix which might just be the only one I'll ever have, but it's quite annoying to do it every reset. I have to uninstall TW from Fedora, and force install "Other systems (not officially supported)" package:

wget https://download.teamviewer.com/download/linux/teamviewer.x86_64.rpm

sudo dnf -y install teamviewer.x86_64.rpm

sudo dnf -y remove teamviewer

tar xvf /home/flam0241/Downloads/teamviewer_15.3.2682_amd64.tar.xz (already downloaded other systems package)

sudo teamviewer/tv-setup install force

It's probably not the best way to do it, but then again I'm still learning.

Why is this happening? What is happening exactly? Is there a better solution?

Edit: It also doesn't work if I'm trying to connect from computers list, but it does work if I connect via ID. However that's through the internet I believe and it kinda makes the delay far worse.