Problems remote controlling a target computer without pressing "Allow" on the target computer

ErikAhl Posts: 1
edited May 2 in General questions

Hi team!

I have just gotten the upgrade to Teamviewer 12 and have the problem that I have to confirm in person for the each incoming remote control connection. (Travel or Walk to the computer I try to remote control and press "Allow").

I have set the settings to "Allow" like in the screenshot below.

Still I get a message saying await confirmation. As shown below.

This was a little better last week. Then I got a count down and was able to quickly logout of the machine and the reconnect and be able to properly remote control it. But today we got a patch pushed out and since then all input is blocked until "allow" is pressed on the target computer..

I have these settings on the target computer (Options):
- Start teamviewer with windows
- Incoming LAN connections: accept (we are on the same LAN)
- Account assignment, have set this to the same as on the computer we try to connect with.
- Have set a password for unattended access
- Windows logon: "Allowed for all users"
- Whitelisted the users that connects to the target computer
Avd settings:
- Adv settings for connections to this computer: Set to allow on all (as shown in my screeshot)

I need help with which other settings to change in order to be able to remote control the target computer without having to walk to it and press "allow" with the mouse button. I can't figure out which other setting could solve the issue.

Thanks in advance!
Regards, Erik

Teamviewer version target machine: 12.0.77242
Teamviewer version control machine: 12.0.78313

Windows 7 Enterprise
Service Pack 1


  • This might be a dumb question, but have you gone through the "Setup unattended access" wizard on the remote PC?