teamviewer.com link icon
or
Ask The Community

Black screen not working (Windows 10)

This seems to be the oposite of the common problem:

I'm unable to show a black screen on the computer I'm connecting to.

I can select "disable remote imput" - which works, and I can also select the "show black screen". Bu this does nothing. On the remote computer, the input is disabled but the screen shows everything.

I've also tried selecting the "enable black screen" option in the tw options on the remote computer, but when I do this the client cannot even connect to it: It hangs forever on "initializing display parameters".

Anyone got any ideas? I was about to buy a license for TW when I noticed this, and it's a complete show stopper for me. There's no official TW help to get either, since I haven't bought a license yet.

I've tried installing and reinstalling the TW monitor drivers on both machines, but TW doesn't even appear to be TRYING to black the remote screen.

Best Answers

«13

Answers

  • bartlanz
    bartlanz Posts: 315 ✭✭✭

    I have seen this option but never actually used it before today. It appears to work for me from my Dell Laptop to a Samsun All In One that I am setting up. I did need to install the driver you mentioned.

    Have you tried it with any other computers in your enviroment yet? I wonder if it is something unique to that machine or that video card model/chipset?

    If my post was helpful, Please throw me a Kudos.
    If my post fixed your issue, please mark it as the solution to help the next person find a solution quickly.
    Bart Lanzillotti
    We Do IT USA
    www.wedoitusa.com
  • I just tried connecting to the same computer with the Android app, actually. And the problem was the same there: The "black screen" option did nothing, but everything else worked fine. Can the problem be that TW isn't able to black the screen of this specific host computer? I'll try using another host computer as soon as possible to troubleshoot further.

  • I've now tried what I should've tried right away: Connected from A to B and B to A.

    When connecting from ComputerA (Dell Lattitude) to ComputerB (HP ZBook), it doesn't work. Neither Actions->Disable remote input/enable black screen on ComputerA nor Advanced Settings->Enable black screen.

    When connecting from ComputerB (HP ZBook) to ComputerA (Dell Lattitude), it DOES work. The moment I select Actions->Disable remote input on ComputerB (HP ZBook), the host monitor (Dell Lattitude) goes blank.

    ComputerB (HP ZBook) has two external monitors in addition to the laptop monitor. I'm guessing this might have something to do with the problems? I didn't think about this at first, because I cannot remember the last time I saw a workplace laptop that didn't have at least ONE external monitor.

    TW DOES detect the multiple monitors though, and when connecte I can switch between all three.

  • CyberTech
    CyberTech Posts: 1

    I am having a similar problem.

    Remote computer, 3 screens -- all HDMI. Screen blanking worked fine.

    Changed one screen to a 2K DisplayPort, and it's unable to blank it.  The HDMI screens still blank fine.

    Win10, Teamviewer 12.0.78313

  • Ugenx
    Ugenx Posts: 1

    This is definitely related to displayport/external monitors. I am having the same issue blanking a remote screen connected to a laptop via displayport. This same blanking on the same system and monitor works fine over an HDMI connection.

  • MichaelG
    MichaelG Posts: 18 ✭✭

    I see the problem too. dual monitors - display port.
    I only found out because I was told that I could be seen working. So, I set up my camera to face the screen. Problem verified.

     

  • MichaelG
    MichaelG Posts: 18 ✭✭

    I just found that it's not blanking on my work computer either. HDMI input on this one.

  • Kimber
    Kimber Posts: 3

    Has anyone found a fix for this?

    I got the prompt to install the driver, but I didn't restart my computer at the time.

    My computer popped up that it stopped the download of the driver.  Now I cannot get the computer to download the driver again.  Each time I select to black the screen, it prompts to download the driver, but it never actually downloads.  Even in the advanced setting, the install monitor driver is grayed out.

     

  • Kimber
    Kimber Posts: 3

    Thanks so much for the reply.  This is really disappointing that they do not have a fix.

    What remote software did you decide to use instead?  I've been looking for other options myself.

  • MichaelG
    MichaelG Posts: 18 ✭✭

    I have the issue on at least 2 computers.
    On one (HDMI), uninstalling the driver, then uninstalling TeamViewer, then reinstalling it all fixed it.
    On the other with DisplayPort and 2 monitors, it did not help. I have a ticket in.

  • janhvh
    janhvh Posts: 1

    I have this problem too, and a colleague as well.
    One screen goes blank, the other does not.

    Might be a difference between HDMI / Digital input / SVGA ?

  • MichaelG
    MichaelG Posts: 18 ✭✭

    TeamViewer support has been good at working with me, but I did some testing on my own.
    I decided to check my NVidia display driver. A new update was available - but it got me thinking. So after allot of testing... the later display drivers do not allow the black screen to work.
    I have two DisplayPort monitors.
    NVidia driver version and will black screen work...
    368.69 - OK
    375.70 - OK
    376.09 - OK
    378.92 - OK (3-20-17)
    --------------------------------- Breaks here
    381.65 - NO (4-06-17)
    381.89 - NO
    384.76 - NO
    385.28 - NO

  • If I may ask, which other solution did you select? Because I'm having the same issue and it is driving me ever-so-slightly crazy.

  • I have the same issue. Windows 8.1 desktop with 2 dvi/hdmi monitors.

  • syslink
    syslink Posts: 8 ✭✭

    I also have the same problem with my notebook. MS Windows 8.1 and display port <=> HDMI connector. I didn't try to resolve it by disconnecting the external monitor because this is not what I want to. It stopped working since I started using version 13 of TeamViewer.

  • PaulB
    PaulB Posts: 7

    Not good enough - come on Teamviewer - you can (and do) do better than this!

  • Show them that they're losing customers by chosing not to prioritize a serious bug like this. For my part, they've lost a customer with 120-130 users.

  • PaulB
    PaulB Posts: 7

    What have you moved to Frank?  I have about 10 users.  Teamviewer has been very helpful but right now is no use.
    How do we make them prioritize this?

    Paul

  • PaulB
    PaulB Posts: 7

    Hey Frank

    Try updating to the latest version - I think they have fixed it now.  It worked for me anyway so I am happy.

    Paul

  • The TeamViewer guys are complete, utter *bleeps*. The monitor driver is unsigned, making it impossible to install on Windows 10 unless you "hack" the security down a notch. And no intelligent administrator will allow that on a coorporate computer.

    Once again: **bleep** you, TeamViewer. *bleep bleepity bleep*

  • The issue seems to be primarily with PCs running nVidia drivers. I've noticed it on my MacBook Pro as well (Late 2013, using nVidia 740M 2GB).

    There could be some AMD instances, but I see many compliants about nVidia drivers, with specific mentions. I haven't noticed AMD complaints, I suppose because the nVidia compliants have stood out. I wonder how many people on this thread are running nVidia drivers?

    I've also noticed on my PCs, my Intel Graphics and AMD graphics don't have this issue. I have a limited testbed, but it does seem to stand out. Doing some looking around it looks like TeamViewer and nVidia have had some trouble playing nicely together at least since TeamViewer 9. 

  • Not to be rude sir, but this isn't helping troubleshoot the issue. 

    My driver signing is still enabled and I have no trouble installing or using Teamviewer 12 or 13. Are you running the latest version?

    I'm running a mix of 12 and 13 (upgrading them all to 13 now), all on Windows 10 (x64), builds 1703 (Creator's Update, upgrading as well) and 1709 (Fall Creator's Update, fully patched), and I have had 0 issues with installation and not seen the behavior you're describing. I have it installed on 9 computers (personal use, 6 Windows boxes, 2 Macs, 2 CentOS). I have not have not had to lower or adjust a single security setting on Windows; only one setting for SELinux on the CentOS boxes. 

    Lowering a security setting isn't "hacking"...it is changing a setting. Unsigned drivers aren't necessarily dangerous either (though I've not had to do this experience with TeamViewer, like you say), it depends on where the driver is coming from and why you're installing it. Reasonable admins should carefully weigh these factors before installing such drivers, but signed drivers aren't a guarantee of security either. They just guarantee that Windows doesn't complain.

    Perhaps you'll recall when Adobe dumped their private key onto the internet in September 2017? (https://www.theregister.co.uk/2017/09/22/oh_dear_adobe_security_blog_leaks_private_key_info/) Windows (regardless of version) would have never complained about malicious software signed with that key, but it still would have been a malware-related security event.

    The developers at TeamViewer (none of whom I've ever had any contact with) work very hard on a complex software; they offer it free for personal use, and they have created it to be cross platform compatible. Good software is tough to architect and implement to begin with; and even harder to get right across every box every time. Microsoft has been in this game how long? And they break stuff all the time. Apple too. It is a fact of life, especially as tech becomes more complex (and hopefully more useful). Admins should use intelligence and reason, not insults or disparagements to choose which software they use, and why. 

  • Lowering the security is very often not possible in a coorporate environment. In my experience it's allmost never possible. These things are controlled by securicy policies. So no - unsigned drivers are not very compatible with a coorporate setting.

    As to the argument about it being free for personal use, it's invalid in every way. Whether the software is free or not is no excuse for not making it work properly. If you're not able to get a feature to work, then remove it. Or fix it. It's as simple as that.

    Also, many of us are paying customers, which makes the argument about "free for personal use" double useless.

    I agree with MichaelG here.This is getting more than old. They have clearly not even attempted to fix this issue;  If they had, things would've happened in the last year or so. It's not a priority for them, which means that they'll lose at least some paying users.

  • CarlosC
    CarlosC Posts: 8 ✭✭

    We are a paying customer of Teamviewer.
    We mainly use the host module so we can support our customers PCs.
    In the last years TV lost several of the features that made us chose it in the first place: The ability to use our own logo is gone (now it requires the download directly from TV, which is not allowed for many of our customers), and most important the lost of the ability to black and lock our customer screen.
    Yesterday we installed 6 new PCS at one of our customers. It absolutelly requires that for certain operations the screen should be not visible to the user - since we can not support this anymore, we are banned to use TV with this customer - so we have a remote support solution that force us to go physically to our customer to do some operations!!!

    A few days ago we received an email from TV asking for our feedback how TV has made us "greener" by reducing travels - We'll be glad to share our experience on how TV has made our face "greener" from rage and despair from the need to GO to the customer.

    The ONLY reason that make us still use TV is our base instaled - we have a few customers whose laptops are away, and the change of remote solution we'll have a cost in time and money for us - but we're closer to that decision.

  • syslink
    syslink Posts: 8 ✭✭

    Unfortunately, I am forced to agree with the previous speaker. Maybe I don't have such complicated situation but I also suffer from lack of possibility to working with the blank screen via DisplayPort and DVI on my laptop (I didn't explore this topic on direct laptop screen but I assume that it doesn't work also). I must admit that the attitude of the TeamViewer team is regrettable and gives no support for this problem except emails in "marketing" style "we'll do our best to make TeamViewer better and blabla...".

    PS
    I bought a corporate version of TeamViewer.

  • Same here... my situation isn't complicated, but the black out screen still isn't working.

    The pop up shows to install the software everytime I log in and check to black the screen.

    Are there any free or low cost alternatives to Teamviewer others are using?

  • Please fix the black screen functionality in WIn 10...

    Thank you

    Vasssek

Sign In or Register to comment.