teamviewer.com link icon
or
Ask The Community

Android screen orientation is wrong

Rasperk
Rasperk Posts: 6

Hi everyone, 

I use teamviewer for remote control generally controlling android tablet from a windows 10 pc. I got a new tablet, Teclast M16, and configured it for being controlled installing Quick Support, Host and the specific add-on.

When I connect for remote control I get the screen misoriented, like in the picture. Only the display is wrongly flipped by 90 degrees, while I could give commands as it was correctly landscaped, also acting on the black zone, and viceversa.

Screen misorientedScreen misoriented

I add info collected from the App.

InfoInfo

Tagged:

Comments

  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    Hi

    Have you tried to disable the autorotate setting in the phone's screen settings?

    Slide down of the top when you are in the monitor size you want to hold unchanged and then disable it.

    I hope this helps. Best regards.

  • Rasperk
    Rasperk Posts: 6

    Thanks for your answer.

    I've tried to hold the monitor either portrait or landscape but it didn't solve the issue.

    When I change the orientation of the tablet, I see it changing on the controlling device and setting in corresponding mode, but after just one second it flips over in the wrong way...

  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    Hi

    This is what I was speaking for in the previous post. All android devices have the option to disable and lock the screen in the orientation the user wants, just by disabling the autorotate feature when the tablet or phone is showing the orientation they want.

    Have you tried this option? It is inside the screen settings.

    Best

  • Rasperk
    Rasperk Posts: 6

    Thanks for the clarification but yes, this is what I actually have done: I locked the screen in both position, one at time, with no effect. Maybe I didn't explain well in the previous message, but I locked the screen by disabling the autorotate feature.

    I recorded a video of what occurs, here

    It didn't solve the issue.

     

     

     

  • Rasperk
    Rasperk Posts: 6

    I foud that turning On the 'Disable HW OVerlay' in developers options solves the issue.

    It is just temporary beacuase once I rebbot the tablet it comes back again and it is not a permanent solution also because by this way I overcharge the GPU with the job destinated to the CPU.

    Hope this hint could be a good starting point for finding a solution.

     

  • Rasperk
    Rasperk Posts: 6

    Any idea?

     

     

  • Rasperk
    Rasperk Posts: 6

    Hi, is there anybody understanding why disabling HW overlays It magically works perfectly?

     

    Thanks

    L.

     

  • Same here.  It's impossible to use teamviewer quicksupport in landscape.  The mouse is not activating the areas that you are clicking. As if there was a calibration issue. Very annoying. I tried to test this with other applications too with my supplier and ... same issue.  Working with Samsung tab a (android 10).  That shouldn't be an issue at all.  :-(

    Please teamviewer support contact me ASAP at +**Please do not post TeamViewer IDs**0 so that I could show you.

Sign In or Register to comment.