teamviewer.com link icon
or
Ask The Community

"Please wait while connecting" but won't connect

Hello everyone. 

For 2 days now whenever I try to access my computer from any device (Android, separate computer, etc.) It shows the "Please wait while connecting" but the circle just keeps spinning and it never changes. 

During this in the notification area on my phone it says that there is an active connection using TeamViewer. About a minute later I get the notification that this was a free session, etc and the connection is dropped. 

I've tried reinstalling. 

I'm currently not home but need to access my computer.. I went into my home network using a private vpn and checked if it's even on/addressable and everything works fine, except for TeamViewer..

Any ideas how I can fix this? I've restarted my home network remotely already as well.

 

Thanks in advance

Tagged:

Comments

  • hspb
    hspb Posts: 1

    I'm not sure if this will work for you, but I was having problems connecting from my android phone to my windows laptop as well. I also had the "Please wait while connecting".


    On your laptop or desktop open TeamViewer

    Settings (upper right of screen - Gear Icon)

    Security (3rd option down on the right side of the window that popped up)

    On the right side of the window, scroll down till you get to "Two-factor authentication for connections"

    Click on "Configure"

    In lower box, of the pop-up window, was the name of my phone

    Click on your phone, or tablet and click on "Remove"

    Click on "OK" and that window will close

    Click on "OK" on the Settings window to close that window

    Try to connect from your phone or tablet again.

    (Apparently I was not getting my TFA on my phone and because of this, I was not allowing myself to connect to my home laptop. I will personally look into the FTA at a later time and see if I can get that working again, if need be.)


    Hope this helps.