link icon
Ask The Community

TeamViewer 15.5.3 crashes during connection (Ubuntu 19.10)

janesc Posts: 4


I'm having this issue every time I use team viewer. The connection works fine for some time but there's a moment when the screen I'm seeing freezes (just to me, other users connected to the same screen see it fine). Once it has freezed there's nothing I can do and when I select teamviewer on the task bar it says that "Teamviewer" is not working and suggests to quit.

Once I quit I can restart the program and ask for the connection again, once I'm connected it takes a shorter period of time till it freezes as I've described. The period between connection failures keeps getting shorter making teamviewer unusable.

I have reinstalled Teamviewer several times making sure that I purged anything related to the "past" teamviewer before installing. 

Are there any solutions to this crash during connection?




  • Vatsilidis
    Vatsilidis Posts: 661 Star

    Hi @janesc 

    It seems like something is caching continuously.

    Have you installed TeamViewer from the official website or from the repository?

    Also, could you upgrade Linux with command 

    sudo apt-get upgrade

     I hope this solves your issue.

    Best regards

  • rolandg
    rolandg Posts: 62 ✭✭


    i'm runing TV on openSuse Leap 15.1 + KDE .
    I also have the freezing UI issue ( already since several versions; I did a post before, but no reactions. )

    Did you read this post:

    could your freezing UI happen after several Ctrl-C and Ctrl-V ?

  • janesc
    janesc Posts: 4

    Hi, thanks for the quick response guys :D

    @Vatsilidis I had the suspicion that there was some caching going on, making the freeze times shorter every time. I think that install TV from the official webpage via the .deb. I did the upgrade and a couple programs got upgraded including TeamViewer Yay! So, I will see if this solved issue. If it keeps working I'll let you know and mark it as solved. :D


    @rolandg   I'm not suer if the freezing is caused  by doing several Ctrl-C and Ctrl-V, I didn't take it into consideration. I will try to use teamviewer normally in the coming days and if it keeps failing I'll let you know.

    Thanks again for the quick response :D 

  • janesc
    janesc Posts: 4

    Hi again @Vatsilidis ,

    I'm still having the issue and it seems that it wasn't solved by the upgrade. Are there any other solutions? Does it have anything to do with the copy and paste that @rolandg mentions? I could just disable the copy and paste if it's causing the issue but I cannot find the option.

  • Skonsoft
    Skonsoft Posts: 2


    I have the same problem with ubuntu 20.04 and Teamviewer 15.6.2.

    Any solution ?

    Thank you !

  • disable UDP in advanced setting

Sign In or Register to comment.