teamviewer.com link icon
or
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳


Please find more information here.

Teamviewer ID Changed after upgrade windows 10 2004 verion (May update)

124»

Comments

  • Updated TV to 15.7.7 before upgrade to W10 2004 on 5 client PCs today and all IDs changed ! Clearly not solved and I just can't imagine the mess you put for those responsible of thousands machines around the world.

    Congratulations, TV, you found better than a virus to kill us.

     

     

     

     

     

     

  • TGeRi
    TGeRi Posts: 27

    Exactly! And why is this not number one priority at TV headquoters???

  • I am pretty sure that TeamViewer is aware of this potential disaster.

    The problem is that Windows 10 2004 were in testing since many months ago. It is unnaceptable that when 2004 reached public release this issue just appeared as not solved. TV should began testing of their products in the early stages of development of new Windows versions. For a reason there is a Windows Insider program.

    This could be related to something in Windows that changes computer identity in some way. So, the TeamViewer app should be aware of this and keep their ID after the update, ignoring the identification changes.

    For now, 2004 is blocked on all my managed devices via GPO.

  • Information : no ID change when upgrading from windows 7 to W10 2004 ... so this is not the "OS major upgrade" causing ID change

  • Yuri_T
    Yuri_T Posts: 2,259 [Former Staff]

    Hi @joloriquelme and @jmangelini ,

    Thank you for your posts and I apologize for any inconvenience caused.

    In order to assist you individually, I have created a support ticket for you.
    Could you please check your email and provide us following information via the support ticket?

    We look forward to hearing from you in the ticket.

    Kind regards,
    Yuri

    Former Japanese Community Moderator
  • Esther
    Esther Posts: 3,880 Community Manager 🌍

    Hi all,

    Thanks for your updates.

    I am still in contact with our dev-team, and it seems that the current release resolved the issue for most of the users.

    However - based on the feedback here, there are unfortunately still a few users affected.

    Please rest assured that this topic has the highest priority for us, and we want to resolve this, but: we need your input.

    We want to ask all of you affected by the switching ID, to 

    • submit the log files (with at least 15.7.7 installed of the devices where the ID was switching),
    • the new TeamViewer ID and
    • the old TeamViewer ID.

    In case you do not have a license, please reach out to me via PM, and I make sure to create a contact with our devs.

    All licensed customers can submit a ticket via https://support.teamviewer.com/

    Thanks and best,

    Esther

    Community Manager

    Support us on Trustpilot.
  • This happened to me after a .NET update.

    Trying a work around, but a complete reinstall and reinstate autologin of TV account has worked so far.

    Not ideal

  • TGeRi
    TGeRi Posts: 27

    With TV v15.8.3 we didn't see any ID change after installing win10 v2004 on our computers!

  • valkyriebiker
    valkyriebiker Posts: 13 ✭✭

    Same here. I opened a ticket several days ago -- alas, no update yet.

    Endpoint connection IDs are being arbitrarily changed. And I've noticed when they do change, they are reassigned relatively low 9 digit numbers. Apparently TV is (finally) recycling old, obsolete connection IDs.

    But the ID change not necessarily in time with an update to Win 10 build 2004. I've got multiple endpoints that upgraded 2-3 months ago that kept the same connection ID. Then in the last 2-3 weeks, the ID up and changed.

    How can this possibly be? Surely TV can fingerprint a computer reliably enough to know if it's the same computer after a simi-annual build or other update? I mean, I've written code in the past that does exactly that as a way of detecting license abuse.

    I have many hundreds of endpoints in my C&C. If this is a harbinger of things to come then I'm in deep dookey.

  • Anguel
    Anguel Posts: 5

    Well done, Teamviewer. Looks like Win 10 2004 upgrade also deleted "easy access" for most of my company PCs. Is this expected at the exorbitant pricing? I had to manually fix the issue thanks to good old remote desktop access which was not only annoying but also costs time and money, even more thanks to 2FA. Any refund for this or is this expected from your customers?

    How about issuing a big warning about his "unexpected" dangerous behavior? Or are the big pop-ups reserved for annoying ads in the paid versions?

    I hope you are aware that this is one of the worst things that can happen to software that claims to be suitable for remote control. And it is a shame that this still hapens months after an official Windows 10 upgrade release.

    BTW: Your forum software also seems to have bugs, it just discarded a long post I wrote before...

  • JSY
    JSY Posts: 2

    This problem is still in version 15.8.3. I just had it happen today, 2020-Aug-18, on two systems. Your Endpoint was installed on both systems. There was no way to uninstall the EndPoint remotely, and your tool for cleanup did not work. the only way to get the license back was to remove the computer and lose all billing information and past work. the following was tried when in front of the computer:
    1. uninstall using windows uninstall under programs. This did not work even after several reboots.
    2. rebooting in safe mode and removing the directory, running your tool, and rebooting 3 times. After doing all this, the computer showed up in the endpoint management console, and I did an uninstall. then rebooted the computer 2 times, then ran your tool and rebooted 2 times. After this, I tried to reinstall under the new ID number, install failed with the message could not access files system. This problem usually occurs due to not rebooting the computer after an uninstall.
    I then called Tech support and was on hold for 35 minutes the man that answered the phone said I had reached sales and would transfer me to Tech support which told me there were 13 people ahead of me, in other words, I was placed back at the end of the queue. I had to hang up; I did not have another 35 to 45 minutes to wait on hold.
    I still have two computers that I can not reinstall EndPoint on.
    I had reported this problem with EndPoint before when I had computers go offline for storage at the start of the COVID 19 problem, and the only way to get the licenses back was to delete the computer, thereby losing all billing and history on the computer.
    Teamviewer needs to have a better way of getting the licenses back when the computer goes offline, or the ID gets changed as with w-10 2004 update and not make us lose our billing information.
    Teamviewer needs a way for users to uninstall Endpoint completely on an offline computer easily.2020Aug18 TV Ver.JPG

  • The issue still persists in 15.8.3

    I have a windows machine on 15.8.3 and I updated from 1909 - 2004 and the ID changed.

    Luckily all our computers are running a BAT-script under source control every midnight. So I pushed the command:

    "\Program Files (x86)\TeamViewer\TeamViewer.exe" assign --api-token NNNNNNN-XXXXXXXXXXXXXXXXXXX --group-id gNNNNNNNNN --grant-easy-access --reassign

    How can I help the TeamViewers software department?

    @Yuri_T 

  • GFORCE1
    GFORCE1 Posts: 13

    OK ..... well it is still not solved so it seems.....
    Its lasting for months now, i still dont have the guts to upgrade my clients to 2004....
    Hope it will be resolved quickly now. Mean time im gonna look for another product if its not gonna be solved.

  • Esther
    Esther Posts: 3,880 Community Manager 🌍

    Hi @JoachimSpange, hi @GFORCE1 

    Thanks for your reports!

    The best way to help your devs is by sending in the logfiles from the machine which switched the ID.

    This helps them to check the scenarios with our previous findings to see what parts need to be worked on.

    If you are in doubt, here the guide on How to submit a ticket 

    Thanks for your help!!

    Esther

    Community Manager

    Support us on Trustpilot.
  • Christian_R
    Christian_R Posts: 5 ✭✭

    Same issue here.

    /slow claps

  • Christian_R
    Christian_R Posts: 5 ✭✭

    Same issue here.

    slow claps ?

    P.S.: Forum threw an error message and sent the previous comment anyway.

  • JSY
    JSY Posts: 2

    There may be a more efficient way to do, I did not try to optimize this process.Tool you sent me 2020_Aug-19Tool you sent me 2020_Aug-19Tool I usedTool I used it.

    The tool you sent me is the same tool I had and used as described in my original ticket.

    That tool does not completely clean the registry. Please see the attached screenshots.

    When the ID changes the account assignment is not in the new ID and you cannot access the old ID on the computer all you can do is delete it from the console in TeamViewer.The only way I was able to resolve this problem was to do the following:

    1. reboot in safe mode and remove the ITbrain folder.
    2. reboot again in safe mode and remove all references to ITbrain in the registry.
    3. reboot to regular mode and run your tool.
    4. 4.reboot two times and then uninstall Teamviewer that has the new ID.
    5. reboot two times and install Teamviewer using my Design & Deploy module.
    6. Delete the old ID from the Teamviewer console to get the licenses back.
    7. reboot the computer and then activate Endpoint protection.

    This process takes a long time and cannot be done remotely.

    I did not try running your tool in safe mode.

    In my experience, the tool did not remove all ITbrain registry entries.

  • Hopefully tickets 33946199 contain what you need.

  • Esther
    Esther Posts: 3,880 Community Manager 🌍

    Thank a lot @JoachimSpange !

    I assigned the ticket to the devs  and I am keeping my fingers crossed ?

    Best, Esther

    Community Manager

    Support us on Trustpilot.
  • ManP
    ManP Posts: 1

    It is not just a Windows update that causes the issue. The method for generating the TeamViewer ID is flawed. It uses network driver MAC address and I suspect that when enumerating the network drivers, TeamViewer picks the first one found. In most cases, this is fine but occasionally the order of the network drivers are changed so subsequent enumerations of the network drivers lists has resulted in the first one being different due to the order being changed.

    This is bad design from TeamViewer and when the order of network drivers have changed, there's no way to know which one was previously first in the list. Their developers will NOT be able to fix this. For example, previously a Realtek driver was first in the list and this is used to generate a TeamViewer ID. After a Windows update or other operation that changes the order of the network drivers (possibly from installing VMWare or HyperV), the Realtelk driver may have been moved to 2nd in the list, with an Intel driver being first in the list. If TeamViewer is always picking the first one to generate an ID, then this method is seriously flawed.

    If TeamViewer wants a more reliable way to generate IDs, they should have cached the ID for the network driver initially and then scan for that cached network driver on each subsequent attempt to generate ID. Again, it's not perfect but it's better than the rather deranged method of always choosing the first item in the list.

    I agree with many disgruntled TeamViewer users here because TeamViewer developers have have implemented a system which was destined to fail at some point and now cannot be recovered!