link icon
Ask The Community

Unable to upgrade to newer version

Hi, I use the 'free' TeamViewer licence. I tried to upgrade from V9 to V14 but download stops part way through with a message saying that download is continuing, although it is not. Tried uninstalling V9 and then downloading V14, but still encountered the same problem. Now I don't even have V9. Can anyone suggest how to resolve this problem please. Thanks in advance.



  • JeanK
    JeanK Posts: 3,846 Moderator

    Hello @CRFC

    Thank you for your message and welcome to the TeamViewer Community! ?

    Using the free version is only possible with the latest version of TeamViewer on both sides of the connection (version 15).

    You will find the answer to your question in our post here: Re: Connecting free versions 13.2 

    I hope this could help. ?

    Best regards


    French Community Moderator
  • CRFC
    CRFC Posts: 3

    Hello Jean,

    Thanks for your response. The problem is that I am not able to download TV. I start the download by running the .exe file, but after downloading what would appear to be all the files a dialogue box pops up with the message -

    Teamviewer Setup / The Teamviewer service could not be started. The installation will be continued.

    There is a new TV icon on the desktop, but it does not open TV. Do you have any other suggestions?

    Thanks, CRFC

  • JeanK
    JeanK Posts: 3,846 Moderator

    Hello @CRFC

    Hmm... weird.

    I suggest you to uninstall fully TeamViewer from your computer by following this step by step guide: How to uninstall TeamViewer on PC 

    Then, try again to install TeamViewer.

    Let me know if this has helped. ?

    Best regards


    French Community Moderator
Sign In or Register to comment.