teamviewer.com link icon
or
Ask The Community

Activation link not working

Hello,

I purchased a Teamviewer remote access licence today and the link I was emailed to activate it does not work and I cannot submit a ticket. If I call support I am told to submit a ticket!

Can someone please help me?

@TeamViewer 

Tagged:

Comments

  • JeanK
    JeanK Posts: 4,219 Moderator

    Hello @MWindmill,

    Thank you for your message and welcome to the TeamViewer Community! ?

    You can call support and tell them that the link is not working. They will generate a new link for you.

    Best regards

    Jean

    French Community Moderator
  • Dear JeanK, 

    I have similar issue, when I reach the TemViewer Management Console too add optionnal features such like Pilot, TeamViewer ask me to confirm using an activation Link. This link seems to be sent correctly at the right email, but unable to receive it despite all TeamViewer's content whitlisted on our firewall.

    Thank you for your support

    Best regards


    @JeanK wrote:

    Hello @MWindmill,

    Thank you for your message and welcome to the TeamViewer Community! ?

    You can call support and tell them that the link is not working. They will generate a new link for you.

    Best regards

    Jean


     

    Christophe Bertholet
    Prod.Manager
    Fondarex SA
    Switzerland
  • JeanK
    JeanK Posts: 4,219 Moderator

    Hello @CBT-FDXm,

    Thank you for your message. ?

    For this situation, I also recommend you to contact our customer support. Our team will be happy to help you with this.

    Best regards

    Jean

    French Community Moderator
Sign In or Register to comment.