teamviewer.com link icon
or
Ask The Community

Disable microphone acquisition when remoting into another machine

Is there a way to stop teamviewer from acquiring the microphone when I remote into another machine?

I appreciate that it is trying to prepare for a possible conference call with the machine but in some cases I just want to remotely manage the computer and not talk with anybody on the other side.

With my bluetooth headphones (which are configured as both speakers and headset), the microphone acquisition has the side effect of muting my speakers. (This isn't behaviour specific to TeamViewer, but any device that acquires my headphones)

Comments

  • bartlanz
    bartlanz Posts: 315 ✭✭✭

    I would suggest messing with the settings in Options > Audio conference, specifically the Red and Yellow arrows in the pic below. You should be able to specify what Mic to use so that it does not lock onto your BT Mic.

    tv Audio Conf.png

     

    If my post was helpful, Please throw me a Kudos.
    If my post fixed your issue, please mark it as the solution to help the next person find a solution quickly.
    Bart Lanzillotti
  • I'm also experiencing this problem (I think). My symptoms are:

    Listening to Spotify/Youtube/Skype call/audio of some kind, then open a TeamViewer window to another machine and my audio quality changes (lose bass, but still works).

    I know it's caused by the microphone being "activated" because when I go into Windows Sound settings, Recording tab, then the microphone activates there too and the same sound quality issue occurs.

    I'm using a Plantronics USB headset.

    I'm starting to think it's a Windows glitch.

  • RickOShay
    RickOShay Posts: 1

    I know this is an old thread - but this issue is very serious. Having audio automatically output to connected devices is a security risk - there needs to be a simpler way to switch on audio and detect if another audio app is handling audio coms. At the moment it is somewhat obfuscated. I use Discord normally for comms. And so by default audio should not be on in TV unless I change that setting. There should be a simple button in TV that toggles all audio.    

  • SierraMSP
    SierraMSP Posts: 1

    I also find this to be very annoying. I usually watch TV through my HD Home Run on a second monitor while working on remote server management tasks over the weekend. I have a few sound output devices on my PC: Bose Speakers plugged in via USB (So they're detected as their own sound card and they're my default output device) in addition to the motherboard Realtek audio and my monitor's speakers via HDMI.

    If I set Teamviewer to send audio through my monitor instead of my default sound device then it stops muting the channels/apps going through my Bose speakers. Instructions for Win 10 Version 1903: Right-click speaker icon in taskbar. Open Sound Settings. At the bottom click "App volume and device preferences" (oh, make sure you have Teamviewer window open). Use the dropdown menu and change the output device on the Teamviewer app to another output device. I also disabled my Microphone input on my mobo. Problem solved for me.

    Annotation 2019-10-05 105128.png

  • haslador
    haslador Posts: 2 ✭✭

    This is useless, it dont stop teamviewer from trying to force take over contorl of the headset and mic, setting it to same thing is literly just saying, hay im using this way go a head and take over the one im using and kill all my other sounds.

  • THINK
    THINK Posts: 1

    Same issue here. It is insane that I can't control wether the app takes over my mic when all I want is to access a remote desktop.

    My current workaround is running TV inside a virtual machine.

  • SMPCH
    SMPCH Posts: 1

    Thank you!  So annoying!

  • A few people in our company are facing this issue and we are struggling to solve it. Can someone from teamviewer support look for a solution to this problem ? 

  • RafhaGunZ
    RafhaGunZ Posts: 1 Newbie

    There are someone who can help us with that?

    It's a very annoying problem, why not put a option to "Enable/Disable" Microphone access?

    I think it's too simple for it not to have been done yet.

  • Googs
    Googs Posts: 2 ✭✭

    Download VB Cable (virtual sound device), assign teamviewer to use the VB cable virtual microphone that leads to no where and you are away. I cannot believe that this has been totally ignored for three years.

  • RalphB
    RalphB Posts: 1

    Brilliant TeamViewer 👏

    This problem just wasted 3 hours of my day, I fixed it by plugging a old headset in to my docking station and telling Teamviewer in the settings to go control that old headset instead of muting my whole computer. I'm so aggravated right now, specially because you can find complaints back from 2017 with the exact same problem and all we need is a "Disable conferencing feature" checkbox.

    PLEASE TEAMVIEWER give us back control over our audio. this is a huge hassle!!!

  • JeanK
    JeanK Posts: 6,435 Community Manager 🌍

    Please see @.Carol.fg.'s reply regarding this issue here:

    This should fix the audio issue you are reporting.

    @RalphB @Googs @RafhaGunZ @Askanov @SMPCH @THINK @haslador @SierraMSP @RickOShay @HOT_since_90 @bartlanz @fostandy

    Let me guys know if it worked for you.

    /JeanK

    Community Manager

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer