link icon
Ask The Community

Commercial use - Connection time out



  • Background:
    My brother is a quadriplegic in a nursing home many states away from me. Often he needs me to log onto his computer to do things such as restart his dragon naturally speaking sofware etc... I DO NOT USE THIS COMERCIALLY. 

    Now whenever I attempt to log onto his computer I get the following:

    "it seems there might be a licensing problem with your connection partner. connecting to this device requires a valid teamviewer license for you or your connection partner"

    It then allows me to log on and boots me after about 30 seconds.

    This is making it impossible to maintain my brothers ONLY connection to the outside world as he is in a nursing home, not allowed visitors due to COVID19.

    Please help!

  • Awesome thank you, I'll try that out a report back.

  • I've been using TeamViewer Free for only one purpose since I started using it:  To help my mother who lives permanently at a rehabilitation and health center ("nursing home").  Today for the first time I had a pop-up appear stating "commercial use suspected".  This is not commercial use.  My mom has had 5 strokes and this is how I can help her keep connected to me and my 2 sisters - especially  Please help me to ensure this pop-up doesnt eventually block my ability to help my mom, Maria, 89 YO.  Thanks  ~Gabe

  • I just started getting this same thing today and I'm not using this for commercial use.  I just recently even started using this again to help my mom setup her new phone.  I keep getting disconnected and then I try to connect and it says I'm blocked because of my license type.

  • Same problem here, having this problem since last week...

  • I usually use to fix my parents computer and smartphone. When I use my smartphone to remote fix theirs devices, the message doesn't appears. The problem is only in my laptop (i'm from Brazil)

  • I support my mom's remote computer and have used teamviewer for some time.  Recently (last two months)?  I can't access at all.  When I access her computer - I am thrown out immediately (less than 2 seconds) and then blocked for several minutes.  I wait until I'm unblocked, then try again unsuccessfully.  Apparently with my free teamviewer there is no support so I can't file ticket.  Any help would be greatly appreciated.

  • Hello, I'm unable to use Teamviewer because it's showing "COMMERCIAL USE SUSPECTED" when i'm trying to connect with my Friend Laptop, Please help me i'm not using teamviewer with many computers, i'm just connecting my teamviewer with my 1 friend to Learn and Study.
    My exams is near and this time it's showing this error, please help me..
    I do not have any commercial use, i'm using it as personal use.

    I have tried to contact support but on Phone number they are saying the phone support is not available for free version, and i tried to find Email Id but no where i can found the support Email ID, 

    Please Help me, What i have to do now.

  • Facing the same problem here since today...

    I am a student. I am using it for personal purpose. Please help me ..... how to sort out this problem.....


  • Facing the same problem here since today.

    I am a student. I am using it for personal purpose. Please help me to sort out this

  • Dear TeamViewer customer support,

    When connecting to my remote PC through TeamViewer, the window "commercial use detected" opens.

    I actually work as a researcher at the university.

    Could you please help with setting the usage back to private.

    Thanks in advance for your assistance.

    Best regards.

    Could you plese

  • xs1
    xs1 Posts: 11

    @bazbsg wrote:

    @xs1 Unfortunately, they also consider it commercial use if you access your home PC to read your personal emails from your office or school during your lunch break.


    What's considered commercial use?

    Using TeamViewer for your business or profession – including accessing your home computer from work or connecting to a Windows Server operating system – or for any purpose for which you directly or indirectly receive compensation constitutes commercial use and requires subscription license in accordance with the End User License Agreement.

    Thats the issue. Server based operating systems and accessing home computers from work aside, "or for any purpose for which you directly or indirectly receive compensation constitutes commercial use" we are not getting compensated in any way, but still getting flagged. I chose to use a server OS for many other reasons, but its just a home network and p2p server... |In no way making money off it... 

    DOWNLOAD Mbps: 919.48
    UPLOAD Mbps: 942.24
  • Mike
    Mike Posts: 5 ✭✭

    A complete uninstall (using something like Revo-Uninstaller for a more thorough cleanup) may or may not reset the "commecial use" flag. Assuming you have an unflagged  working "personal use" setup, you can try usIng it without signing in. It is less convenient because you have to enter the  Teamviewer ID manually each time., perhaps keeping a note of these for your family and/or friends.

  • @xs1

    It's no wonder you're flagged as you log on from an office PC. There are smarter ways to access your mail anyway. If you use the IMAP protocol you can read your e-mail from anywhere: in a browser on your office PC, from your phone etcetera.

    If your managers at work considered it important that you were able to access your home PC from your office PC then they should shell out a few bucks to make that possible. As it is, you should use an office PC for work-related stuff and not for personal stuff. Well, you can, and nobody will stop you, but you shouldn't be surprised your TV use gets flagged.

  • xs1
    xs1 Posts: 11


    The **bleep** you talking about? Ive never stated i access email from any office Pc. I dont have access to teamviewer @ my job.. 

    DOWNLOAD Mbps: 919.48
    UPLOAD Mbps: 942.24
  • This happened to me almost 2 years ago and now I'm facing the same issue again. Nothing has really changed about how i use my computer, I'm mostly connecting to my desktop pc at home or my laptop from my phone to control my sonos speakers at home when i've forgotten those on or to turn off my pc when too lazy to go to it physically or looking at the dogs through the webcam.

    This time i had Android Studio running when connecting to my gaming-pc, I was trying to learn more about apps earlier today and left the program running. This is not my profession and I just had the application running in the background when starting Teamviewer. This may possibly be the reason why it triggered today.

    I'm not sure if I'm comfortable with teamviewer snooping which applications I'm running to make money out of my usage patterns. At work, we are using completely different softwares, I'm not allowed to run 3rd party applications without approval and using Teamviewer at work is a strict no-no which leaves me with zero options to run Teamviewer commercially. I'm not mixing any corporate data on any device that is in my possession. I've got a work computer and phone for work and a private phone + own computers for private use.

    I'm actually pretty sad that even though I'm a regular geek with tech as a hobby, Teamviewer doesn't trust our ability to pay for ourselves. If i was using Teamviewer for work, I'd gladly pay for it since I'd need 100% reliability for connections. 

    I'll get back to my point: Occasions like this is really bad from a business perspective. Services I need may be purchased at work, with company money, for company purposes if I need it for my work. If I'm facing problems using any service for personal or commercial use, the likelihood of the company licensing the software is getting smaller.

    I hope Teamviewer will revert the restiction as soon as possible, even though i dont actually need it. I've just gotten used with the comfort of putting my pc to sleep without leaving my bed or for taking a quick look at files from my NAS when I'm not at home.

  • Hi,
    I use TeamViewer to help my daughter or partner when they have a problem on their PC (not a commecial use at all), however a sign appeared to indicate that it have been detected I am making "commercial use", and their use have been blocked.
    What can I do?
    Thanks, best regards.

  • I'm getting the same issue, not using it commercially, but I'm still getting disconnected after 1 minute and with the annoying pop up saying I'm using it wrong. This happened once in the past and I was able to submit a ticket, now I just get redirected to Community as if this was a user error and not a flaw of the product. Please solve it asap!

  • Since these **bleep** are unable to produce a solution, here it is:

    Go to, log into your account, fill in a form, it will generate a PDF, print it, sign it, scan it and upload it. Yes, welcome to the 21st century.


  • I setup my elderly in-laws with TeamViewer (free for personal use) last year. Been working fine until today. Now I get "Connection blocked after timeout". They live in Florida and I live in NJ so helping them out, especially during a pandemic is important. I remote to their computer (unattended) about 3 times a month. What can be done to get this working normally again?


  • Hi,

    I have used Teamviewer for years without any issues until last year when I used it once at work to help out my mom, which is the only reason I have Teamviewer. I had no idea it would stop working because I was at my workplace.

    I created a new free account with another email and I have only used it once before. Today I tried using it again to help my mom and again I got the "connection timeout" error, even though I am at home.

    What can I do to fix this?! I'm tempted to create a third account but I have a feeling I will have the same issue.

    Please help me! This is the only way I have of helping my parents with their computer and phone issues.

  • This is ridiculous, happened to me now too.

    Switching to **Third Party Product**, have been using TV for so many years.

  • Here we go again.  Can't Teamviewer fire the guy that puts this in the updates.  This is not the first time TV has botched the upgrade and started flagging everyone as commercial.  I am another of the victims.  Personal use, family and friend help, no money being made anywhere.


  • bazbsg
    bazbsg Posts: 100 ✭✭

    @sammysooser They'd also avoid a lot of confusion if they used the dictionary definition of commercial:

    1. concerned with or engaged in commerce.
    2. making or intending to make a profit.

    Instead they are considering students at school as commercial. They are considering individuals checking their email at home commercial. Users that have a server OS are considered commercial. I've heard of people getting flagged as commercial just for using the Wifi in a hotel.

  • bazbsg
    bazbsg Posts: 100 ✭✭

    Wow. just now I tried to post a message and got an error. they asked me to fix it and post again. I did. then I got another error.

    • Post flooding detected (user tried to post more than 1 messages within 30 seconds)
  • Thank you!

  • ZUO
    ZUO Posts: 3

    So I guess this is the place where I complain about being blocked for "commerical usage". Been using TeamViewer to connect from one personal PC to another, both of which are on the same local network. Got blocked. Submitted a ticket and got a responce that they were unable to verify that I'm using it for personal purposes.

    Is there any way to make them actually fix this? I'm not going to mail that declaration of personal usage over mail and support is unhelpful.

  • Tymu
    Tymu Posts: 1

    I'm having the same problem. I submitted a ticket two weeks ago (at the advice of Teamviewer on Twitter), but I've heard nothing.  I dunno how to reset my account or how to show I'm using this at home)....dunno what to do :(

  • I'm using TeamViewer primarily from my Macbook (MacOS 10.13.6) to connect to an iMac (up-to-date Catalina). Whenever I connect, I first get a very fast notification along the lines of "There seems to be a Licensing issue with the other computer," but then the notification disappears and I connect. I have no problems while connected, but the session then times out after 1 minute, and I'm thanked for playing fair and using the "free trial".

    This seems similar to other questions I've seen, where people are told that "Commercial Use is Suspected," but I have received no such notification. My ID may have been flagged because I am on a university campus, but my usage truly is non-commercial. Have I been flagged for commercial use? Should I submit a ticket through that avenue? Or is there some other reason my sessions only last for one minute? Any help is appreciated.

  • It keeps thinking I'm using it for commercial use. Why not have a person subscription plan for us who only use it for non-profit? Something affordable like $9.99 a month. I only use it to connect to family and friends and also to connect to my 2 other computers in the same house.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!