Teamviewer is running an old version which is out of date / no connection anymore !!



  • GarryAnderson
    GarryAnderson Posts: 13 ✭✭

    I found a good alternative, by searching on line.  Previoulsy, when I posted the name of the alternative in these messages, such messages were deleted by the "though police" that operate the web-site.  Another example of how to destroy one's reputation.

  • EagleFlyFree
    EagleFlyFree Posts: 2 ✭✭

    and were you able to create a vpn remotely or not?(without the help of a person I mean)

  • GarryAnderson
    GarryAnderson Posts: 13 ✭✭

    To EagleFlyFree:  I am not sure exactly what you mean by your question, so let me answer it like this:  The desktop App that I found provides for Unattended Remote Access, after setting it up for same with a password for remote access.  So from my desktop, I click on a target machine and it automatically logs on to that computer, and then I have complete remote control, just like being at the remote desktop.  I can operate the remote machine and do file transfers both ways.  It can also be configured for non-unattended access, so that somebody needs to allow access.  When I close down the connection, it automatically disconnects.  The only bug with this App is the way it handles keystrokes that I send to it.  There are 2 or 3 ways to allow keys to be interpreted, and some modes block some keys (for some reason).  Try a Yahoo search for "unattended desktop help center" and see what you can find.  Sorry that I am restricted from telling you what App I found.  Garry Anderson at shaw dot ca.

  • Beniii
    Beniii Posts: 1

    Actually, I also have this problem.

    I tried reinstall, i tried install a lot of older versions of teamviewer.
    v3, v6, v8, v9, v10, v11, v12, v13, v14, v15
    The problem is the host user is, almost blind, she can not update her
    client version. And she is not has win 7 system administrator access, just for me.
    The "Covid-19" is limit me, to visit her.

    How can I solve it?
    What shall we do?

  • ahs613
    ahs613 Posts: 3 ✭✭

    I am getting this message too. I try to help a family member (age 94!) and updated TeamViewer on her Mac from version 9 to 12, the latest her computer can run. It cannot update further! I tried version 12 on my Mac, the oldest version I can run. Her TeamViewer ID seems to be prompting us to update TeamViewer, but that's not possible. The ID didn't change when I uninstalled the old version and reinstalled the new one, or when I deleted her account and logged in as me, or when I installed TeamViewer Host. How can I help her without buying a new computer that will run the latest version? Thanks.

  • francwalter
    francwalter Posts: 5 ✭✭

    Did you try an older version of **Third Party Product** already? I guess your family member might have OS X 10.9 (OS versions). [removed per Community Guidelines]

    In any case VNC must work, there are several clients for it and the VNC protocol didn't change since. With a repeater you can pass through the router's firewall but this is a bit tricky to install. But if your family member can press a button than a port forwarding will do it already.

    Good luck, frank

    PS.: TeamViewer is not very confident about their product. If I mention in this forum some other, concurrent product, they will automatically delete the name, so I had to mask it, see above **Third Party Product**. Look what happens if i write it in clear: **Third Party Product**

  • ajsmsg78
    ajsmsg78 Posts: 1

    No offense here but isn't the point of Teamviewer to give remote support?  If the other person has a virus or a full hard disk, etc which happens more frequently than you might think then they won't be able to receive remote support because of this " you have to update" implementation  which eliminates the point of providing remote support in the first place.  I'm surprised that TeamViewer developers would implement such an awful feature.  In fact it's preventing me from purchasing TeamViewer to use for my business because if it's not something that I can just click and connect with without the other person's interaction then it's not really that useful for me.

  • davidpelfrey
    davidpelfrey Posts: 1


    TV is mistakenly giving an incorrect warning because it wrongly thinks the remote computer is running a different version. The message is:

    "The remote TeamViewer is running an old version which is out of date. Therefore, you can not connect to this version anymore."

    I was at the remote computer's location yesterday, and updated TeamViewer 14 to the latest version 14.7.48298. I verified this version number after the install by using Apple's "get info" feature, which shows any file's version number.

    Today, I used the same .dmg installer to update Teamviewer 14 on my non-remote computer to the identical version 14.7.48298 (also verified).  Yet when I launch TV on the non-remote computer, I get the aforementioned warning message, which is clearly incorrect.

    Any ideas? Both computers are running Mac OS 10.12.6. Both versions of TV are the free one.





  • Ted_G
    Ted_G Posts: 1

    I am afraid this "solution" was of no help at all. I have appreciated the use of Teamviewer to remotely support my elderly father for several years now, but it has just stopped working.

    Even though we are both running the exact same Version 14.7.48298, from May 28, 2020, on Mac laptops , I can no longer connect and instead receive the Version out-of-date: Update the remote Teamviewer error message. Is this a software bug? Is there any solution or workout available?

    Any help you may be able to offer would be greatly appreciated. Thank You

  • davy36
    davy36 Posts: 1

    I am using Windows XP service pack3, when i try to connect to another device I get two messages (windows): "Version out-of-date:Update the remote TeamViewer" and "Impossibile to connect, unknown cause".

    Before that, just a week ago, I could connect but just for 5 minutes. That's started more or less a few months ago.

    TeamViewer version is 14.2.56676 on both devices (the controlled one is running Windows 10).

    May you do anything?

  • lidiawisniewska

    I did I install on both computers news version and still having the same message can't connect reason unknown??

  • erikfel
    erikfel Posts: 1

    I'm trying to connect to a Windows XP machine (TeamViewer V14.2) from Windows 10 machine (TeamViewer V15.11.6) and constantly receive an error message which says that the remote TeamViewer version must be updated however as the other machine runs on Windows XP later versions are not supported. how can I solve this issue?

  • Badcalli3
    Badcalli3 Posts: 4 ✭✭

    Teamviewer Loop: I try to log in to my remote device > "Version is out of date..." I have to update the remote device in order to access it > I can't log in to the remote device because it's not updated so I can't update it.

    They've taken what use to be just a challenge and made it impossible. I used to use it so I can access a device remotely. They don't have a method to update devices that you can't access, but they force you to update to connect. They have a "web interface" that is unusable because Google is phasing out their Chrome app.

    And they think this is fine. There's never a helpful response. I don't even use Teamviewer anymore.

  • melwakil
    melwakil Posts: 1

    @Natascha I need to remote to a Windows XP machine from Windows 10. Currently, both computers have TeamViewer 13 installed. As you may expect, I get the "Version out-of-date" error message.

    If I upgrade to a paid account, will I be able to connect to the XP computer?


  • Natascha
    Natascha Posts: 1,591 Moderator

    Hi @melwakil

    Thank you for your post and welcome to our community 😊

    If you have a licensed TeamViewer account, you will be able to connect to older versions and in your case to the XP computer.

    Please have a look at our article Which operating systems are supported in order to make sure to use the right OS and the compatible TeamViewer versions.

    Hope this could help. Wish you a great day.

    All the best,

    Natascha 🙋‍♀️

    German Community moderator 💙 Moderatorin der deutschsprachigen Community

  • Sunblood
    Sunblood Posts: 1

    I'm getting errors as of this morning stating that any client I attempt to connect to is out-of-date. I've verified all clients are using the latest Teamviewer. This is happening both to and from multiple different PCs. I've restarted TV clients on all machines but the error persists.

  • PieOPah
    PieOPah Posts: 1

    As of this afternoon, I have been getting a message saying I am running an old version which is out of date so am unable to connect.

    Both Host and Client have the latest version installed (although I get the same error when attempting to connect to my sisters machine - which I can't check).

    I also receive a connection error when attempting to use my Mobile Phone to connect.

    Is there a general issue at present (it was fine a coupe of hours ago)...

  • testas134
    testas134 Posts: 0

    I confirm the problem! Everywhere the current version of TeamViewer is installed and everywhere I see the message about the outdated version. It is impossible to connect!

    Team Viewer, are you sleeping there?

  • Sunblood
    Sunblood Posts: 1

    It just started working for me again after retrying connections a few times.

  • RodrigoTavares

    I am having the same issue with a raspberry PI, tried to reinstall the client but it didnt work.

  • mohamosa
    mohamosa Posts: 1

    when I try to connect to partner, I am getting this message

    version out-of-date: update the remote TeamViewer

    I am running the ver 15.14.5

    and the partner is not accessible.

  • DBquick
    DBquick Posts: 8 ✭✭

    Are both devices using the same version?

  • TheRidgeback
    TheRidgeback Posts: 5 ✭✭

    I was connected this morning to my home Mac in spain. with no issues

    I tried to connect this afternoon and i get the following error.

    Saying version out of date,

    I tried to connect to my wifes, same answer.

    My laptop is running 15.14.5

    I managed to connect to my mac using my phone I then checked what version i was using on the mac.

    The same version is running on my mac 15.14.5.

    Heres the strange thing, i then tried to connect using my laptop and it connected without the error.

    I repeated this on the wifes laptop as well. all ok

    Was there an issue with your server connections rejecting clients or is this a bug?

    Cheers Mac.

  • mohamosa
    mohamosa Posts: 1


    this error is solved automatically I can connect now.


  • Beamishino
    Beamishino Posts: 3 ✭✭
    edited February 2021

    @Natascha I have the latest version of teamviewer (free) on both my remote PC and the one I am using; both are on windows 10. I was using it, then I rebooted the remote computer and started getting this message point blank.

    How do I fix this?

  • TVD
    TVD Posts: 0

    I have exactly the same issue. Worling on a free license.

    Worked great even yesterday, today I got the message (alltough both where running the same version).

    Then I upgraded, first the client side, no succes, then the "server" side, no succes. Then I restarted both computers. Still no acces, same message keeps popping up.

    Running version 15.15.5 on both systems now

    What to do to solve this???

  • sn50
    sn50 Posts: 4 ✭✭

    Exactly same issue. Started today.

  • TVD
    TVD Posts: 0

    I had a brief chat with a commercial guy via their website. He confirmed me that I was allready the fifth person in a very short time.

    He asked me a few things to check but as he was no support engineer could not be of much help. He was however going to escalate things internally.

    Also on Twitter there where people complaining.

    So as we are not the only ones, I guess a major issue is going on at TV, that should (hopefully) be solved soon ...

    Fingers crossed!

  • HPCC
    HPCC Posts: 0

    Same issue too. Started today.

  • SimonH_UK
    SimonH_UK Posts: 0

    Same issue here too, it's instant, it doesn't even try to connect or timeout, an instant failure.

    Tried 3 remote machines and my Mac and AWS Windows box as a test. Nada. showing no issues but there def are.