Commercial use - Connection time out



  • breese
    breese Posts: 4




  • my license is block. why?

  • So this just happened again today. I rarely use TeamViewer, but by the time I need it away from home, this happens! Takes forever to get fixed. I don't get why this happens. I am just a home user using this to accessing my personal computers from other personal devices. This time from my phone from a hotel to my house. Do I need to create a new post ever time this happens? 

  • how do you connect with Team viewer to get the account reset to free?  What URL?  What phone number

  • TV.JPGI keep keep getting blocked on my free version. I only use this for personal use. Very very frustrating!




  • breese
    breese Posts: 4

    I feel your pain.

    Today I got an email from support (below) and now I get the "Connection Blocked error message"!!!

    Dear User,

    Thank you very much for sending your self-declaration of private use to us.
    We have successfully reset the TeamViewer ID(s) you submitted via the form provided earlier.
    We acknowledge that you are using TeamViewer for private use only on these devices.

  • IrvSp
    IrvSp Posts: 7

    It seems we've all gotten one or two RESET emails. I got 2, one from the PDF I had to d./l, print the last page, sign it, and then upload to TV where I got the d/l from and the on-line Private USE reset page.

    In both cases the reply was I am a PRIVATE user and a RESET was done. However I still get one of two popups when I try to use TV.  Either I have too many connections (I think) or I am a Commercial user and buy a license.

  • ACEkin
    ACEkin Posts: 6

    I am wondering whether any TeamViewer support staff look at these posts and offer answers or is this some sort of a venting block? I was hoping to hear from TeamViewer by now, what is the sense of talking to each other without getting any solutions. TeamViewer please let me, and possibly others, to know whether there will be a solution to this problem or not.

    Thank you,

    Cemal Ekin

  • Same thing just happened to me.  What can be done to resolve this?

  • This is an issue with my main PC that I use on a daily basis. 

    I submitted a Commercial Use detected ticket twice and received responses that everything was resolved except I am still getting the message “You connection has been blocked because of very high activity level.” In addition to creating 2 tickets, I also replied to the resolution emails and did not received any response.  I rebooted the computer and also trues uninstalling and installing Teamviewer.

    I also tried connection to the same remote Team ID from a different computer and no issues… so it is not that a remote ID was blocked. 

    I only use this computer to help my parents, remotely, with their PC issues.  This Team ID that is being blocked has been used for quite a few years.  The only thing I can think of that may have caused this high usage is that I left a connection open to one of the PC overnight.

    Any recommendation as I tried calling TeamViewer and I do not get to speak with support as I am a free User.

  • I did send them the signed form. Four days later and still no resolution.

    What a pain!!! 

  • d3x0r
    d3x0r Posts: 5


    Goes to a 502 bad gateway.

    Submit support ticket only goes to community forum.

    This computer says 'timeout immediately'

    the other computer gave me  a 5 minute timeout, between the same two computers (one upstairs and one downstairs)

    Was trying to help my friend solve a database issue; but I don't get paid for that.

    WIsh I knew when I was going to trigger going to commercial mode so i can prevent doing so... I'm not connecting to any commercial liscense things.

  • I filled and signed the PDF. Went to upload and then 502 Bad Gateway. And now I can't submit the PDF. This happens to me at least once a year and I rarely use it. And only for personal use for helping my family such as my kids, wife, and mom. Whether it's home work or answering questions. This is so silly that Teamviewer can't get it right with detecting commecial use.

  • Worked great logging in from laptop to my mom's house computer for the 1st few months, now it wont let me on for over 30seconds then kicks me off saying 'seems like commercial access',  I also have it also installed on my phone to connect to home too and that never says anything of the sort, and nothing is commercial at all  about any of my computers or useage. Of course I need to be able to get on with the laptop for typing and being able to see everything, phones are too small. How can I confirm this is NOT commercial and egt rid of this error blocking my use?? PLEASE HELP!!

  • This is my second time submitting this because apparently the community portal is also broken. I am finally sitting down and trying to submit one of your non-commerical use forms at this page:

    I have been flagged for commerical use for absolutely no reason as I am using TeamViewer on personal devices. I cannot even generate the required PDF form to start an investigation though because I get a 'bad gateway'. Can someone fix this?

    Error I'm getting: TeamViewer.Bad.Gateway.png


  • I AM HAVING THE SAME ISSUE.  I STOPPED USING THEM IN 2019  IN MAY!!!! AND THEY ARE STILL BILLING ME!  CLAIRE M SCHAPIRO.  YOU CAN REACH ME AT  [The personal information has been removed as per the community guidelines. ]

  • ACEkin
    ACEkin Posts: 6

    I have the latest version of TeamViewer and Windows 10. The only thing I can say is I cannot connect to help my friend. TeamViewer blocks me with "commercial use detected" and "too many connections" or "too much activity". I reported this and sought help twice and twice I got a reply from TeamViewer staff that my account was unblocked. But there is still no way to connect to offer help.

    If I may also report that the lack of response from TeamViewer support to all the similar complaints is disheartening, especially these days when we cannot simply visit our friends to help them.

    Your definitive reply to all who seek help for similar problems will be a huge welcome. That is if you see it in TeamViewer to help the community. It is in its name!

  • Josette
    Josette Posts: 18 ✭✭

    I was told, and I wish I were joking, that it's a different department.

    @bazbsg wrote:

    @Josette Too bad the management doesn't authorize the moderators to spend time to help solve the problem instead of tidying up the message board.


  • I still haven't heard a word from TV... I filled out their form, signed it, sent it back and crickets... I don't get it. I maybe, MAYBE use it twice a month, if that, sometimes months go by without using it. There is absolutely no reason I should have been suspicious of "high activity". AFTER a decade of use, on a personal account and on a commercial account, completely separate from each other, **bleep** the commercial account wasn't ever used on any of my personal computers, this **bleep** happens. Well guess what TV, that commercial account is researching other corporate level RDPs, because of my issue and other support issues they have already been having with you. Your actions are immoral, if you just want to do away with free accounts, then be honest with those of us who follow the rules and use it for personal reasons. Don't play these nasty games, hoping we will just buckle and pay for a service, after years of free use. We won't play that game, especially when there are other free alternatives, or in my case, built-in RDP on my windows licenses.
    Your "BLEEP" filters are over the top! See image as for the "bad" words they filtered... WOW!



  • bazbsg
    bazbsg Posts: 112 ✭✭

    @Josette I dont doubt it at all. It's a standard trick to avoid responsibility for a decision. The department that can talk to you doesn't have the authority to fix the problem. And you cannot talk to the department that made the decision and has the authority.

  • GaryZ
    GaryZ Posts: 1

    I'm curious if we can find a common thread that TV finds to flag *LEGITIMATE* free users as commercial. For example, my usage is:

    • Typically from a Windows 10 Pro machine
      • Running Docker Desktop and Hyper V images for work
    • Accessing Windows 10 Home machines on my home network over both hard wire and *multiple* wireless networks since I can't use RDP and dislike the other popular option 
    • Helping my ederly father and in-laws with their Windows 10 machines and Android devices - This one is the key reason I'm using TV

    My hunch is something to do with Docker and/or my constantly changing networking profile. Anyone else who's been flagged care to share their environment without any identifying details?

    I've been using TeamViewer for years with no problems not sure why all of a sudden I keep getting flagged, but this last flag was the end of my efforts. There's other options I can utilize that may not be as convenient but work.

  • Keifus
    Keifus Posts: 4 ✭✭

    i keep getting 5 minute will disconnect, I had this issue before when the person I was connecting to didnt use the personal version, how can I fix this please? Thank yoiu

  • JL7
    JL7 Posts: 2

    Hi, i tried to connect to my parents computer remotely for the first time in months and i received the message of commercial use detected. I only use teamviewer to help them when i'm away. After some research on the website, i can't find a way to request a reset of my account (link doesn't work in the Knowledge base) and i can't create a ticket. Is there an other way to remove the commercial use flag from my ID?


  • When I click on the reset link to try to begin the process of requesting that my incoorrect "commercial use" flag be removed all I get is a web page that says:

    502 Bad Gateway

  • Here is the link I found to request your ID to be reset.

    It would seem the Teamviewer developement team has been directed recently to crack down on free accounts to generate more revenue.  I have a commercial account for work and my personal account for personal (free) use and it is mixing them up when I use my personal login on my work PC.  To give them credit I may have logged in my commercial account on my personal PC to access a customer site.  I am guessing this is the problem as I thought my work account is registered as a commercial account, but my PC has a free version of the software installed.

    I am already looking into finding something else to support my family at home.  Will probably do the same for my work account because the software has been imposing rules and limit on that account as well that I didn't know existed before.

  • same issue, I one of my connections is flagged as commercial use detected, but I can't unlock it!

  • Hi,

    I was trying to connect from my phone to my personal PC (as I always do) which is a free license and 100% personal use. I've had this acount probably for over a decade but today I got an error saying "Commercial Use Detected".

    So I googled and found out that I can report incorrect commercial detection using this link:


    Unfortunately this link doesn't work and show a 502 Bad Gateway.


    What's the next step for fixing this?

    I'd like to stay on free.



  • I got this  message too today! Wanted to help my uncle as I always did for the past couple of years.

  • Thw0rted
    Thw0rted Posts: 14 ✭✭

    @GaryZ )

    TeamViewer has a pretty broad definition of "commercial use", which includes working for a non-profit, certain kinds of school use, etc.  (Also, any use of a "server" OS falls under the "commercial" side.)

    You can find more discussion of this a few pages back, but it's possible that connecting from your work machine to your home PC, though obviously for "personal" use, still taints the connection as "commercial" because it's your work system on one end.  I studiously avoid touching any of my personal systems from a work system.

    It really would be great if mods would pop in here from time to time to at least clarify the official policy, but in the meantime we can try to figure it out for ourselves.

  • Thw0rted
    Thw0rted Posts: 14 ✭✭

    @KGUD-Production )

    This is an example of what I mentioned in my previous message -- 501c3 charities are not excluded from TV's definition of "commercial" and they do expect you to pay for a commercial license to use TV with your charity's computers.  I won't bother suggesting a specific alternative product because that's against the board rules here, but it's safe to say that there are better value-for-money alternatives for a small team like you're describing.  It'd be great if TV made the product free for charity use (or at least charity under a certain size), or had a lower-cost / more-restricted price tier available, but they don't.