link icon
Ask The Community

Commercial use - Connection time out



  • ACEkin
    ACEkin Posts: 6

    I have the latest version of TeamViewer and Windows 10. The only thing I can say is I cannot connect to help my friend. TeamViewer blocks me with "commercial use detected" and "too many connections" or "too much activity". I reported this and sought help twice and twice I got a reply from TeamViewer staff that my account was unblocked. But there is still no way to connect to offer help.

    If I may also report that the lack of response from TeamViewer support to all the similar complaints is disheartening, especially these days when we cannot simply visit our friends to help them.

    Your definitive reply to all who seek help for similar problems will be a huge welcome. That is if you see it in TeamViewer to help the community. It is in its name!

  • I was told, and I wish I were joking, that it's a different department.

    @bazbsg wrote:

    @Josette Too bad the management doesn't authorize the moderators to spend time to help solve the problem instead of tidying up the message board.


  • I still haven't heard a word from TV... I filled out their form, signed it, sent it back and crickets... I don't get it. I maybe, MAYBE use it twice a month, if that, sometimes months go by without using it. There is absolutely no reason I should have been suspicious of "high activity". AFTER a decade of use, on a personal account and on a commercial account, completely separate from each other, **bleep** the commercial account wasn't ever used on any of my personal computers, this **bleep** happens. Well guess what TV, that commercial account is researching other corporate level RDPs, because of my issue and other support issues they have already been having with you. Your actions are immoral, if you just want to do away with free accounts, then be honest with those of us who follow the rules and use it for personal reasons. Don't play these nasty games, hoping we will just buckle and pay for a service, after years of free use. We won't play that game, especially when there are other free alternatives, or in my case, built-in RDP on my windows licenses.
    Your "BLEEP" filters are over the top! See image as for the "bad" words they filtered... WOW!



  • bazbsg
    bazbsg Posts: 103 ✭✭

    @Josette I dont doubt it at all. It's a standard trick to avoid responsibility for a decision. The department that can talk to you doesn't have the authority to fix the problem. And you cannot talk to the department that made the decision and has the authority.

  • GaryZ
    GaryZ Posts: 1

    I'm curious if we can find a common thread that TV finds to flag *LEGITIMATE* free users as commercial. For example, my usage is:

    • Typically from a Windows 10 Pro machine
      • Running Docker Desktop and Hyper V images for work
    • Accessing Windows 10 Home machines on my home network over both hard wire and *multiple* wireless networks since I can't use RDP and dislike the other popular option 
    • Helping my ederly father and in-laws with their Windows 10 machines and Android devices - This one is the key reason I'm using TV

    My hunch is something to do with Docker and/or my constantly changing networking profile. Anyone else who's been flagged care to share their environment without any identifying details?

    I've been using TeamViewer for years with no problems not sure why all of a sudden I keep getting flagged, but this last flag was the end of my efforts. There's other options I can utilize that may not be as convenient but work.

  • Keifus
    Keifus Posts: 4 ✭✭

    i keep getting 5 minute will disconnect, I had this issue before when the person I was connecting to didnt use the personal version, how can I fix this please? Thank yoiu

  • JL7
    JL7 Posts: 2

    Hi, i tried to connect to my parents computer remotely for the first time in months and i received the message of commercial use detected. I only use teamviewer to help them when i'm away. After some research on the website, i can't find a way to request a reset of my account (link doesn't work in the Knowledge base) and i can't create a ticket. Is there an other way to remove the commercial use flag from my ID?


  • When I click on the reset link to try to begin the process of requesting that my incoorrect "commercial use" flag be removed all I get is a web page that says:

    502 Bad Gateway

  • Here is the link I found to request your ID to be reset.

    It would seem the Teamviewer developement team has been directed recently to crack down on free accounts to generate more revenue.  I have a commercial account for work and my personal account for personal (free) use and it is mixing them up when I use my personal login on my work PC.  To give them credit I may have logged in my commercial account on my personal PC to access a customer site.  I am guessing this is the problem as I thought my work account is registered as a commercial account, but my PC has a free version of the software installed.

    I am already looking into finding something else to support my family at home.  Will probably do the same for my work account because the software has been imposing rules and limit on that account as well that I didn't know existed before.

  • same issue, I one of my connections is flagged as commercial use detected, but I can't unlock it!

  • Hi,

    I was trying to connect from my phone to my personal PC (as I always do) which is a free license and 100% personal use. I've had this acount probably for over a decade but today I got an error saying "Commercial Use Detected".

    So I googled and found out that I can report incorrect commercial detection using this link:


    Unfortunately this link doesn't work and show a 502 Bad Gateway.


    What's the next step for fixing this?

    I'd like to stay on free.



  • I got this  message too today! Wanted to help my uncle as I always did for the past couple of years.

  • Thw0rted
    Thw0rted Posts: 14 ✭✭

    @GaryZ )

    TeamViewer has a pretty broad definition of "commercial use", which includes working for a non-profit, certain kinds of school use, etc.  (Also, any use of a "server" OS falls under the "commercial" side.)

    You can find more discussion of this a few pages back, but it's possible that connecting from your work machine to your home PC, though obviously for "personal" use, still taints the connection as "commercial" because it's your work system on one end.  I studiously avoid touching any of my personal systems from a work system.

    It really would be great if mods would pop in here from time to time to at least clarify the official policy, but in the meantime we can try to figure it out for ourselves.

  • Thw0rted
    Thw0rted Posts: 14 ✭✭

    @KGUD-Production )

    This is an example of what I mentioned in my previous message -- 501c3 charities are not excluded from TV's definition of "commercial" and they do expect you to pay for a commercial license to use TV with your charity's computers.  I won't bother suggesting a specific alternative product because that's against the board rules here, but it's safe to say that there are better value-for-money alternatives for a small team like you're describing.  It'd be great if TV made the product free for charity use (or at least charity under a certain size), or had a lower-cost / more-restricted price tier available, but they don't.

  • CoolRaoul
    CoolRaoul Posts: 6 ✭✭

    @Thw0rted wrote:

    @GaryZ )

    It really would be great if mods would pop in here from time to time to at least clarify the official policy, but in the meantime we can try to figure it out for ourselves.

    Already asked several times, and, as long as I remember, no official answer has been posted ever.

    I'm totally OK to accept restriction on free usage of a commercial product (and that how I'm using it, exclusively providing remote help from time to time to a very small number of family members and friends) but I really don't understand the lack of a clear specification of what is allowed and what is not (I've already been locked once, still trying to understand the exact reason)

    The rules have to exist since they have to be implemented in the app code, so why not having them explicitly and easily available to everyone?

  • There is no figuring it out. It is 100% on their end and they are purposely ignoring us. They know all of this. I've taken to talking to their support publicly on Twitter.

    And being on my laptop in bed TVing to my desktop in the family room in the same house is not commercial in any way, shape or form.

  • Krisavi
    Krisavi Posts: 4 ✭✭

    My account has been locked more than once now.
    One time it was because I had machine called "Server" in the machines list. It is home server running debian. This was just after they had added the restriction of server OS being a no-no. However what is a server OS? Debian can be desktop OS as well, but I decided to remove that machine from my list as I have other means to access home server and do not need TeamViewer for it. Felt that it was more aligned to their accepted noncommercial usages to remove that machine from the list.

    2nd time they just locked because they suspected commercial usage when I connected from my phone to on of my home PC. Not sure why, but I guess they had problem with me having 14 devices in my account list. 4 being my own computers or phone and rest being family members devices where I occasionally provide IT help for absolutely nothing. Maybe sometimes I get a "thank you", but not always, never recieved a penny or even box of candies for the help provided.

    3rd time, when my account got some issues was when I used work computer that has commercial license for TV to connect to machine that was not under commercial license. No problems connecting, but after that they were thinking my home computer cannot be under free license because it was accessed from a commercial license once. Learned from it not to connect from licensed account to machines connected to free licence accounts. Even though it seemed to be something I was free to do with commercial license. If I am right then the origin machine license mattered.

    4th time I got locked in was when I used my personal laptop at work to connect to home PC during my lunch break. Appearantly you are not allowed to connect from "work network" or it will be commercial use. I was using company "guest" network and not the company network meant for employees on my personal laptop, but I guess they have the endpoint IP registered as commercial location I guess. So next time I had to connect I was using mobile hotspot connection if I needed to use personal laptop in order to access home PC. 

    Today my relative asked help with her tablet. I asked her to start up the Teamviewer Host that is up to date according to Play Store, but to my surprise Teamviewer does not let me access it, "Remote is using earlier version of Teamviewer, In order to upgrade check that link" and points to link how to upgrade teamviewer on PC... I cannot update TV host when they do not update it in play store. There is no way for me to update the version to latest. 

    Using TV free license is like being on minefield, you never know when something blows up in your face again. Due to all that I have started to use alternative software between my computers and from phone to computer connections. Only real reason I need teamviewer is the computer to phone or tablet connections, but as I described earlier, that doesn't even seem to work any more because of their version restriction and them not supporting the older android version I might need to connect once in 6 months to give assistance in using the device.

  • When I connect to my (88 yeard-old) mother's iPad from my Mac I am able to follow along and see her screen for a few minutes but then it is as if I get disconnected even though it shows still connected at her end. I can no longer see her screen changing. I do not want to manager her iPad remotely but just want to be able to see what she sees so that I can help her with her iPad. I know in earlier releases it would disconnect as soon as she pressed her home button but this newer version seems to survive that. Are we doing somethingwrong or does it always only connect for a short time?

    It doesn't make sense for us to pay close to $50/month for the IT admin version of Teamviewer/Quicksupport. 




  • Got flagged as suspected commercial use and submitted the requested form for reset. 

    Is there any type of visiable case tracking on this?  I've gotten no confirmation email or teamviewer message. 

    If I re-login to the reset page it just tells me its pending.   

    Thank you.

  • I have a free version and was blocked for commercial use. I reached out to team viewer and they sent me an email saying it was corrected but it was not. How do I open a support ticket for the free version? They told me the website name over the phone but I forgot it. I responded to the email they sent me but they never respond it has been over 2 weeks. 

  • Hi ACEkin,

    Thanks for the suggestion and the instructions which seem very simple to implement :-). Unfortunately, my Dad is 89 and not up to doing his side of the installs but I'll be able to do it for him when I next visit him in Poland, which due to Covid restrictions on travel there and here will need to wait until after Xmas :-(

    At least we have an easy way forward thanks to your tip.

    Cheers and have a great day.


  • My account was wrongly accused of being used for commercial use, which has been fixed. But afterwards, my main desktop is unable to make outgoing connections to control the remote computers. The main desktop also cannot be connect to from other pcs, but I can connect from my phone. All other devices can connect to each other, except my main pc.

  • I use the free version and recently updated and only connect to 1 computer in another location and everytime I connect - I get disconnect in less than 2 minutes and then I get a message cannot reconnect for 1 minute and this goes on for a few minutes and it starts all over again.

  • Not only TV blocks connections but also useful information! Shame! The answer lies at Kept Light Photography. This may be removed by the blockers too. This is not to provide help and support. I am not sure who, but someone should be ashamed of this behavior. Not providing any help and blocking potentially useful information. True colors are showing!

    Cemal Ekin

  • By the way, the fact that you are removing useful information shows that you see the questions and pleas for help and still keeping quiet and silent. Is there any reason for this silence? Or are we not allowed to ask questions like this?

    Cemal Ekin

  • @George1957  I hope you get to help your father in Poland.

    Cemal Ekin

  • Thanks Cemal, still working on it.

    Currently I get TV connection to Dad for a minute before it disconnects, but it's just long enough to open his Skype and switch on its screen sharing. TV then disconnects but Skype connection stays on thereafter. I can't take control via Skype but at least I can talk him through most of his simpler pc problems so that will just have to do until I can visit him sometime in early 2021 when travel restrictions are lifted.

    Cheers and have a great day.


  • I installed the free version on my home computer and on my remote computer. When I try to connect with the home computer, it kicks me out after about 20 seconds saying my session has timed out. I can reconnect immediately but the same thing happens again. Any suggestions?

  • leoizzo
    leoizzo Posts: 1 ✭✭

    Hi TeamViewer,

    I've been using Team Viewer app for years either to connect between my laptop and my home office or to help my mom who lives in a different country. Only Personal use not commercial. this morning I got a message saying my account was turned into a Commercial one and I have only 5 minutes before got blocked. I tried everything to fix it but not success. Could you guys please help me to get my personal use only access back again?


  • I am having almost the same exact problem except I can't connect at all... please help. I tried to fill out the form to get it fixed but it keeps returning an error.