Commercial use - Connection time out



  • CoolRaoul
    CoolRaoul Posts: 6 ✭✭

    @Thw0rted wrote:

    @GaryZ )

    It really would be great if mods would pop in here from time to time to at least clarify the official policy, but in the meantime we can try to figure it out for ourselves.

    Already asked several times, and, as long as I remember, no official answer has been posted ever.

    I'm totally OK to accept restriction on free usage of a commercial product (and that how I'm using it, exclusively providing remote help from time to time to a very small number of family members and friends) but I really don't understand the lack of a clear specification of what is allowed and what is not (I've already been locked once, still trying to understand the exact reason)

    The rules have to exist since they have to be implemented in the app code, so why not having them explicitly and easily available to everyone?

  • Josette
    Josette Posts: 18 ✭✭

    There is no figuring it out. It is 100% on their end and they are purposely ignoring us. They know all of this. I've taken to talking to their support publicly on Twitter.

    And being on my laptop in bed TVing to my desktop in the family room in the same house is not commercial in any way, shape or form.

  • Krisavi
    Krisavi Posts: 4 ✭✭

    My account has been locked more than once now.
    One time it was because I had machine called "Server" in the machines list. It is home server running debian. This was just after they had added the restriction of server OS being a no-no. However what is a server OS? Debian can be desktop OS as well, but I decided to remove that machine from my list as I have other means to access home server and do not need TeamViewer for it. Felt that it was more aligned to their accepted noncommercial usages to remove that machine from the list.

    2nd time they just locked because they suspected commercial usage when I connected from my phone to on of my home PC. Not sure why, but I guess they had problem with me having 14 devices in my account list. 4 being my own computers or phone and rest being family members devices where I occasionally provide IT help for absolutely nothing. Maybe sometimes I get a "thank you", but not always, never recieved a penny or even box of candies for the help provided.

    3rd time, when my account got some issues was when I used work computer that has commercial license for TV to connect to machine that was not under commercial license. No problems connecting, but after that they were thinking my home computer cannot be under free license because it was accessed from a commercial license once. Learned from it not to connect from licensed account to machines connected to free licence accounts. Even though it seemed to be something I was free to do with commercial license. If I am right then the origin machine license mattered.

    4th time I got locked in was when I used my personal laptop at work to connect to home PC during my lunch break. Appearantly you are not allowed to connect from "work network" or it will be commercial use. I was using company "guest" network and not the company network meant for employees on my personal laptop, but I guess they have the endpoint IP registered as commercial location I guess. So next time I had to connect I was using mobile hotspot connection if I needed to use personal laptop in order to access home PC. 

    Today my relative asked help with her tablet. I asked her to start up the Teamviewer Host that is up to date according to Play Store, but to my surprise Teamviewer does not let me access it, "Remote is using earlier version of Teamviewer, In order to upgrade check that link" and points to link how to upgrade teamviewer on PC... I cannot update TV host when they do not update it in play store. There is no way for me to update the version to latest. 

    Using TV free license is like being on minefield, you never know when something blows up in your face again. Due to all that I have started to use alternative software between my computers and from phone to computer connections. Only real reason I need teamviewer is the computer to phone or tablet connections, but as I described earlier, that doesn't even seem to work any more because of their version restriction and them not supporting the older android version I might need to connect once in 6 months to give assistance in using the device.

  • When I connect to my (88 yeard-old) mother's iPad from my Mac I am able to follow along and see her screen for a few minutes but then it is as if I get disconnected even though it shows still connected at her end. I can no longer see her screen changing. I do not want to manager her iPad remotely but just want to be able to see what she sees so that I can help her with her iPad. I know in earlier releases it would disconnect as soon as she pressed her home button but this newer version seems to survive that. Are we doing somethingwrong or does it always only connect for a short time?

    It doesn't make sense for us to pay close to $50/month for the IT admin version of Teamviewer/Quicksupport. 




  • Got flagged as suspected commercial use and submitted the requested form for reset. 

    Is there any type of visiable case tracking on this?  I've gotten no confirmation email or teamviewer message. 

    If I re-login to the reset page it just tells me its pending.   

    Thank you.

  • I have a free version and was blocked for commercial use. I reached out to team viewer and they sent me an email saying it was corrected but it was not. How do I open a support ticket for the free version? They told me the website name over the phone but I forgot it. I responded to the email they sent me but they never respond it has been over 2 weeks. 

  • George1957
    George1957 Posts: 4 ✭✭

    Hi ACEkin,

    Thanks for the suggestion and the instructions which seem very simple to implement :-). Unfortunately, my Dad is 89 and not up to doing his side of the installs but I'll be able to do it for him when I next visit him in Poland, which due to Covid restrictions on travel there and here will need to wait until after Xmas :-(

    At least we have an easy way forward thanks to your tip.

    Cheers and have a great day.


  • My account was wrongly accused of being used for commercial use, which has been fixed. But afterwards, my main desktop is unable to make outgoing connections to control the remote computers. The main desktop also cannot be connect to from other pcs, but I can connect from my phone. All other devices can connect to each other, except my main pc.

  • I use the free version and recently updated and only connect to 1 computer in another location and everytime I connect - I get disconnect in less than 2 minutes and then I get a message cannot reconnect for 1 minute and this goes on for a few minutes and it starts all over again.

  • Not only TV blocks connections but also useful information! Shame! The answer lies at Kept Light Photography. This may be removed by the blockers too. This is not to provide help and support. I am not sure who, but someone should be ashamed of this behavior. Not providing any help and blocking potentially useful information. True colors are showing!

    Cemal Ekin

  • By the way, the fact that you are removing useful information shows that you see the questions and pleas for help and still keeping quiet and silent. Is there any reason for this silence? Or are we not allowed to ask questions like this?

    Cemal Ekin

  • @George1957  I hope you get to help your father in Poland.

    Cemal Ekin

  • George1957
    George1957 Posts: 4 ✭✭

    Thanks Cemal, still working on it.

    Currently I get TV connection to Dad for a minute before it disconnects, but it's just long enough to open his Skype and switch on its screen sharing. TV then disconnects but Skype connection stays on thereafter. I can't take control via Skype but at least I can talk him through most of his simpler pc problems so that will just have to do until I can visit him sometime in early 2021 when travel restrictions are lifted.

    Cheers and have a great day.


  • I installed the free version on my home computer and on my remote computer. When I try to connect with the home computer, it kicks me out after about 20 seconds saying my session has timed out. I can reconnect immediately but the same thing happens again. Any suggestions?

  • leoizzo
    leoizzo Posts: 1 ✭✭

    Hi TeamViewer,

    I've been using Team Viewer app for years either to connect between my laptop and my home office or to help my mom who lives in a different country. Only Personal use not commercial. this morning I got a message saying my account was turned into a Commercial one and I have only 5 minutes before got blocked. I tried everything to fix it but not success. Could you guys please help me to get my personal use only access back again?


  • I am having almost the same exact problem except I can't connect at all... please help. I tried to fill out the form to get it fixed but it keeps returning an error.

  • I received an email saying my Teamviewer ID has been successfully reset, but when I try to connect to my remote computer I still am flagged as a commercial user. I tried to submit another reset request for my remote computer's Teamviewer ID, but the website says "Your request has already been submitted and is pending further review. Thank you for your patience as we process your request."

    Please help!

  • MsBee
    MsBee Posts: 1

    I use this to support my 87 year old mom who lives in another state.  I followed the steps to get my ID reset and cannot reach the form.  I am getting the error "504 Gateway Time-out" when the form should appear.  The message above that states, "Sorry, that page is missing.  Do you want to check if a saved version is available on the Wayback Machine?"  If I click "Check for saved versions" apparently the wayback machine can't find it either.  I have tried this on both Brave and Chrome browsers, still can't get there from here.  Any suggestions?


  • same

  • I have happily used TeamViewer for more than a year to access my home computer's Plex library and to remote access my kid's laptops to monitor what they are doing when I'm out of the house and troubleshoot issues they may have when uploading their school assignments. Today, when attempting to troubleshoot an issue my son was having with his laptop I received the following message:

    "This software seems to used in commercial environments. Please note that the free version may only be used for personal use."

    "Your session will be terminated after 5 minutes. Please check our web site for further information"

    I do not have any commercial business to conduct in any way, much less remotely, so I do not know why I am receiving this message. Also, while I was still able to login to my son's laptop I was disconnected after less than 60 seconds and blocked from logging in again for nearly 10 minutes. Then, when I was able to login I was again disconnected after less than 60 seconds.

    Does anyone have any ideas?

  • Greetings, I keep getting the commercial use notice but I only use the application to help family/friends with problems as well as to transfer files from one of my systems to another of my systems, I have three systems. How do I get teamviewer to verify this?

  • same issue here. I use TV on my personal laptop at home, and only use it to support my mother who is 80 years old and doesn't live near me. Not sure why TV thinks I am commercial use.

  • Unfortunately I'm now a victim of this as well. This is absolutely a terrible idea, during the pandemic. 

  • Getting same issue with my iphone...

  • FWIW:  got the same message today, Chrome and FF, both latest versions.  Windows 10, just updated.

  • Hello I am using the free license (non comercial use only account) until today I had no problem accessing my home computer from my laptop. Today I logged in and then got this message after it logged me out of my PC,  "Connection blocked after timeout. Your license limits the maximum session duration to a partner, imediate reconnects are blocked. Please try agian later or upgrade your license".Was there a policy change? I have been using this free account for years with no issues. Thanks for any help

  • My computer was initially identified as "Commercial use" about a year ago. I requested a reset, because I never get a single penny from this use and I got it. After this reset some months ago, I again got the message that I was using it commercially. I requestaed again a reset for my computers and I received it a few days ago. But just one of my computers kept giving off the message of commercial use. I requested again (third time) a reset, but this is not being done. I even received a link that is sending me (after asking to log in) to a "Bad gateway". 

    Is there a way to be able to use TeamViewer as "Private use" without all these issues? If following all the requested steps does not solve the problem, what should I do?

  • klefr
    klefr Posts: 1

    For the second time, my connections throught Teamviewer free were cut-off with accusations of commercial activity.  I mostly use Teamviewer to communicate with the computer at the telescope in my backyard while I control and monitor the activity from indoors.  With the Teamviewer connection disabled I lost both nights observing and photographing activities.  

    I understand that you need to monitor for users using the Teamviewer inappropriately.  But couldn't you give a warning and a chance to respond without cutting it off withiout notice?

    Also, your procedure to cure the problem is unreasonable.  You requiire that I find some hidden links to request a form (and yesterday this did not respond for a couple hours, giving broken or time-out links).  Then print a form, sign it and scan it adn upload.  Not everyone has a printer and scanner.  I bought a car over the web using digital signing and didn't need a printer and scanner.

    While you have reenabled my access to Teamviewer, I am unhappy that you have cost me two nights of astronomical observing.  I am now looking into moving to **Third Party Product** to see how they stack up.

    Fred Klein

  • I am affected also, and submitted the form. However, there's no ETA on when this will get resolved. This is absolutely inexcusable to do to people during a pandemic and worldwide crisis where people rely on your software/service to support their families. 

  • Same problem here. I have already requested the reset, submitted the "affidavit" and received a response that it was received and a reset done, yet I still get the commercial warning and quick lockdown.