link icon
Ask The Community

landscape mode touch position wrong

Hello, so I connect to my Samsung Galaxy S10 via Team Viewer from my PC. Whenever I turn the display into landscape mode I can no longer control it because the taps happen somewhere totally elsewhere then where I aim with my mouse! Seems like coordinates somehow don't get translated from portrait to landscape mode.



  • so I see nobody cares...

    Meanwhile I found a workaround and it's software called SCRCPY which works nice via cable connection

  • brettborowski
    brettborowski Posts: 2 ✭✭

    I have the same issue with an SM-T510 "Tab A 10.1 (2019)" tablet. It's like the touches get scaled by the opposite width/height. Touching the control box upper left is fine. Touched it lower left puts the cursor on the left edge but only about 66% down from the top. Can't reach the bottom of the screen!

    In the horizontal direction, if you touch about 66% across, the tablet gets a touch at the right edge. Touch any further across and you're touching off the edge of the screen.

    (You can turn on "Pointer Location" in Developer Mode.)

    Worse on the tablet - if you start the connection  when the tablet is horizontal, the control screen is totally black. If you start the connection when the tablet is vertical, you can see the screen. Either way - blind or not - the touch mapping when the tablet is horizontal is broken.

  • I am having a similar issue - problems with cursor "alignment" when attempting remote control of an Android tablet in landscape mode.

    I am able to remotely control an android tablet (Samsung SM-T510) only when the tablet is held in Portrait mode.

    Putting the tablet in Landscape mode does not allow effective remote control - appears to have the same "scaling issue" with cursor location as the control PC cursor and position on the tablet being controlled remotely do not align.  (Moving the cursor around and "clicking" in various locations can activate the apps on the tablet, but since the cursor position is not aligned, these cannot be closed or controlled effectively once opened)

    I am currently running TeamViewer 15.11.6 and QuickSupport 15.11.152 on the tablet.

    I had previously been able to remotely control the tablet in both portrait as well as landscape modes, but as of today, only can do this effectively in portrait mode.

  • Same here.  It's impossible to use teamviewer quicksupport in landscape.  The mouse is not activating the areas that you are clicking. As if there was a calibration issue. Very annoying. I tried to test this with other applications too with my supplier and ... same issue.  Working with Samsung tab a (android 10).  That shouldn't be an issue at all.  :-(

    Please teamviewer support contact me ASAP at +**Please do not post TeamViewer IDs**0 so that I could show you.

  • llPac
    llPac Posts: 3 Newbie
    edited December 2020

    Hey i solved this on Tab S7+

    But it isnt working on Tab A7

    Install a app like Rotation Control Pro (it was for free few months ago). There you can give any app a orientation. So i gave the teamviewer Host App a Non Landscape setting. On my s7+ i just need to open after connecting the keyboard an press 3 times space and voila. It works perfectly in bouth orientations.

    But this 1 doesnt works on the tab a7. Maby Teamviewer @Esther can put out an version of the host app which starts always in Non Landscape. Or with a button in the app.

    So we have a solution for the tab s7 without any external app.

    In case of tab a7 maby samsung needs to do something. I just saw that there is no secure folder.

    I tryed with the app **Information removed as per Community Guidelines**. Its much slower then teamviewer and it only works if somebody turns on the screen (on tab a7. Tab s7 works perfect). You need to use adb for grand 1 right so you can use unattended access.

    I hope this helps some of you, still we get an fix for my favorite app.

Sign In or Register to comment.