link icon
Ask The Community

TeamViewer Host times out and disconnects (android)

pzsnipersss Posts: 1

hi, i think i'm going crazy. i need to remote control my android device (i'm trying with s8, huawei p8 and samsung j3) and on all of this devices i got the SAME PROBLEM! i start teamviewer host (i cannot put hands on device cuz i'm really far) and for some minutes the connection is ok, after some time the connection runs out. But the problem is that I cannot connect to the phone when is locked, i tried everything reading past topics but nothing, i tried to optimize the background settings and battery settings, but after some time the phone go offline and i cannot connect anymore from teamviewer on the pc. i think that is a problem of background app management. i need to be able to start teamviewer host and connect after 2 hours, but this app is fully bugged. i found topics of some years ago, possible that a software that cost thousands of dollars is bugged on its main function? and after many yrs there are not solutions? 



  • hello did you ever figure out a fix to this ? I'm having the same issue 


  • that's crazy ..never used to happen  :(

  • JustSumDad
    JustSumDad Posts: 3 ✭✭

    I am haveing the same problem on some devices.

    My Odroid-N2 with LineageOS 16 specifically.

    other devices are fine.  Never happened b4 the latest update to TeamViewer App...

    I think maybe going to eco mode may make it more reliable... 

    the TV app keeps saying there is no internet connection but thats solid, and turning off wifi and back on does not fix the issue...





  • Hi,


    The same issue happening with keeps on timing out. Sometimes the only way is to erstart the device. Did you manage to resolve?


  • Fiona_G
    Fiona_G Posts: 689 Staff member 🤠

    Hi @Michael613 and all,

    Thank you for the feedback and we value the input to our community.

    Possible reasons for this may include: 

    1. Background app management closes the TeamViewer Host
    2. The device cuts off the apps internet connection when the device is locked.

    Please turn off the advanced battery optimization (Different for every brand and some phones even have 2 layers of this) or try eco mode.

    I hope the information above would be helpful. If this doesn't fix it, please raise a ticket to get 1-0n-1 support if you are a licensed user.

    Best regards,


  • p_p
    p_p Posts: 3 ✭✭

    Hi, @Fiona_G ,

    I'm having the same problem for a long time with several devices. Every time I face this problem is when I control my parents devices and they watch the screen. The devices are never locked and TM host app is always alive. I guess there are some other causes.

  • londag05
    londag05 Posts: 4 ✭✭


    I have been trying to access my daughter's phone, but most times time just keeps spinning until it times out.. it works for a few days and then it will be down for lime 4days. The device isn't locked and the host app is live. So can you please fix this ongoing problem

  • londag05
    londag05 Posts: 4 ✭✭
    edited January 17

    This *bleep*

    [The logfile has been removed as per the community guidelines.]

    This is horrible, it just keeps spinning and timing out constantly.

Sign In or Register to comment.