link icon
Ask The Community

Commercial use - Connection time out



  • Ruddman20
    Ruddman20 Posts: 0

    I have a free account and maybe 9-10 machines added(friends and family I help with issues). I'm constantly flagged for commercial use or suspected use and it kicks me off remote or only allows me on for 1 minute. Why am I being flagged?? This restriction needs to be removed. I'm under the allowed machines added on my save list and I only use the service when needed.

  • MarkHaaseth
    MarkHaaseth Posts: 1 Newbie

    Same here. I lost my security code too.

    I need help!!!

  • MarkHaaseth
    MarkHaaseth Posts: 1 Newbie


    I need help!

    It keeps thinking I have a commercial license so I can't even use it anymore.

    I use it for my parents, my Aunt and a couple friends.


  • Al_Atl
    Al_Atl Posts: 0
    edited February 2021


    For the third or fourth time, one of my computers has been wrongly flagged with "commercial use detected." I work in Canada and have an apartment here. My permanent home is in Georgia, I have a house there and computers there. When I am in one place, I often log into the other to check on things, make changes, send/receive files etc. My son and I also help each other out on computer issues. I am not now, have not ever and will not ever use this for commercial use. It is all personal, home use!!! Can you please help me with this? It is so aggravating! I need to do something on a remote computer that would likely only take me a few minutes but with Team Viewer kicking me out after a few seconds, it is impossible and so very irritating. Effectively useless. Please help! You detection system is set far, far, far too sensitive that this keeps happening over and over, not only to me, but from what I am reading in online groups, many others as well.

    Thank you for your help.


    **Information removed as per Community Guidelines**

  • Raman2021
    Raman2021 Posts: 0 Newbie

    Dear Sirs I'd like to claim that my TeamViewer account is suspected as Commercial, however I'm using it only to access a couple of my own devices and my parents' PCs. I can prove it by providing all the necessary data about each device. Waiting for your comments. Thank You!

  • dtrcorp
    dtrcorp Posts: 0
    edited February 2021

    When I remote control another computer, the session only lasts 45 seconds then times out. When trying to reconnect I get the following message:

    Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license.

    I am using FREE ver. 15.14.5

    Any idea what is happening? It never did this before.

    DAVLISLE Posts: 0

    My account has been intructed to acquire paid license. Is this required for only local household network use on max 3 computers?

    What activity might have triggered this "commercial activity" designation.

  • TE5LA
    TE5LA Posts: 9 ✭✭

    Is TeamViewer no longer free for non-commercial use? I use it mainly to connect to my own server in my home instead of having to physically move to that computer. Sometimes I use it to help a friend who is not very computer literate. I have not been able to use TV for several months now. It times out after 10 seconds and disconnects, telling me I must buy a license.

    I have previously submitted a ticket about this but nothing was ever done to solve it. I want to know in case I need to dump TV and find another alternative.

  • wave5136
    wave5136 Posts: 0
    edited February 2021

    TeamViewer ID: [removed by a moderator due to Community Guidelines]

    Email address: [removed by a moderator due to Community Guidelines]

    Name wave36 [removed by a moderator due to Community Guidelines]

    [removed by a moderator due to Community Guidelines]

    Usage situation

    "I regularly maintain my friend's computer."

  • Mike
    Mike Posts: 5 ✭✭

    205 pages of complaints on the same issue and still counting. It doesn't look like this problem is being resolved or even addressed. In the past, submitting an appeal used to be reviewed and resolved but now it seems no longer to be the case.

  • Mike
    Mike Posts: 5 ✭✭

  • Ruddman20
    Ruddman20 Posts: 0

    Why is this not being answered by anyone at TeamViewer? Technical Support? Someone?

  • I used '' an get as far as filling the form with name, address etc, then the 'Generate PDF 'button at the bottom of the form does absolutely nothing, and gives no error messages. Help please

    JESSICAJO Posts: 0

    Frustrated! I am using the Free and latest version of Teamviewer. I never had the problem before, but recently my connection with my partner times out within about 5 minutes and it is extremely frustrating!

    How do I increase the connection time? I cannot seem to find an answer when I search in the Help option.

    JESSICAJO Posts: 0



  • statementxp
    statementxp Posts: 2 ✭✭
    edited February 2021

    I have a problem.

    My friend got a bug with Windows Preinstall Environment on LiveUSB, and I tried to connect to him. After 20 sec I've been disconnected and then i still cannot connect due to several causes: 4 times I couldn't reconnect because I have to wait for next minute and I waited, then "You cannot connect because you do it too often or fast".

    ***bleep***, guys. I almost want to go to another remote control program.

  • philk07
    philk07 Posts: 2 ✭✭
    edited February 2021

    I am having the same issue and it times out in less than 1 minute. I have uninstalled and reinstalled Teamviewer but no change. Even though in the advanced options, the inactivity is set to OFF, I tried to increase 8 hours but still the same result in that it times out in less than 1 minute.

    Attached is the logfile in the event Teamviewer support is monitoring this community message.

    **Information removed as per Community Guidelines**

  • kkoehler
    kkoehler Posts: 0 Newbie

    Getting message-

    Connection blocked after timeout.

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license.

    Connections to this partner will be blocked until 18:53


    This is a free account and I'm trying to connect to my linux box sitting under my monitor here on my desk. I don't understand why the maximum session duration is 0.00 seconds and I get immediately blocked from further attempts.

  • I feel confident that others have to be experiencing this too, but my search didn't really pull up much (though I may be bad a selecting search terms). Anyway, I've used the free TeamViewer for years to help my parent whenever they had a computer question. I had helped them back in October of 2020, then didn't have to connect to their computer until just recently (early February 2021) . When I did connect again, I was booted off after about a minute - the message said that my session had timed out, and then I was prevented from reconnecting to them. I tried again a few days later and had the same experience. I then began to suspect that maybe the free version had been nixed, so I looked for pricing for a licensed version and the most economical option was $49 a month...

    I am having a hard time believing that what they'd offered for free is now $600 a year, but crazier things have been happening this past year. So, can anyone confirm whether this is true? Did they ditch the free version?

    Many thanks!

  • "Your Teamviewer session has timed out and will be closed"

    I get logged of after less than 1 minute. Only with one friend.

  • The system says I am using it for commerical use.. when all I am doing is supporting my Mom and Brothers. How do I ask them to reset it?

  • ralphglenn
    ralphglenn Posts: 0 Newbie

    i recently submitted an affirmation that my use was personal. still having problems

  • KeyserSoze
    KeyserSoze Posts: 2 ✭✭

    Hi Guys,

    I previously was using a corporate account but since you changed your TOS

    I only use TeamViewer Personal from home to help friends & family members. After sighing into my personal account and trying to connect to my brother’s computer I get

    “Your TeamViewer session has timed out and will be closed”

    after only a couple of minutes. I thought it might have been because I was using my corporate account previously so I uninstalled TeamViewer and removed all of the excess files from

    C:\Program Files (x86)\TeamViewer


    C:\Users\MyUserAccount\AppData\ Roaming\TeamViewer

    I then reinstalled TeamViewer and tried again but I get the same message and get booted after a few minutes

    See links:

    Any Help Would Be Greatly Appreciated,


  • sandrajones_45
    sandrajones_45 Posts: 1 Newbie

    I have the same problem

  • bshores
    bshores Posts: 0

    one PC that i remote into about 1 every six months will not stay connected - and reconnect is not an option. . .free version for years with only like 6 PC's that i remote into every so often

  • statementxp
    statementxp Posts: 2 ✭✭

    You know, i got same problem.

    Also my topic had been deleted in hours.

    I dunno what should I think about that.

  • Ajoshi
    Ajoshi Posts: 0 Newbie

    I was using TeamViewer(TV) for my personal use for which subscription was free. But suddenly my sessions got limited to 2 mins only. It says (TV) I am using it for commercial purpose which is not true. Who should I talk to regarding this? Thanks for the help!

  • Free version access will not allow me to connect to a friend.

  • garycase
    garycase Posts: 7 ✭✭

    For the past several months, I've been unable to help any of my friends or family with Teamviewer, as any connection I made automatically disconnects in less than a minute. I am NOT getting the dreaded "commercial use suspected" note -- I had that problem a couple years ago, but got that resolved. Now it's simply disconnecting with a brief pop-up that says the session has timed out (not sure of the exact wording as it disappears very quickly).

    My Teamviewer correctly shows that it's a "Free license (non-commercial use only), and has worked perfectly for years (except for a month or so when I had the "commercial use suspected issue about 2 1/2 years ago. But sometime last fall (I think in September) it started simply shutting down.

    I tried downloading a copy to my laptop, and running it from there (didn't actually install it; just used the "run once" option), but it does the same thing. So I suspect this may be somehow tied to the IP of my provider, but am not sure.

    I submitted a ticket to Teamviewer about a month ago, but never heard from them. I sent a "what's the status" message last week, and got a note back that simply says "This ticket is closed" -- with no explanation and the problem hasn't changed.

    Any ideas ???

  • Baldizzi
    Baldizzi Posts: 1 Newbie

    I have reloaded the Teamviewer software but my free version continues to timeout right after connection with the partner. No error message. I believe I need a reset, however, I don’t how. Please help! Joe Baldizzi