Have to allow each time with host app

tatankasa Posts: 1

I just installed the Teamviewer Host app on my Pixel 4 running Android 11.  Each time I connect to my phone from my PC, the phone pops up with attached warning, and I have to tap 'Start Now' before I can control the phone.  I have to tap 'Start Now' physically on my phone, which means I can only remote control my phone if I have it with me in my hand.  I want to be able to leave it out in the other room, which I believe is the point of the Host app?

Does anyone know how I can accomplish true unnattended access with the Host app?  I'm assuming there is some way to disable this warning, or 'auto-allow' it?  Thanks in advance!!!!

Edit:  Since I couldn't find any results googling for the exact phrase Start recording or casting with Host I thought I should add the text in here for indexing

warning that appears on phone and must tap 'Start now' before I can remote control my devicewarning that appears on phone and must tap 'Start now' before I can remote control my device



  • davidbtooks314
    davidbtooks314 Posts: 2 ✭✭

    Bump!! Same problem here. Trying to log into covid grandma's tablet

  • Xav0
    Xav0 Posts: 2

    Same problem here... "unattended" but asking for permission...

  • fostex909
    fostex909 Posts: 1
    edited February 2021

    Thank you smpl for this solution! This has worked for me on a Samsung Tab A.

    Under App Ops, the app I had to search for was "Host" since I had the Teamviewer Host app installed on my Tab A. Once I was in there I was able to see the PROJECT_MEDIA permission and allowed it.

    For anyone else doing this on a Samsung Tab A, I had to connect the ADB via Powershell from my Win10 laptop twice and then had a successful connection. (Hold Shift and Right Mouse click in the ADB folder on Win10 to open a different menu and the "Open Powershell Window here" option is present.)

    I now have full Unattended Remote Access to the Tab A without the annoying popup.

    Cheers! 🍺

  • LindonMorris
    LindonMorris Posts: 0

    Many thanks smpl!

  • Zetrad
    Zetrad Posts: 0

    This work-around worked for me. I have 2 identical Galaxy Tab A Tablets I use in trucks for ELD and this worked to access both with out the security popup!


  • ccandiotes
    ccandiotes Posts: 1

    This solution worked for me too. Thanks @smpl for the steps and @fostex909 for the tip to look for host.

  • Oleksandr_1
    Oleksandr_1 Posts: 1

    Many thanks @smpl! This solution works for me to!

  • gatesps
    gatesps Posts: 1

    You can also just run this ADB command:

    adb shell appops set com.teamviewer.host.market PROJECT_MEDIA allow

  • JamesHinPhilly
    JamesHinPhilly Posts: 3 ✭✭
    edited July 2022

    [Updated post 11:38 a.m. 24Jul22] - The information posted above seems dated, as I just found a YouTube video titled "Unattended access from mobile to mobile using Teamviewer 2021." As the first person asking the question pondered it seems like the whole point to this is to be able to access another phone (or other device) without the need to physically give permission from the Host device. Anyway...this YouTube video appears to be the solution (you simply download "Teamviewer Host" to the Host phone. My problem is, for some unexplained reason, I cannot get the Teamviewer Host app to download to my phone. That is my question - Does anyone know why I would not be able to download this app [Note, I get a simple error message that cannot downloan now, "try again." And I have successfully downloan many many apps from Google Play.]

    [Original post (not answered) from 9:35 a.m. 24Jul22] In the solution provided above what is ADB, and Shizuku, and App Ops (you are talking over my head of sorts with shorthand)? Please give step-by-step instructions for how to get these apps (i.e., ADB, Shizuku and App Ops) on to my android phone (I am trying to control one phone from another phone without the Host being required to provide physical permission EACH time).

  • Zymotik
    Zymotik Posts: 1

    Much easier method from https://www.imval.tech/index.php/blog/teamviewer-android-skip-the-confirm

    1. Enable developer mode on your phone (press ten times on the Build version in the system info)
    2. Enable USB debugging in the developer menu
    3. On your computer, with ADB (part of the platform tools, you can find other tutorials online), run the following command: adb shell appops set com.teamviewer.host.market PROJECT_MEDIA allow
    4. Voilà! You can now connect to your Android Smartphone with Teamviewer Host without having to press a confirm button, truly unattended.

  • eortegaz
    eortegaz Posts: 2 ✭✭
    edited May 2023

    Quite an old thread, but I figured this would help people get their ADB working (Windows).

    Instead of going the Shizuku/AppOps route, the easiest way is to setup ADB and execute a single shell command to grant TeamViewer the PROJECT_MEDIA permission.

    If you don't know how to do that, here's a quick tutorial:

    On Android:

    • Enable developer settings:
      •  Settings -> About phone -> Software information (may vary by manufacturer) -> tap "Build number" seven times. You'll get a notification "You are now a developer!"
    • Enable Wireless debugging and start pairing:
      •   Settings -> Developer Settings (new menu) -> Wireless debugging -> toggle on. Select "pair with code." Take note of your IP, pairing port and pairing code.

    On Windows:

    • Open PowerShell (Win + R -> type "powershell")
    • Let it auto-install Nexus Tools (ADB) by typing:
      • iex ((New-Object System.Net.WebClient).DownloadString('https'+'://raw.githubusercontent.com/corbindavenport/nexus-tools/main/install.ps1'))
    • Close and reopen Powershell (reloads path variable)
    • Pair with Android - type:
      • adb pair <IP>:<pairing-port> <code> (from step 1), e.g. adb pair 123456
    • Wireless debugging shows the IP (same as above) with a different connection port (under your device's name). Connect using it:
      • adb connect <IP>:<connection-port>
    • Finally, to give TeamViewer PROJECT_MEDIA permission by typing:
      • adb shell appops set com.teamviewer.host.market PROJECT_MEDIA allow

    You can grant any app this permission, so it can be used for other apps like this:

    adb shell appops set <app-package-name> PROJECT_MEDIA allow

    Here's a list of packages for apps that commonly request this permission:

    [removed per Community Guidelines]

    TLDR; adb shell appops set com.teamviewer.host.market PROJECT_MEDIA allow