link icon
Ask The Community

Commercial use - Connection time out



  • TTsekov
    TTsekov Posts: 1 Newbie

    I have two personal machines under my account. I need to monitor an application running on these two machines and sometimes I have to do this form the work computer.

    Whenever I connect, I get about 30 seconds of access to them and after that Teamviewer closes the session and says I have reached a limit of personal use. And gives me a random back-off timer until I can reconnect for another 30 seconds.

    I`m not a business, I just want to watch my machines from time to time and access to copy/paste files.

    All two machines are under my account, along with the machine at my workplace.

    Can someone advice or do I have to get my card out because I dare to have 3 machines under the account?

  • Nanomaterials
    Nanomaterials Posts: 0


    I use TeamViewer to connect to different computers in the lab at the university. So it is for non-commercial purposes.

    But it sometimes suspects that I use it for commercial purposes and limits the connection time or blocks the connection (maybe because the receiving computer is named after the supplier company of our lab facilities).

    How can I ask TeamViewer support to solve this issue? I cannot find any easy contact route directly to the support team.


  • I have an issue with my personal account. When I enter in a remote pc, after a few seconds teamviewer closes and says that the use is commercial. I uninstalled and re-installed but the problem persists from my pc.

  • viktoriagimhim
    viktoriagimhim Posts: 2 ✭✭

    I have the same problem

  • soniarodri
    soniarodri Posts: 0 Newbie


    Sessions from my laptop to my desktop keeps disconnecting every about 5 min with a timeout message, I have a non-commercial license.

    Please advise.


  • bigchak
    bigchak Posts: 1 Newbie
    edited March 2021

    that's it I'm moving to [third party product]. I'm not spending 500 bucks a year for a private usage. I'd be happy to pay 20 or 50. If you don't want to adapt your business model you'll just lose customers.

    The experience of being disconnected every 15 seconds this morning was the last one, i'm done.

  • sflo
    sflo Posts: 1 Newbie

    I need some help, my home computer access is blocked saying that a commercial use is detected. I use teamviewer only for personal purpose...

    Since I am thousands of kilometers above seas away from my home, you are getting my computer and personal data hostage !!! Please stop this aggressive commercial action so I can install another software and get rid of teamviewer... thank you...

  • Hearth
    Hearth Posts: 0

    Good Morning

    Since this morning (yesterday I was connected at 18:00h. GTM + 1)

    When I connect to my other computer in less than a minute he kicks me out, and I get a message saying

    "Your TeamViewer session has timed out and is about to end"

    When trying to connect again, I get the message

    "Connection blocked because time limit has expired.
    Your license limits the maximum duration of the session and blocks immediate reconnection. 
    Try again later or update your license.
    Connections to this partner will be blocked until hh: mm."

    Can you tell me what happens please?

  • Matti_Kokenut_67
    Matti_Kokenut_67 Posts: 2 ✭✭
    edited March 2021

    In Finland Windows 10 has the same problem too. I've been trying many things, but not succeeded. I have free version and I'm trying to help elderly relative. Please help. ( I used Windows 10 Quick Assist, but was not so easy get it through by explaining by phone to elderly)

    My english is quite good, maybe I understood wrongly: but I got "warned" from Teamviewer moderator: This topic has already been answered here and we will go ahead and merge... and they are suggesting to me reactive my account for commercial use to private, but I DON'T GET THOSE COMMERCIAL USE MESSAGES, I THINK I HAVE DIFFERENT PROBLEM (maybe I'm wrong), it just kicks out in 10 seconds: Your Teamviewer has timed out.... 

    But for few days I wait for good ideas, if I don't get then I try what Teamviewer moderator suggests.

  • PaulusR
    PaulusR Posts: 0

    Same here.

    Before today no issues!

  • Steen1
    Steen1 Posts: 0

    I am being timed out of sessions after just a few seconds despite having a private licence. It has just started after using the program for months. I have tried to delete and download the program on both the computers on which I use the program. Any help to solve the program?

  • NN0316
    NN0316 Posts: 0

    I am having same issue on macos ... catalina version yesterday worked perfctly but today from 5 hrs i am tryig to use it.. 1 min and kick me off

  • clorinthe
    clorinthe Posts: 3 ✭✭


    Probably same problem here, in slightly different conditions :

    I have been suggested to update TeamViewer on 2021-03-03 from version ? to 15.15.5 on my Laptop. My PC did not need update.

    Since then, neither the PC, nor the laptop can be in session with each other, for more than 1 minute.

    There is a very special context for this connection problem. I am not sure it has something to do with the timeout, but let me explain...

    I was working with the helpdesk of my antivirus provider, to try and solve the following problem : No teamviewer connection was possible when the controlled machine was being prompted by the antivirus software (to allow a specific access, for example), this situation could be resolved only by a person typing on the controlled machine making teamviewer unusefull.

    In order to collect information about this issue (tech reports, screen captures,..), I have been testing a long time, letting the problematic connection process waiting. I have not yet been given a solution, and I return to the normal use of Teamviewer, that is a few minutes per day with the laptop controlling the PC, or the opposite.

    But it will not work anymore !

    As my use of teamviewer sessions was far above what I usually do, I suppose that teamviewer "thinks" that I am a professional user, as they did already a few years ago ?

    I will keep 24 hours without using teamviewer and see what happens.

    If someone has information about this issue, I would appreciate to know ;=).

    I can speak French as well.

    Good luck !

  • jorgen_levesen
    jorgen_levesen Posts: 0

    Insted of solving these problems, I get_

    Congratulations! You've been promoted to Electron.


  • Hearth
    Hearth Posts: 0

    It is due to the publication of your first message. It is a category of the forum.😅

    As I have been told from the Moderation, this is the same problem as when you think you detect an incorrect use of the license.

    They have not sent you a message to send a PDF form? 😕

  • Lith
    Lith Posts: 16 ✭✭

    Teamviwer staff, can you please adress this?

    Why arent you here in forums trying to give people information on whats going on?

    Is your strategy to ignore the free users?

    If you are that money hungry, atleast do a "private home version" that is cheaper? The business versions are way to expensive for a private person using the program a few times a week.

    Ppl would probably pay for a "home license", but would not wanna pay for it every month...

  • afeno
    afeno Posts: 0

    Same here. This is insane... I use Teamviewer a few minutes a day and I get a timeout and I can't access my remote PC anymore.

    Any workaround available?

  • Giu
    Giu Posts: 1

    Hi there,

    Trying to connect to my remote computer I am receiving the following message:

    "Unable to connect: Connection blocked after timeout

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license."

    I have checked my email and TeamViewer manager account, but did not find any notification about changes in their policies whatsoever. I am using TeamViewer for personal purposes (no business/work related stuff). However, I cannot be connected to my remote computer more than 1 minute before this message pops up, and disconnect me. I have already re-installed TeamViewer with no success. Any idea how to solve it?

    Thanks in advance!

  • afeno
    afeno Posts: 0

    It should be clearer how this timeout works. I believe that there is currently a bug in the system. When I try to connect, I get a message saying that I should wait 1 minute. And after 1 minute I get a message saying that I should 1 more minute. And so on so for.

    And when I can connect after waiting 1 hour, I can only connect during 2-3 minutes.

    So, my conclusion is that there is a bug. Like the versioning problem that we had last week.

  • zell180
    zell180 Posts: 0

    I've the same issue!

  • NN0316
    NN0316 Posts: 0

    Yes.. i am using it on macos idk why and what but anooyed me already...

    Any news did they fixed it or they will ?? or how to resolve it :))))

  • gverhoev
    gverhoev Posts: 0 Newbie

    me too, since today

  • markad
    markad Posts: 3 ✭✭

    Me too. It worked fine yesterday. Reinstalled latest version on both home computers and get the same problem.

  • Chris1049
    Chris1049 Posts: 7 ✭✭

    Bonsoir, j'ai aussi le souci qu'après une minute, ma connexion est coupée vers un pc de mon asbl, j'espère qu'il s'agit d'un bug, et si oui j'espère que cela prendra pas des semaines avant que cela se règle

  • Lith
    Lith Posts: 16 ✭✭
    edited March 2021

    Exacly, this is a bug. But teamviwer staff ignores it. I even got a warning for pointing out the problem, even tho the problem ISNT resolved. This is NOT a commercial use problem, its a timeout problem.

  • doruvil
    doruvil Posts: 0

    I am having the same problem

  • Madman227
    Madman227 Posts: 12 ✭✭

    I have the same problem, seems to be a widespread problem.

  • Madman227
    Madman227 Posts: 12 ✭✭

    Same problem here.

  • The_Scorpions
    The_Scorpions Posts: 0

    Same problem


  • Adeljo
    Adeljo Posts: 0 Newbie

    Hello I've been having a problem with team viewer with free license or personal use how you call it because i have 3 android boxes that i connect into my house because it is easy to use them from the pc but now it says after 30 second connection timeout. the thing is i use it for my own its not that i use it for bussines or so can you do something to fix the problem for me please?