link icon
Ask The Community

Commercial use - Connection time out



  • marina2707
    marina2707 Posts: 0 Newbie

    Same problem appeared today. Connecting from mac to windows 10.

  • pedroxramos
    pedroxramos Posts: 1

    same here. also Connecting from mac to windows 10/ubuntu

  • Guiri
    Guiri Posts: 0

    I am using the free version and non comercial use of Teamviewer to help my friend do homework since i'm very good with computers and help them, and it keeps showing up that i'm blocked, any help?

    Best Regards,

    Liam Richards

  • calpub
    calpub Posts: 2

    Good evening,

    Between 0 and 29€90, there is a gap that can be filled.

    Could you please provide a license for "enhanced" PERSONAL usage, with technical limitations but proposing the cross platform remote session services for a limited set of devices.

    Such a licence could propose for instance :

    • 30 managed devices
    • No access to server OS
    • No access to PRO version of Windows or other ? (to be discussed, but ok if not provided)
    • No printing
    • No simultaneous/double/parallel connection on a device
    • No meeting
    • No chat (when helping someone I phone him/her).
    • Simplified/limited web management console
    • No other unused (at least by me) options...

    I don't know what I did tonight to trigger again (third time) the "suspicion". The two first times were when helping friends who appeared to have a "Pro" version of Windows. OK, now I ask them what version they have before connecting. But tonight, connecting from My Linux computer to another Linux computer (Linux Mint personnal PCs, NO RedHat or other servers...), I faced a "limited timed connection".

    Thanks !


  • lgflavio
    lgflavio Posts: 0 Newbie


    i am blocked



    I use team viewer once a year...literally once a year. I connect 1 of my PC to the other.

    commercial use... seems really not fair

    what do I do

  • Lith
    Lith Posts: 16 ✭✭

    They merged thread with a "commercial use thread" for some strange reason. This problem started around 25 february, but they keep merging every thread speaking of "timeouts" to this thread instead, ignoring the real issue.

  • Madman227
    Madman227 Posts: 12 ✭✭
    edited March 2021

    What is happening with many people is not a commercial use issue, it's people with free not commercial use that was working fine just last night and today when they login it cuts after 30 seconds and then blocks you for logging back immediately. I'm even beta testing the new versions ahead and I only connect between 3 pc's at home on my local network. There is no comercial use message, so it's strange.

  • Madman227
    Madman227 Posts: 12 ✭✭

    Wednesday everything was normal, on Thursday I got home and connected from my laptop to my main pc all in my local network. I only use it at home to move files or control it to browse it. Suddenly after 30 seconds it disconnects. There is no Commmercial Use message. When you try to connect again it shows I have used all the time I have and blocks me from connecting again. I wait a bit and connect again and the same thing happens. From what I read here more people suddenly got it, you just merge the messages to the same thread but not even answer the problem! I'm using the beta test versions, I also already filled long ago the form with my details and signed and explained that I'm a home user and not a company or use it for work. So what is the problem this time? I changed nothing on my setup and only log on a laptop to a desktop pc in front of me. It doesn't make any sense. Something you changed is causing this and people no longer can use team viewer. I will try the rest option but it can't be what is happening.

  • liuplace
    liuplace Posts: 0
  • Madman227
    Madman227 Posts: 12 ✭✭

    Same problem here and for a lot of people, they are merging this to the commercial use discussion thread. Don't think it's the same because I get no commercial use message, seems something they changed and for some reason are giving problems to the free users. I resent them the email with the form I signed last year stating I'm not using it outside home use, which is my case.Only have a laptop connect mostly to a pc to move files and browse some pages. Don't have windows server installed anywhere, so don't understand why this is happening. Seems to be a global problem and they are not replying to our messages on why this is happening.

  • mbacklund
    mbacklund Posts: 9 ✭✭

    Ok, just a heads-up for everyone;

    I submitted ALL my personal TeamViewer ID's to the reset form, they handled it and sent me an update that my account has been reset. Now it seems to be working.

    I had the connection timed out issue after 59 seconds.

  • Wicrof
    Wicrof Posts: 0

    Hi i'm have a problem with My account, i can't connect with My PC because My sesson don't use comercial... And i miss connected with My PC.. Is prívate.. My PC.. help

  • Teo_Lomb
    Teo_Lomb Posts: 0

    Dear all,

    I am being using Teamviewer from a while now. I use it for personal reasons to control a second computer of mine. However, from a couple of days, after just few seconds Teamviewer quit the connection and tell me that my session expired (something that before happened to me only after 1h of connecton or so).

    I already tried to uninstall and re-install my teamviewer, but nothing changed.

    Do you have any idea of how I could solve this issue?

    Thanks in advance,


  • FEB
    FEB Posts: 0 Newbie

    Reset management page does nothing. It just asks for account authorization and when you press approve it goes to a blank page...

    This silence from the Teamviewer team reminds me of the situation where Garmin servers were hacked a couple of months ago... I hope it is only my imagination. But this update to latest teamviewer -> commercial activity suspected -> 30 secs timeout problem has been going on since 10 days and i had all these errors happened exactly in this order. So i believe all these errors are related to each other and this is the same bug that's why Teamviewer merged all these subjects together.

    But i sincerely hope that this is not something related to suspicious activities or hacks. I changed my password in any case.

  • mbacklund
    mbacklund Posts: 9 ✭✭

    Have you tried it with another browser? I had no problems on that.

  • FEB
    FEB Posts: 0 Newbie

    I tried with Firefox and Chrome on Windows and OSX. None of them worked...

  • scorval
    scorval Posts: 2 ✭✭


    I have just came into a problem, I have now a message that tell something like "Your license limite you'r max duration of session with a partner" but I never had this problem before and I only use teamviewer for a personal use and not comercial.

    Does someone have an answer please ?

    Sorry if my english is bad I'm French and not very use to it.

  • clorinthe
    clorinthe Posts: 3 ✭✭

    Hi, ALL

    Just in order to appreciate how wide the problem spreads (*), we could tell each other in what country we are.

    (*) Please forgive my bad English,

    Michel from...


  • RebecaLoMir
    RebecaLoMir Posts: 0

    I have the same problem! It's kicking me out all the time and I can't access because the "connection has been blocked". Can someone help us? Thanks!

  • Fabio70_tecnico
    Fabio70_tecnico Posts: 4 ✭✭

    Hello, I have been using TeamViewer for almost a year to give assistance to friends in Smartworking, until two days ago everything is ok..but since yesterday unfortunately when I connect with any user of the group (10 pc) the connection closes after a few seconds with the words "Your TeamViewer session has expired and will be closed.

    What can I do?

  • I have a problem of time out with team viewer today, the version of my team viewer is 14. may you help please.

  • Mr_Bach
    Mr_Bach Posts: 2 Newbie
    edited March 2021

    TV is broken and they did not fix that disconnect bug for years know. [third party product]. Sorry, they don't seem to care. :-|

  • Madman227
    Madman227 Posts: 12 ✭✭
    edited March 2021

    Same problem and many others have it like us. Teamviewer won't help and just merge this thread into the commercial use thread. You won't get an answer from them

  • Madman227
    Madman227 Posts: 12 ✭✭

    I'm from Portugal. Problem still happening. Sent email with the form I sent last year and explaining again that I use it at home. Tried with my phone no message but doesn't login.

  • hrguerra
    hrguerra Posts: 0 Newbie

    The past few times I’ve tried to use TV to connect to my iMac I’m getting a timeout disconnect in little more than a minute of use. It’s a free license but I literally only use it to connect to the iMac and move personal media files around to the external drives. The TeamViewer Host in the iMac and the apps in my iPhone and MacBook are all updated, and all are running the latest OS.

  • hrguerra
    hrguerra Posts: 0 Newbie

    I gotta say, the post about my thread stood alone without being merged into this unrelated issue thread was almost as fast as the timeout time we’re all experiencing.

    I’m from México, all Apple devices. Same network, different network, wi-fi or cellular, etc. It always happens. And as all others have said, there is no “commercial use” message.

  • Esther
    Esther Posts: 4,110 Former Community Manager

    Hi Fabio, can you make sure your license is activated on your account? For Smartworking a license is required and it sounds like you maybe were not logged in to your licensed account. Thanks, Esther

    Former Community Manager

  • pauluspla
    pauluspla Posts: 6 ✭✭

    The same happened today to me. I only use TeamViewer for one phone, and I didn’t connect to it in about one week. It is not the message of using commercially an account, fist time it disconnected a few seconds after connecting, and now, after a while I try to connect and directly appears this message, screen is in black.

  • redskam
    redskam Posts: 0 Newbie

    Hello I have a similar problem : I have been using team viewer successfully for less than a year and ever since a few days ago I am unable to connect more than a minute on my remote laptop. Everytime I do, it disconnect me and block me from reconnecting saying "Connection blocked after expiration of response delay

    Your licence limit the maximum time of session with a partner, immediate reconnections are blocked. Please try later or update your licence.

    Connection to this partner blocked until 15:36 (in one minute)"

    It's always been working fine, why does it suddently do this ? Was there an update ?

  • pauluspla
    pauluspla Posts: 6 ✭✭
    edited March 2021

    Yes, I got more or less the same message. In Spanish, but very similar.

    More info shows a message thanking for your buy, and that my account is being upgraded to business(something that I haven’t done)