Commercial use - Connection time out



  • Proton68
    Proton68 Posts: 0

    I have the same behaviour on one notebook, free sessions do get disconnected after 1 minute and the same message popups.

    on another notebook, no problem, I can connect to my pc at home without problem... :-(

  • NNZ
    NNZ Posts: 0

    Hello Community,

    I am using a TeamViewer with a free license for personal use.

    Just like Mykola, my free sessions also last no longer than a minute. Upon establishing a new connection this message pops up :

    "Connection blocked after a timeout.

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked ...

    Do you what's happening here?

    Best regards,


  • costy
    costy Posts: 1

    Hello Community,

    I am using a TeamViewer with a free license. tToday, my free sessions only last 1 minute.When I try to reconnect, I see:

    "Connection blocked after timeout.

    Your license limits the maximum session duration to a partner , immediate reconnects are blocked ....

    I can see no message of suspect commercial use on my screen, do I have to submit for reset or is this something different from suspect of commercial use? I only use it for personal reasons.

    Thank you

  • amlinor
    amlinor Posts: 1


    I am outside USA and trying to connect to my Laptop at home (USA).

    Some weeks ago it was working properly but since some days ago, the connection only works around 50 seconds.

    I reinstalled the team viewer but the problem remain the same.

    May yo help me.


  • gusalomao
    gusalomao Posts: 0

    I'm with the same problem on my Team Viewer, from Brazil.

  • amlinor
    amlinor Posts: 1

    Did you solve the problem ??

    I reported several times the problem to team viewer with no answer.

  • Andreas65498746546
    Andreas65498746546 Posts: 1
    edited March 2021

    Hi there,

    I am using TeamViewer commercial and private. For private usage I have a free account.

    Connecting to a computer with my free account via ID and Password starts the session as usual. But after some seconds - less than a minute - the session is ended by TeamViewer with the following dialog:


    This was a free session, sponsored by teamviewer... blabla.

    I then try to reconnect but TeamViewer says...:


    Connection after timeout locked. Your license limit the maximum connection time. Reconnections are blocked. Next connection to this partner is possible ar 16:38.

    I don't understand why this happens. I thought the free account has a timeout or 3 hours or so.

    I hope someone can help :-)


  • JoshP
    JoshP Posts: 895 Community Manager 🌍
    edited March 2021

    Hello @Andreas65498746546

    Thank you for your post.

    As mentioned in this older thread, is not possible to have a commercial account and private account on the same device.

    When you log in with the commercial account, it marks that TeamViewer ID as a commercial device.

    As it is a commercial device at that time, a free account cannot be used on the same device. This is why the free account times out when in use.

    To resolve, the free account would need to be used on a separate device.

    I hope this helps clarify.

    Josh P.

    Senior Community Moderator


  • Antoniolg
    Antoniolg Posts: 1


    I use Teamviewer to connect to my computer that operates my telescope at my hobbyist observatory.

    It is not commercial use or anything like that. I am a fan of Astronomy.

    The session is cut in a few seconds. I have uninstalled, cleaned, reinstalled and still the same problem.

    That I have to do?

    I have used it for a long time and have never had a problem.

    Best regards.

  • dparrish2
    dparrish2 Posts: 1

    I rarely use TeamViewer except to support family and a few friends. All of a sudden I am getting a Sorry for interruption message stating that my connection is blocked due to very high activity level. Being that I rarely use it, I don't understand why I am blocked and why it states there is high activity level.

    Is there anything I can do to get this corrected or just plan on ditching the Teamviewer product totally?

  • franco_fz
    franco_fz Posts: 0


    I have been using TeamViewer for a non-commercial one for several years. I have rarely had any problems. But in one of the latest updates, I can no longer make a remote connection.

    It does not give any particular error.

    I have already removed and reinstalled the software, but could not fix the problem.

    Thanks for the help tips

  • Adje
    Adje Posts: 0


    I have same issue for weeks now. Already contacted support team but no reply so far :-(

    I don't know how to solve this issue :-(

    @ Teamviewer support: Please fix this.

  • hutch10
    hutch10 Posts: 0

    Same issue here. Wouldn't mind paying a small amount or even pay as you go. Trying to support my 94 year old mother and cannot afford the exorbitant monthly company fee. I need generally use it for about an hour or two a month if that and paying over $51 per month fee is not worth it.

  • Msraps
    Msraps Posts: 1

    Hi there,

    After less than a minute I get an time out on one of my PC`s, but on a second one, no problem.

    Best rfegards,


  • ciprianmp
    ciprianmp Posts: 0

    In my case, exactly the same thing happens when trying to remotely connect to my daughters desktop. Both on latest TeamViewer and with free accounts. Can someone fix it or tell us what is wrong lately with TV?

  • funkhelp
    funkhelp Posts: 1

    why 'timeout' always came up?

    why i'm blocked?

    im privatuser

    there was no 'long' connection to a partner

  • Paullievens79
    Paullievens79 Posts: 1
    edited March 2021

    Message from TeamViewer: ID has been reset from **Information removed as per Community Guidelines** to **Information removed as per Community Guidelines** but nothing has changed? 

    How long can it take before I see the new ID on my HP pavilion laptop?

    Am I being too impatient?

    Please some advice...

  • bjornz
    bjornz Posts: 0

    Suddenly I am getting a timeout after 1 minute on one of my computers. Then I have to wait for another minute or two before I can log in again. I think it started after a Windows update (but I'm not sure). Is that a Windows issue, or is it because i have suddenly become a suspect? My login says that I have a free license.

  • izc
    izc Posts: 1
    edited March 2021

    Well what to say other than bye bye teamviewer

    Hello **Third Party Product**:-))))))))))))))))))

  • franco_fz
    franco_fz Posts: 0

    in my case I understand where the problem lies.

    When connecting from the mobile to the PC, I get a warning that a commercial version has been detected and therefore it will only work for 5 minutes.

    The strange fact is that both the mobile app and the software in my pc are for non-commercial use.

    Now how do I fix it?

  • gabriglz
    gabriglz Posts: 1

    I have an issue after trying to connect one of my computers on my home, it shows and error attached, the app only allows me to connect for a minute and then it shows up the message

    could you please help to advise to solve this issue


  • Aperl
    Aperl Posts: 0

    I have the same issue.

    Waiting for support team replay to this post

  • netzero
    netzero Posts: 4 ✭✭

    absolut the same

  • netzero
    netzero Posts: 4 ✭✭

    where is the solution for this?

  • netzero
    netzero Posts: 4 ✭✭
    edited March 2021

    my ticket was deleted... why? **Information removed as per Community Guidelines**

  • netzero
    netzero Posts: 4 ✭✭


  • blak24
    blak24 Posts: 1

    Hello everybody.

    As said, a message appeared today when I logged in to my remote PC. I always do back and forth from my student home in a city, to my parent's house in another city in the weekend. I generally connect to my remote PC on my student home to play with some games remotely, or just to organize some files and online classes at university. So my license is absolutely not violating the free-license terms. The problem is that I can't contact anyone at TeamViewer. They say, in the message, to contact them through a ticket, but I can't do that because it appears that only paid licenses have support through tickets. So, what should I do? Move TV to the trash and use another software?


  • wjnobbe
    wjnobbe Posts: 0

    I'm also getting these problems lately, and Its strange. I've also got a free Teamviewer for personal use only.

  • iswanto
    iswanto Posts: 0

    The same here, never used any commercial license, just for personal use for less than 1 hour twice a month, both installation confirmed: Free license (non-commercial use only).

    But starting on 13 March 2021 seemed to have given this error, last used was on 28 Feb. 2021 without any connection problems.

    Both sides have re-installed the latest (same) version, to no avail, not even 30 seconds, closed the connection every time. When tried to connect, always received the following message:

    Unable to connect.

    Connection blocked after timeout.

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license.

    Connections to this partner will be blocked until xx:xx.

    Any idea ?

    (Last laptop SW update was done recently a few days ago)

  • Thrax
    Thrax Posts: 1

    Has anyone else ever experienced this? I have tried uninstalling, removing settings, restarting, reinstalling several times, but nothing seems to help.

    The issue should not be related to my internet, because my laptop can stay connected to people normally, just not my PC. I'm not running any kind of VPN, and my time/timezone are set correctly.

    I have not been flagged for commercial use and my connections aren't lasting anywhere near 5 minutes anyway. I'm sure that it disconnects in <1 minute

    I really love this software. Please help.