Commercial use - Connection time out



  • M_S_R
    M_S_R Posts: 1

    How can i change teamviewer ID when requesting for reset my account as it has been detected as a commercial user but its actually not.

  • lvfbutch
    lvfbutch Posts: 5 ✭✭

    I have been using the free version for months, actually years. It just quit and I cannot get anyone to email me back to re-set it. It says I have the free version but it is treating it like the commercial version. I sure need it to work again. I did download an iphone update maybe that had something to do with it.

  • garycase
    garycase Posts: 7 ✭✭
    edited March 2021

    I've had the same issue since about October ... connects fine, but within 30 to 40 seconds it times out and shuts down, so it's useless.

    I've tried reinstalling; using a different computer; etc. and nothing helps.

    Here's what happens after 30 to 40 seconds ...

  • DataGeek
    DataGeek Posts: 1
    edited March 2021

    I can see many folks complaining about this issue, some merges, thought I would add my observations. Love the product (until this current Bug), I have two local win10 pc's, both fail connecting to my dads (remote) win10 pc. The Teamviewer session connects for about 30 seconds, then drops. If I try to reconnect, I get a message that TeamViewer cannot reconnect for a few minutes into the future. If I wait a period of time, the same scenario occurs. I tried to connect to my local second win10 pc without an issue. All three devices are running the latest teamviewer app ver. 15.15.5. I have my local log files saved, see lots of apparent issues, but need smarter folks to analyze. I tried sending the "non commercial use form" in case that was related, but np apparent changes to issue.

    [PDF has been removed as per the community guidelines.]

  • Domalb81
    Domalb81 Posts: 1
    edited March 2021

    Ok I see we all have the same **bleep** problem. Is their a Fix..... yes or no?

  • garycase
    garycase Posts: 7 ✭✭

    Note: I am NOT getting the "commercial use suspected" message (which the warning message above seems to imply). The system works fine in terms of connecting another computer -- it's simply useless as it disconnects within less than a minute (as shown in the messages I get).

    I did, nevertheless, submit the form suggested in the warning post, as it seems to be the only way to generate a ticket with Teamviewer ... trying to do it through the Support links simply brings me back to the community forum with no way to generate a support ticket.

    One other thought -- this issue happened around Oct or Nov. I didn't think about it when I first had the issue, but this may have started around the same time I upgraded to v20h2. I'm running the latest version of Teamviewer (and have uninstalled/reinstalled several times trying to get this to work).

  • T_Myers
    T_Myers Posts: 1

    I've been TeamViewer for years (free license) from time to time when my parents need help with their computer. All of a sudden, I get disconnected after a few min and it will not let me back in stating I've passed my time limit.

    As something changed?

  • rocketmanb
    rocketmanb Posts: 1

    I never received a message saying there is no time remaining for use with the host within my home that I log into from upstairs. It also says that I am being upgraded to a business account, for which I do not want to pay. How can I go back to my personal use license.?

  • Bob_N6RW
    Bob_N6RW Posts: 3 ✭✭
    edited March 2021

    Don't hold your breath waiting for a solution anytime soon. After looking at garycase's first comment about having this problem back in October, I looked back in the feed to see when the quick time-out problem started. It appears that the first complaint was in May 2018 (page 31). The complaints switched from "commercial use suspected" to just plain time-outs in less than one minute. I don't know what the usage limit is for the free accounts, but maybe we each get the problem when we hit that limit. I had no idea that there was a limit (if there is one) until I first got the time-out on March 19th. I started using TV on the evening of March 10, when I connected to the computer at my remote amateur radio location. I just left it on continuously while I played with the remote station. If any TV support techs actually look at this feed, they are probably amused at my conjecture - but maybe not.

    It would be nice to know what the usage limits are, but I haven't found them yet. Wouldn't it be nice if a support person would tell us what the limit is or what our problem is. It has been almost three years now.

    If they aren't going to fix the problem, then our choices are to (1) buy one of their licenses or (2) find another provider that doesn't cost so much. [removed per Community Guidelines]

    For me, it doesn't matter which choice to make. TeamViewer's failure to keep me connected, while in the middle of a radio contact, taught me a lesson. [removed per Community Guidelines] I just got lazy and thought I could just use TeamViewer for a short time instead of going through the hassle of connecting up the Remote Rig units.

    I have a feeling this post won't last long before it is removed, but perhaps TV would love to get rid of us freeloaders and use their servers for revenue production.

  • hgtt
    hgtt Posts: 0

    same here, shall we just wait? OR any link to contact

  • melloa
    melloa Posts: 0

    Why my post was merged here? It has nothing to do with commercial use. I have 8 computers using it and use once or twice/week if that. Just been disconnected after a minute or so.

  • Katy35_onSt
    Katy35_onSt Posts: 2 ✭✭

    Hi there,

    I have been using Teamviewer for over a year now. I help my nephew with his schoolwork. I got a message saying that I have reached my maximum session duration with him due to licence limits.

    What do I do now to stay connected to him?

  • dopalaczxl
    dopalaczxl Posts: 0
    Hello. I have had a problem for some time, my connection is disconnected because the system has detected that the program is used for commercial purposes.
    What can I do with this?
    I had a laptop connected with a phone and once in a while I needed it when even my other half could not print documents.
    I don't run a company, I don't work remotely.

  • icaruswp
    icaruswp Posts: 0

    Dear Sirs

    I'd like to claim that my TeamViewer account is suspected as Commercial, however I'm using it only to access a couple of my own devices and my parents' PCs. I can prove it by providing all the necessary data about each device. Waiting for your comments. Thank You!

  • kellyloraine
    kellyloraine Posts: 2 ✭✭
    edited March 2021

    Hi all,

    I'm having an issue where my connection times out (free license non-commercial use) after just a few minutes, then when I try to reconnect, I keep getting the message "Connection blocked after timout. Your license limits the maximum session duration...... Connection to this partner will be blocked until..." and even when I wait until past that specified time, I get the same error again with a new time.

    I have three computers connected to my account -- my new laptop, my older laptop, and my mom's laptop -- so I can act as tech support for my mom (lol). I only have this issue connecting to or from my new laptop. Older laptop is on the same wireless internet and is fine.

    Thanks in advance!

  • Jules55
    Jules55 Posts: 0


    Is anyone else having issues with the windows updates released on the 23rd March 2021 ?

    I think the numbers are KB4589212 and KB4601554.

    I have two systems both Windows 10 - i5 Platform Systems

    One did the updates the other didn't.

    The updated system now times out within a minute the other stays connected as it all ways had.

    Nothing else has changed as far as I can see.

    I have had a issue / Dymo had issues this month when an update stopped all their label software from printing,

    all you got was a blank label.

    Looks like Teamviewer may have similar issues........



  • Jules55
    Jules55 Posts: 0

    Both systems are using:

    Teamviewer 15.15.5 ( 32bit )

    Feb 17th 2021 18:13

    Version Software

  • kellyloraine
    kellyloraine Posts: 2 ✭✭

    Hey, There is no mention of suspected commercial use in any of the messages that pop up or anywhere on my account when I face my issue of a timed out session. My question was merged with this thread. Is it indeed then suspected commercial use? Thanks!!!

  • JeffMc4
    JeffMc4 Posts: 0
    edited March 2021

    Hey Everyone.. I've been using Free TeamViewer for years.. I connect to my home computer every day to assist my children with remote learning. I love the program. Starting yesterday, after about 1 minute of being connected, the session times out. This has never happened before. I've tried this for 2 days now and can't stay connected for longer than a minute.

    I have the latest version installed and nothing has changed from Friday when I used this and it worked fine. Is anyone else having this issue?

    Thanks for any help!

  • Rootdet
    Rootdet Posts: 0

    they deleted a big thread here on it. seems like this is the new "free tier", and they rather have people just leave the platform.

  • tinem
    tinem Posts: 7 ✭✭

    I have the same problem and are about going crazy. Did you solve this problem, please tell how?

  • priyankapotluri

    How to resolve this issue? Please help meASAP

  • CNewhouse
    CNewhouse Posts: 1

    Message reads connection blocked after time out. Your license limits ..... to partner

  • degarmoj
    degarmoj Posts: 1

    I have the  free version and it keeps timing out. Only after 1 minute.

    Error Message:

    Connection blocked after time out.

    Your license limits the maximum session duration to a partner.. Immediate reconnects are blocked.

    Try later or upgrade your license.

    I never had this problem before

  • José_António54
    José_António54 Posts: 10 ✭✭
    edited March 2021

    Good afternoon

    I have long used the free version of Teamviewer for private use of Teamviewer for remote sessions.

    Now I have a problem when I enter the remote computer, I get a message "Connection blocked after time exceeds" and cancels the connection in less than 1 minute.

    I don't know why, but I'd like you to enlighten me.

    My Account: **Do Not Post Email Addresses**

    Best regards.

    I await your answer.

    Thank you very much


    I can't attach the file with the error, so I report it here. "Connection blocked after time is over." "Your license limits the maximum session duration for a partner and new immediate calls are blocked.

  • ChocolateBiller

    I've been having issues with the same. Any updates? I am going to reach out to them for an answer. Will check back.

  • ChocolateBiller

    Just tried calling and no phone support for free users. I've tried uninstalling and reinstalling to no avail. I'm starting to believe Rootdet is correct.

  • Johnny_B
    Johnny_B Posts: 0

    That's a shame - I've been using it for years, especially to help my family etc. Hopefully it's something with a MS update that is causing this and not them, if so, I will not be paying 50/month. I'd pay 50 a year but a month? For personal use? Nuts...

  • BJK
    BJK Posts: 2 ✭✭

    I am not flagged as a commercial user. The newest version of the personal Teamviewer times out.

  • TranceAddictFoX

    Even if you're not getting the commercial warning you do need to reset. My teamviewer is back to working normally but I had to do resets on both my client and remote IDs. Took about 24 hours.

    To be clear I never got the warning about detecting commercial use. Not once ever. So it's doing this to people without the proper warnings TEAMVIEWER. Pay attention.

    Again: The reset link is on page 1 of this thread