link icon
Ask The Community

Commercial use - Connection time out



  • StevenEd
    StevenEd Posts: 1 Newbie

    TemaViewer, which has been rcok solid since December, is not working today. My use case is --

    * use free version

    * service running on a windows computer

    * access the remote service from the TeamViewer app on a Mac OS system

    Today, every time I connect the remote system display is visible. Within 30 seconds an error window is displayed that says the session has timed out. When attempting to reconnect I get a message that I cannot reconnect until a certain time. This time value is wrong in that I cannot reconnect for 5 or 10 minutes. In which case I can connect but I get the same timeout error.

    Attached are screenshots of my error windows.


  • amandafro
    amandafro Posts: 0 Newbie

    Ive been having the same issues !!!! I am not happy

  • twnorth
    twnorth Posts: 1 Newbie

    when i connect to our church projection pc the session times out after about 30 sec and then closes.

  • OlegAR
    OlegAR Posts: 1 Newbie
    edited March 2021
  • OlegAR
    OlegAR Posts: 1 Newbie
    edited March 2021

  • MrSzymon
    MrSzymon Posts: 1

    It's almost as if they want to get rid of their free users, no?

  • cdry
    cdry Posts: 0

    Hahooooo! someone to answer, the problem is not solved for me or anyone else ... it is not a solution that the company is silent and does nothing. what kind of communication manager do they have? the whole thing is frivolous.

  • Jayjay70
    Jayjay70 Posts: 0 Newbie

    Hi, I'm using my Teamvies to connect my iMac and laptop to mu HamShack PC This is purely for my own convenience, so I do not need constantly walk different rooms.

    Also I use Teamviewer to maintain my 72yr's old dad's computer in different town.

    Why do I get disconneted after minute or so? This started to happen just maybe two/three weeks ago.

    Br, Janne

  • br1an0hara
    br1an0hara Posts: 0 Newbie

    I've had a Personal Use account since 2011. Now it has been restricted. I have completed the Reset-Request form and despite ensuring all fields filled, clicking the Generate PDF button does nothing - therefore I cannot submit the request. Can anyone suggest how I can resolve this, please?


  • Chappy6975
    Chappy6975 Posts: 0 Newbie

    Ok perform reset as described with link on Esther's blog, even after you get email that account is reset it takes a few more days to work. In the mean time download Team Viewer app from Microsoft store

  • BB63876
    BB63876 Posts: 2 ✭✭

    Going on a month now and nothing from TV, which ensures they will never see a dime from me. I have no problem paying for good software, and like many other users have stated I would have gladly paid for longer limits / better support if there was a reasonable 'personal' tier.

  • austin8356865
    austin8356865 Posts: 1 Newbie

    I have been using the free version of teamviewer for a few years now, and this is the first time I have seen this error. But I cannot connect to my remote pc for longer than 3 minutes. From what I have read, this is happening to others, and there is no easy way to get ahold of teamviewer, so you have to ask this question in the forums.

  • jjwillis39
    jjwillis39 Posts: 7 ✭✭

    Why time out auto under free session

  • slingshot202
    slingshot202 Posts: 0

    I'd like to add myself to the list, but I have found something interesting.

    On my home personal PC I am connecting to the remote devices and it keep saying my "free sessions has eneded" then I also got the messages about the block.

    Now on the other side of this, I can connect to these units on my phone and I did not experience a time out, same router. I also utilized my mother's computer which I usually remote to, to connect to another one of my remote PC's in my house and it worked w/o issue as well. So, what gives?

    I think I am going to unistall and re-install.

  • gmxx
    gmxx Posts: 0 Newbie

    Just for the record requesting a reset via the PDF link -> sign -> upload ... does not work. I did that, got the email that my ID got reset and ok to use for personal. It didn't work, still got disconnected randomly either after 5 sec or 1 minute. So I just submitted the second round of reset request, see what'll happen.

  • bcatoe
    bcatoe Posts: 13 ✭✭

    I just read thru a couple pages of this thread. I don't see any response from Teamviewer support on how to address the issue. I'll join into the thread with this very specific question.

    We have a commercial license and use it properly. I also use TeamViewer for personal use to help family, which is a perfectly legit use of the free version. I run the Teamviewer app, logOUT of my corporate account and logIN to my personal account. I connect and get kicked (timed out) after 30 sec or so. In the past, I would get something like 5 min.

    Teamviewer site claims 'TeamViewer is free for personal use. This can’t be overstated. There are no fees, no time limits, and no subscriptions." and yet I am unable to use this. I assume it has something to do with me also having a corporate account.

    @TeamViewer What is your supported method for having both a corporate and personal account?

  • Chadm31
    Chadm31 Posts: 1

    I cant' seem to figure out why my connection to a remote computer keeps timing out on initial connection, every time. The computer is in my trusted connections and I have connected to it before. It shows online, but when I connect, it goes through the process the immediately times out. Thoughts?

  • itsjustrobby
    itsjustrobby Posts: 1 Newbie

    Hi there, I use teamviewer to manage my own personal 5 computers at home as well as help my dad with his two computers remotely, all are logged to my account for easy access. I've been getting kicked out of teamviewer sessions shortly after connecting though, this is the message that appears when I try to reconnect. Is teamviewer free for personal use? because that is the way that I'm using it. It's helpful because I don't have to access all the computers physically in order to make changes or config things..

    Any help is greatly appreciated!



    CKPETE Posts: 0

    I just began experiencing the same issue. I recently changed my router to use pfSense, and am using it to host a personal cloud. I had thought maybe that could have flagged my IP as a 'business' or something to that effect. Do you have anything similar set up, or does this appear to be independent of that?

  • itsjustrobby
    itsjustrobby Posts: 1 Newbie

    They are saying do a commercial reset. No problem. Idk about getting a "warning" though, seems kind of negative. The error message within teamviewer says nothing about commercial license.

  • slingshot202
    slingshot202 Posts: 0

    Unistalled and reinstalled. No luck. This is frustrating.

  • gharman
    gharman Posts: 1


    I have a personal account and when I connect to my cottage the connection only last about a minute and then gives me a popup "Your Teamviewer session has been timed out and will be closed". When I try to reconnect it give a different popup "Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license." It then tells me to try again in ! minute, which of course if fails and give the same message. What am I missing her? I can still connect to other PC's.


  • Matanz
    Matanz Posts: 1


    I have a free licence and i get the following error (frequently):

    I get it after only one connection during the day.

    Please help me,


  • Nick_Russell
    Nick_Russell Posts: 3 ✭✭
    edited March 2021

    Hi. I use the free version to help my mother and friends, about 15. I have tried to add another friend but when I try an connect, after a minute or so I get a "Connection Blocked after Timeout" message and I get disconnected. Same using QS or installed TeamViewer. Only difference is he has a Mac, all my other friends use Windows.

    Can anyone advise why this should happen and what I can do about it? I do not get a "Commercial use" message so I don't think I need to reset, and anyway other people are OK.

  • JoePlumber
    JoePlumber Posts: 1 Newbie

    Sessions are timing out after just a few seconds. What needs to be do to resolve this problem?

  • SSilvestre
    SSilvestre Posts: 0 Newbie

    Just like most people here, I need to support my aunt. And I am getting this message all the time:

  • pixelwiz
    pixelwiz Posts: 1

    Hi, I'm trying to help my mom with her laptop remotely. This used to work perfectly, now after I connected, it disconnected me after a few seconds and keeps giving me that my session timed out and can't be restarted for 60 seconds. I wait a minute or 2, try again, get the same error message. I tried to connect from my desktop to my laptop, and experiencing the same problem. I have a personal license, but I should be able to help my mom or connect to my other computer for more than a few seconds right?

  • slenisap
    slenisap Posts: 1

    I have a free licence ( only private use) but if I try to connect with my friends, after few seconds it comes a windows by saying : "Connection blocked after reaching the maximum time ; Your license limits the maximum duration of a session with a partner ; Immediate connection attempts are blocked; Connections with this partner will be blocked until..."

    I do not understand what it happens ; I never had problems with Team Viewer...

    May I have some help ?

    Thanks in advance

  • WeeBoo
    WeeBoo Posts: 1 Newbie
    edited March 2021

    I am having the same issue since today, wanted to help my parents and after 1 minute I got disconnected... and can't use it anymore.

  • hbosh
    hbosh Posts: 0 Newbie

    Am receiving the same error today - extremely annoying. The customer support phone system says free users have to use the community for help but i'm not sure where to contact someone official on here.