Commercial use - Connection time out



  • bcatoe
    bcatoe Posts: 13 ✭✭

    I just read thru a couple pages of this thread. I don't see any response from Teamviewer support on how to address the issue. I'll join into the thread with this very specific question.

    We have a commercial license and use it properly. I also use TeamViewer for personal use to help family, which is a perfectly legit use of the free version. I run the Teamviewer app, logOUT of my corporate account and logIN to my personal account. I connect and get kicked (timed out) after 30 sec or so. In the past, I would get something like 5 min.

    Teamviewer site claims 'TeamViewer is free for personal use. This can’t be overstated. There are no fees, no time limits, and no subscriptions." and yet I am unable to use this. I assume it has something to do with me also having a corporate account.

    @TeamViewer What is your supported method for having both a corporate and personal account?

  • Chadm31
    Chadm31 Posts: 1

    I cant' seem to figure out why my connection to a remote computer keeps timing out on initial connection, every time. The computer is in my trusted connections and I have connected to it before. It shows online, but when I connect, it goes through the process the immediately times out. Thoughts?

  • itsjustrobby
    itsjustrobby Posts: 0 Newbie

    Hi there, I use teamviewer to manage my own personal 5 computers at home as well as help my dad with his two computers remotely, all are logged to my account for easy access. I've been getting kicked out of teamviewer sessions shortly after connecting though, this is the message that appears when I try to reconnect. Is teamviewer free for personal use? because that is the way that I'm using it. It's helpful because I don't have to access all the computers physically in order to make changes or config things..

    Any help is greatly appreciated!



    CKPETE Posts: 0

    I just began experiencing the same issue. I recently changed my router to use pfSense, and am using it to host a personal cloud. I had thought maybe that could have flagged my IP as a 'business' or something to that effect. Do you have anything similar set up, or does this appear to be independent of that?

  • itsjustrobby
    itsjustrobby Posts: 0 Newbie

    They are saying do a commercial reset. No problem. Idk about getting a "warning" though, seems kind of negative. The error message within teamviewer says nothing about commercial license.

  • slingshot202
    slingshot202 Posts: 0

    Unistalled and reinstalled. No luck. This is frustrating.

  • gharman
    gharman Posts: 1


    I have a personal account and when I connect to my cottage the connection only last about a minute and then gives me a popup "Your Teamviewer session has been timed out and will be closed". When I try to reconnect it give a different popup "Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license." It then tells me to try again in ! minute, which of course if fails and give the same message. What am I missing her? I can still connect to other PC's.


  • Matanz
    Matanz Posts: 0


    I have a free licence and i get the following error (frequently):

    I get it after only one connection during the day.

    Please help me,


  • Nick_Russell
    Nick_Russell Posts: 3 ✭✭
    edited March 2021

    Hi. I use the free version to help my mother and friends, about 15. I have tried to add another friend but when I try an connect, after a minute or so I get a "Connection Blocked after Timeout" message and I get disconnected. Same using QS or installed TeamViewer. Only difference is he has a Mac, all my other friends use Windows.

    Can anyone advise why this should happen and what I can do about it? I do not get a "Commercial use" message so I don't think I need to reset, and anyway other people are OK.

  • JoePlumber
    JoePlumber Posts: 1 Newbie

    Sessions are timing out after just a few seconds. What needs to be do to resolve this problem?

  • SSilvestre
    SSilvestre Posts: 0 Newbie

    Just like most people here, I need to support my aunt. And I am getting this message all the time:

  • pixelwiz
    pixelwiz Posts: 1

    Hi, I'm trying to help my mom with her laptop remotely. This used to work perfectly, now after I connected, it disconnected me after a few seconds and keeps giving me that my session timed out and can't be restarted for 60 seconds. I wait a minute or 2, try again, get the same error message. I tried to connect from my desktop to my laptop, and experiencing the same problem. I have a personal license, but I should be able to help my mom or connect to my other computer for more than a few seconds right?

  • slenisap
    slenisap Posts: 1

    I have a free licence ( only private use) but if I try to connect with my friends, after few seconds it comes a windows by saying : "Connection blocked after reaching the maximum time ; Your license limits the maximum duration of a session with a partner ; Immediate connection attempts are blocked; Connections with this partner will be blocked until..."

    I do not understand what it happens ; I never had problems with Team Viewer...

    May I have some help ?

    Thanks in advance

  • WeeBoo
    WeeBoo Posts: 1 Newbie
    edited March 2021

    I am having the same issue since today, wanted to help my parents and after 1 minute I got disconnected... and can't use it anymore.

  • hbosh
    hbosh Posts: 0 Newbie

    Am receiving the same error today - extremely annoying. The customer support phone system says free users have to use the community for help but i'm not sure where to contact someone official on here.

  • danno3
    danno3 Posts: 1

    I went through the online steps to request a 'reset', but it only allows 1 TeamViewer ID. I submitted and uploaded the reset form. When I tried to generate a 2nd reset form for my other TeamViewer ID, it simply generates the same form as before.

    I'm baffled by the arbitrary and random nature of these blocks. Doesn't seem like 'commercial use' since I got the same block connecting to the same remote using my other TeamViewer ID (and that's hardly ever used - it's been at least a month since it was used). That remote computer had been accessed by my primary TeamViewer ID only once previously this month, generating an instant 'timeout', then was blocked from any further connection from any TeamViewer ID.


  • DavidCrosson
    DavidCrosson Posts: 2 ✭✭

    having timeout problem, need to talk to a person

  • Ron_Gale12
    Ron_Gale12 Posts: 1

    CAN any one help?????????

  • Craig_Sh
    Craig_Sh Posts: 0 Newbie

    I am encountering this same issue. Came here to ask why, maybe they updated on their backend that changed some accounts? I use Teamviewer to help assist family members with computer problems (personal use) as I cannot drive out to them most of the time. It just makes like much more manageable.

  • mommahawk
    mommahawk Posts: 1 Newbie

    I'm trying to connect to my daughters computer so that I can keep an eye on her doing her school work (home schooling is SO much fun lol) but I keep getting a message saying that the connection timed out but I am able to connect for a few seconds. This has been happening the past 2 days now. How do I fix this?

  • hodged02
    hodged02 Posts: 0

    Tonight I have come to use teamviewer for personal use and found after 2-5 mins that i had been kicked out of the session with an error saying i have been restricted and couldn't reconnect for a set amount of time. This has now happend on multiple occasions and was told that last time my account had been flagged as a potential business account, this is NOT the case, i use teamviewer to help my family with computer based issues, i would like to know why this keeps happening and this to be fixed please, could it be that i am using an old PC that i have a windows 10 Pro licence on? If so is there a fix for this as i really like teamviewer and have recommended it to so many people but at the moment dont feel i could do that now.

  • abdulhakeem
    abdulhakeem Posts: 3 ✭✭

    I primarily use Teamviewer to manage my Ubuntu home server/HTPC from my other machines (Windows desktop and Linux laptop). However I also occasionally help out family members with tech support.

    Been using Teamviewer for quite a long time, but now all of a sudden when I try to connect to my home server, the connection times out after roughly a minute, and then I keep getting "connection blocked after timeout" when trying to reconnect. Even when I wait until the specified time in the message ("connections to this partner will be blocked until 16:21"), it just gets blocked again and the time increases.

    I've seen others complaining about this and suggesting the possibility of "commercial use detected", but I haven't gotten any emails or notifications or anything about the "commercial use detected" message so I don't know if that applies to me.

    Does anyone know what's going on here? Is it just a bug in a new update or something? Maybe Teamviewer thinks that because I'm accessing my personal home Ubuntu server/HTPC that it's commercial use?

  • itsjustrobby
    itsjustrobby Posts: 0 Newbie

    This has been happening to me for the past two days

  • Smithvilla
    Smithvilla Posts: 1 Newbie

    I'm not! Strictly personal for fantasy baseball. i have already uninstalled and reinstalled. but the connection times out after maybe 5 minutes and a pop up box came up stating that teamviewer doesn't believe i'm playing fair.

    The computer in use has been used by my son to access his school, and has been used by my wife to access her adult school, but there's never been any commerical use of this machine.


  • BobM
    BobM Posts: 1
    edited March 2021

    I am having the same problem since the last update. Has something changed for free users that they did not tell us about? HELP!!!! I support my 92 year old dad, my 75 Year old Step Mother and My wife through Team viewer. Here are the errors I am getting:

  • Bizzybiz
    Bizzybiz Posts: 0 Newbie

    Yes me to. I only get a few seconds to log in then it kicks me out :(

  • Ace3x
    Ace3x Posts: 1 Newbie

    I would be able to successfully complete the connection, and see remote desktop. Then in about 10 seconds, the connection get dropped. Getting following error:

    Your Teamviewer session has timed out and will be closed

    When tried to reconnect, getting following error:

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license.

  • My user is been locked with the information of comercial use.

    I only have personal computers. that is why I select personal use.

    How can I resolve this ?

  • I am having the same problem, has anyone gotten an answer as to what the problem is? Can I downgrade to an older version?

  • MoBe
    MoBe Posts: 0

    I have the same issue. Can someone please post a solution to this? Thanks.