Commercial use - Connection time out



  • Keith_NM
    Keith_NM Posts: 2 ✭✭

    Yes! Same problem. It started a couple of weeks ago. No matter what I do, I connect to someone and I get timed out in about 1 minute. I'd love to know what the issue is.

  • Keith_NM
    Keith_NM Posts: 2 ✭✭

    Yes. I am experiencing the same problem. I get the immediate reconnect restriction as well. I sure hope this issue gets resolved as it is making TeamViewer impossible to use.

  • DGriffen
    DGriffen Posts: 1 Newbie

    Same problem here but only from the ipad to the desktop m desktop to desktop works fine.. however i suspect that it keeps saying that i am a business user when in fact i am a free user using my ipad to connect to 4 separate computers . If this keeps up i will be ditching team viewer for a competitor unfortunately. The other options are really quite poor

    all my Windows version are 10 home or pro . If you ask Microsoft to activate windows ... they will switch you to a non nagging inactivated enterprise licence which team viewer detects as a business user and kicks you off .

    so far TV is useless

  • JGM197
    JGM197 Posts: 1 Newbie

    It's amazing this program has gone so far down the drain.

    Same issue. Oh well, I've got Win10Pro on my machine so I'll just start using Remote Desktop to assist my Dad with his computer.

  • OneGrumpyDude
    OneGrumpyDude Posts: 4 ✭✭
    edited April 2021

    I've seen a bunch of other posts with the same thing. It has to be on the TeamViewer side I have tried reinstalling on both ends removing settings and deleting registry entries (accomplished on the remote end with another product).

    This really **bleep** as the Father-in-Law is going through a divorce and they are in the process of selling their property. I have been relying on this tool to support him with the attorneys and realtors. His technical ability is about a 2 of 10! Without my ability remotely help him with emails and document signing, he would be SOL.

    It would be nice if TeamViewer actually read these forums, but that doesn't seem to be the case.

  • kljhsdfsd
    kljhsdfsd Posts: 1 Newbie
    edited April 2021

    Same here. Kicks me out after about 15 seconds saying the connection timed out. It only happens with one of the machines I have attached to my account, but incidentally, it's the one I connect to most often. There is no message about trials or commercial use. This reeks of a licensing issue that Teamviewer is not being upfront about. Pretty disgusting, honestly...

  • Omega2
    Omega2 Posts: 2 Newbie
    edited April 2021

    what the **bleep** is going on? Mine is less than a minute. It's like 15 seconds. Then it BLOCKS me for 5+ minutes from reconnecting. This is hot garbage.

  • dcweather
    dcweather Posts: 10 ✭✭

    Keep getting unfair timeouts. Trying to follow reset procedure bu just stops at generate PDF? What is supposed to happen when you click on that button. Years of slight use perfectly, now nothing but problems.

  • Omega2
    Omega2 Posts: 2 Newbie
    edited April 2021

    What is this garbage? Out of nowhere I cant use this. No warning, no nothing.

    Download a PDF, sign the PDF, reupload. What the **bleep** is the point of this? There's such a thing as digital signatures, you know that right?

  • xinhao
    xinhao Posts: 0

    Hello, why is my account limited to 1 minute remote computer? I just check the information of my home computer from the company computer. Can you help me lift the ban.


  • rascoe
    rascoe Posts: 1 Newbie

    same problem here. started two days ago. trying to help my 89 year old father with his computer. teamviewer, please fix this asap

  • Ken_E
    Ken_E Posts: 0

    Over the last couple of days my teamviewer has been dropping the connection to my 90 year old dads computer after just a few seconds.

    After about 10 seconds it just says "Your teamviewer connection has timed out"

    I have reinstalled teamviewer on my desktop and my laptop and tried a test connection between them and I get the same result.

    I dont have a commercial use warning showing.

    I would be very grateful for some pointers.

    Thank you.

  • majestic100
    majestic100 Posts: 14 ✭✭

    Trust this is in the right catagory............

    I'm a Personal user of Teamviewer. I provide support to family and friends. I've had instances in the past of 'Commercial use Detected' but having completed and returned form, thought this issue had been resolved. Today friend called re printer issue and I asked him to fire up Teamviewer and I would connect and take a look. However, within 15 - 30sec of connecting (?) got 'Unable to connect' message window (see below) and obviously disconnected.

    No commercial use detected message so confused as to what has happened. Attempted to connect to my friend again and within, say 15 sec, was again disconnected but with the following message.............

    So, have been recognised as free for personal use but why am I being disconnected. Unable to help my friend other than give over the phone advice.

    Appreciate help to resolve.

    Thanks in anticipation

  • imgkc
    imgkc Posts: 8 ✭✭
    edited April 2021


    How is this commercial use? I'm accessing my personal pc's for personal use, I'm not accessing my work pc or any other work related device. There's no commercial use. Please explain.

  • markdmoss
    markdmoss Posts: 3 ✭✭

    I've been using TeamViewer to help family members (primarily with my mom) for several years. I don't need it often, so I'm not entirely sure when or how this started.

    Trying to connect from my home (PC) computer to my mom's (iMac) has now started connecting for about 1 minute, then disconnecting with a "Session Timeout" and not letting me reconnect ... giving me a pop-up that says I'm not allow simultaneous connections, and that I'm blocked until XX:XX (where the Xes are the exact current time). This is not commercial use, or a particularly recent installation, and I'm definitely not abusing the personal use license. Any clues how to fix this? I realize asking for help from the company for a freebie use license is an exercise in futility.

    Both copies of the software client say they are the most current version and up to date.

  • markdmoss
    markdmoss Posts: 3 ✭✭

    I'm having the exact same issue! I also posted a question. I'll let you know if I get an answer!

  • KJD
    KJD Posts: 0 Newbie


    I use teamviewer free to remotely access a few of my own personal workstations. I have a server that I remotely manage with plex and I use it every day for an hour or so. Suddenly yesterday my teamviewer began to abruptly close out after only 8 seconds with an error message 'Sponsored Session: Inactivity Timeout". It continues to do this when I make any connections at all. I tried several hours of troubleshooting, including reinstalling teamviewer on all devices. Teamviewer has become un-usable!

    I've checked all my settings twice over. Timeout time was set to OFF, but even changing it to 4+hrs has no effect on this. Teamviewer shows green ready to connect. I can connect remotely to my laptop and my server, both will auto terminate after 8 seconds. I have not had 1 successful session in 2 days

    My log files show a few errors:

    G2!! DataTransceiver: UIModel => RemoteScreenDragAndDropUIModel::IsIncomingDndOperationRunning: dndStateClient is null

    G2! JPEG message: Corrupt JPEG data: 8 extraneous bytes before marker 0xe0

    G2!! EmergingUdpConnection[3]::AsyncReceiveHandler receive failed e=10009

    G2!! PLItemPermissions::IsAllowed: ConnectionType unknown!

    G2!! PLConnector::Connect: Connection type not allowed.

    There are more, but these were from the bottom just before everything terminated. Everything should be working fine and I should be able to connect like I have been every other day.. Any help would be appreciated.

  • adamc85
    adamc85 Posts: 0 Newbie

    Hi Support,

    Team viewer is closing immediately after opening with the below message.. the session doesn't even open to display the remote screen before this message comes up.

    I'm currently using a free license since this is for personal use to my home computer.

    "Connection blocked after timeout.

    Your license limits the maximum session duration to a partner, immediate reconnections are blocked. Please try later or upgrade your license.

    Connections to the partner will be blocked until x:xx"

    Please let me know if you need any additional information to assist with this.


  • linuxlore
    linuxlore Posts: 4 ✭✭

    I'm getting this too and it is not to do with commercial use (except possibly as a side issue). I have confirmed my account is permitted and am still getting the problem, so there is a bug somewhere. With no way to contact TeamViewer without a commercial license this seems the only way to raise the issue, but if commercial licenses aren't seeing the problem I guess they have not major incentive to sort it. It is driving me up the wall trying to support family members I can't visit who are non technical. This really doesn't make me want to purchase the software if the time comes that I need it for business use!

  • WillyB
    WillyB Posts: 4 ✭✭

    Hello YooYJ,

    I have been experiencing the same very annoying problem. Did you ever figure out how to fix this issue?

    TeamViewer has worked very well for me for +-1 year then all of sudden this morning, out of nowhere, my connection is blocked and I find it somewhat suspicious that after it kicks me out up pops an Ad to Upgrade to a Business Plan for $699/yr. 🤔

  • I submitted my form to have my access reset to personal use yesterday and had an email today saying it has been reset. I haven't had a chance to try it yet but hoping that it's sorted out now.

  • xorxfon
    xorxfon Posts: 1 Newbie

    I would like to see a one time Non-Commercial payment to unlock the program so our time is not wasted and more importantly the company time is not wasted on someone constantly reseting the free profiles. Just a one time fee that lets TeamViewer know that I use the program on the regular but it is not for commercial use so there would be no monthly charges. Or just charge a monthly non-commercial license fee and watch the customers bleed away.

  • DvilDove
    DvilDove Posts: 1 Newbie

    I use team viewer to help my parents and one friend, yet I keep getting timed out.

    Where can I find the time limits, as well as how much I have used?

    Can anyone explain this to me or do I need to look for another solution?

  • ralnavman
    ralnavman Posts: 5 ✭✭

    I'm getting this for the 2nd time's really infuriating. Especially as I was 'warned' last time I posted the problem. I was contacted by someone (probably support) who apologised for the 'warning' saying it was an error but that I had to complete a form. I duly did that but I didn't get yet it was fixed.

    So I've been using it for about a week and bang, I'm chucked out again!! I've completed the form (AGAIN) but that was 2 days ago and I haven't received any email. It would seem that there is a general issue which they can't fix but it is getting really tiresome, I can't access my personal machines round the house (they don't have monitors etc..).

    And the weekend is approaching.....

  • jfbernard
    jfbernard Posts: 1 Newbie

    Hi to all,

    I'm get timeouts after very short connections, and afterwards I get the error window "Unable to connect" with the message "Connection blocked after timeout" etc.

    The message does NOT say "Commecial use detected" though. Is this the same problem anyways?

    Can you please help?

    Thank you so much!

  • jugdeep
    jugdeep Posts: 1

    I'm getting the same issue too

  • Jami1
    Jami1 Posts: 1 Newbie

    I'm getting the same issue.

    Anyone know how to fix this?

  • larryamay
    larryamay Posts: 2 ✭✭

    I am going to fix it after months of abasing myself in frint of these people, I am going to immediately Un-install, hope it does not screw up my computers and then install one of the other remote desk-tops that will work. Adios Teamviewer after many many years of enjoyment.

    Larry May

  • linuxlore
    linuxlore Posts: 4 ✭✭

    I wouldn't bank on it. I did that about a year ago, and thinking that I had been flagged commercial again with this timeout issue I did it again. I was told that I was already non-commercial a couple of days ago - hence assuming this is something bug related. It also tells me "Connection blocked after timeout", and "Your license limits the maximum duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license". This wouldn't be as bad if the session was longer than about 15 seconds or so, and if the block actually was removed when quoted (which tends to be about a minute later) rather than just getting the same message that indicates I will be unblocked if I want another minute (all be it only for another 15 seconds!).