I've activated but still looks a free account.

Sehun Posts: 2 ✭✭
edited May 2 in Licensing


I purchased remote access license, activated through email.

but, I can see my account as free on management console web page and TeamViewer App.

I tried to activate again through the email, then the error message showed.

"The license you tried to activate is already activated on another TeamViewer account."

please check what my account happened.



  • Ying_Q
    Ying_Q Posts: 2,237 Moderator

    Hi, @Sehun,,

    Thank you for contacting us.

    Please make sure that your sign in the licensed account on TeamViewer clients.

    Fee free to check out the activation information from the article below:

    Alternatively, you may raise a support ticket via Customer Support page for further assistance.

    Hope it would be helpful!

    Warm regards,

    Community Moderator/中文社区管理员
  • Sehun
    Sehun Posts: 2 ✭✭

    I don't think there's anything I can do.

    In user management page, there is "Request Free Trial" button.

    but as I described, I have purchased a remote access on this email account.

  • wassan
    wassan Posts: 1 Newbie

    hi there ,

    I am facing the exact same problem and can't get access to any help from team viewer . I tried to call them with no success and only given the option to post here ?

    What should I do ?