Commercial use - Connection time out



  • Tobi0711
    Tobi0711 Posts: 1 Newbie


    for months I was able to connect to my home PC from anywhere. Until one Day the message suddebly came up that my account was also being used commercial, which is definitely not the case. Can you help me what should I Do?

    Greetings Tobi

  • PhilipArgy
    PhilipArgy Posts: 2 ✭✭

    I am having the same issue. I am trying to support my 95 year old father and Teamviewer is literally his lifeline. Now it lets me login for about 90 seconds and then just disconnects. When I try to re-connect it says I've breached some time limit and can't reonnect until [current time plus 1 minute]. So I wait until [current time + 2 minutes] but get the same error message but with [current time plus 1 minute] again. So this time I wait until [current time plus 3 minutes] and so the loop goes. If I wait an hour it does let me log back in but only for another 90 seconds before terminating the connection.

    Something is seriously wrong and it has only started happening for me in the last week or so - I've never seen this before and I've been using TeamViewer virtually since it was released.

  • EdoM
    EdoM Posts: 0

    I am trying to reset my computers from being flagged as "Commercial User". I tried to populate 2 computers (this one and the one that I am commenting to) but only one machine populated. When I tried to complete another form, the company stated that I already submitted a form and I have to wait 24-48 hours. Any ideas?

  • chefire
    chefire Posts: 0 Newbie

    Please advise.

  • Groenenzo
    Groenenzo Posts: 0

    I help my blind mother navigate her computer. Why is this counted as commercial use?

  • Good day. Recently, there has been a report of suspicion of commercial use. But I didn't do anything like that. What should I do to get my status canceled?

    with respect

  • chito_u2
    chito_u2 Posts: 1 Newbie

    I only use the program once in a while, not for business.

  • Jerzy50
    Jerzy50 Posts: 1

    Good morning,

    My name is Jerzy Pogrzeże and I am a PhD student. Currently, I was using your program for teaching purposes, to be able to remotely check the progress of my analyzes on computers in my Department, which greatly facilitated and allowed me to save my time. For some time, the program doesn't allow me access anymore.

    Therefore, I would like to ask for a possible unlocking of access to the free version of the thresholds for teaching purposes, so that I can continue my research work.

    Have a nice day.

    Yours faithfully

    Jerzy Pognec, MSc

  • sfederici
    sfederici Posts: 1

    This started a few months ago. I'm using TV on a MacOS BigSur. Every time I open a TV session it closes after 10-15 seconds. I'm using a non-commercial license. Is this a wanted behaviour?

  • jphilippa
    jphilippa Posts: 35 ✭✭

    I have used Team Viewer for years to access a distant PC to offer help. For maybe a fortnight now, I have received a 'time-out' notification, after only a minute; and am then blocked from attempting a new connection.

  • JeanK
    JeanK Posts: 6,892 Community Manager 🌍

    Hello @Miroslav83023,

    You can delete your computers within the Computers and Contacts list.

    Community Manager

  • Trygwe
    Trygwe Posts: 1 Newbie

    Used TeamViewer Free occasionally for several years. Now I am blocked due to commersial use. I have been granted access several times but am each time thrown out with a message about commercial use. My use is exclusively private. What could be wrong? And what can I do. Since it can take several months between each time I use TeamViewer, the pro version is out of the question.

  • noobnoob
    noobnoob Posts: 1
    edited June 2021

    As the title says, how do I fix this? My connection is cut off every 5 minutes which is really annoying since I'm trying to help my mother with her aging laptop that also takes forever to load stuff.

  • j_czerwin
    j_czerwin Posts: 1

    I don't seem to be able to easily find a solution - so I'm going to post this everywhere I can and see if I can get TeamViewer help and/or post other software solutions we can use in a personal application.

    It is crazy that the timeout keeps coming up for no reason. I am not a commercial business, but something in their software is triggering the event and making a timeout in just a minute or two.

    Here is what I have learned so far:

    Solution #1 - Remove the app from all of your computers, and every hint of its existence, and reinstall. Uninstall the app. Then you have to search your hard drive (with hidden files showing) for every reference to TEAMVIEWER. Delete them all, files an folders. Then you also need to go into the command prompt and type REGEDIT. These are important windows values - be careful. Click on the very top line COMPUTER and then Edit>>Find or Control+F. Type in TEAMVIEWER and search. If it is in the left screen - delete it there. If it is in the right screen delete it there. Deleted everything you can. Search again and make sure all is gone. Then when there is nothing left you can delete, close the REGEDIT and reboot your computer. Then download and install again, selecting the free version. This all takes about 20 minutes. I did this on two computers and it solved the problem! ISSUE #1, I then installed the app on my iPhone and connected remote to one of the two computers. BAM! Timeout issue reappeared!!! Now I have to do everything again and not use the iPhone app.

    Updates to come.

  • I'm having the same issue. Never had this happen before. I'm considering other programs. There seem to be good alternatives out there.

  • deporter
    deporter Posts: 4 ✭✭

    For quite a while, I have not been able to help my friends because teamviewer times out after I am connected for about 30 seconds. What would cause this problem and how do I fix it?

  • deporter
    deporter Posts: 4 ✭✭

    I am not getting a message about commercial use suspected, just a message that my connection has timed out.

  • RAPullen
    RAPullen Posts: 2 ✭✭

    TV on one PC connects correctly. TV on 2nd PC drops connection within a minute (Session timeout). Both PCs have same settings for TV. Does anyone know why second PC has TV Session timeout error?

  • RAPullen
    RAPullen Posts: 2 ✭✭

    TV on one PC connects correctly. TV on 2nd PC drops connection within a minute (Session timeout). Both PCs have same settings for TV. Does anyone know why second PC has TV Session timeout error?

  • bcarl_37
    bcarl_37 Posts: 1

    I'm only on for 30 sec and get kicked saying session timer limit exceeded

  • jphilippa
    jphilippa Posts: 35 ✭✭
    edited June 2021

    Same here. I reported it in another post and got an email with a link to a 'reset', and was told to fill out a form, but there is no form to fill out at the link

    CHAT gives four options that do NOT include addressing my time out problem.

  • Hafiz116
    Hafiz116 Posts: 0

    Hi all,

    Can someone help to advise why my account has been restricted? I am just helping my sister-in-law and its frustrating that this has happened. How do I reset this?

    Thanks in advance,


  • FuzzmanKs
    FuzzmanKs Posts: 54 ✭✭

    Follow the directions exactly. No spaces between TV ID numbers, just use comma. No spaces in (non-usa) zip codes. Try that to see if it helps. Share your results here with others if it works.

  • FuzzmanKs
    FuzzmanKs Posts: 54 ✭✭

    Sounds like you are using TV commercially. That is not for personal/private use. Unless you know of some education exemption. Read the first message in this thread along with the blog mentioned in the message.

  • FuzzmanKs
    FuzzmanKs Posts: 54 ✭✭

    Good luck with that long procedure. I don't think it will work in the long run. Fill out the RESET MANAGEMENT form mentioned in the first message.

  • EdwardUK
    EdwardUK Posts: 47 ✭✭

    @FuzzmanKs it seems that you and I seem to be doing the heavy lifting for teamviewer in constantly pointing users to the need to go through the reset management process. 😃

    It would be so much easier if Teamviewer gave proper notice and a link to the reset process before they deem users to be commercial users.

  • dixongrm
    dixongrm Posts: 0

    Hi. I have logged four tickets for removing the commercial use flag, sending in all the correct teamviewer ID's etc. Each time I receive an email back from support stating that the flag has been removed... Yet I am still being flagged for commercial usage. Please help!

  • hllrzr22
    hllrzr22 Posts: 0

    I use this to connect to computers at home. Not for work. Im away from home with no access to printer or scanner to fill out the reset form. But need to access computer at home for more then 15 sec. How can i fix this?