link icon
Ask The Community

TeamViewer and Windows 11 (21H2) Update



  • sejal
    sejal Posts: 1 Newbie
    edited October 2021

    After updating into Windows 11 Insider Preview 22478.1000 , the remote controllling is glitched it get stuck in connecting just like in the pic

    i tried to connect to my friends laptop and in his laptop it say im connected even my cursor can seen moving but on my screen its stuck

    i've tried udp but not working

  • Paulo86Lima
    Paulo86Lima Posts: 1 Newbie

    Goodnight. I have the update available from Microsoft to fix the bug, but I still have issues.

    I disabled UDP and it's working fine now, but it hasn't been fixed with the mentioned HotFix.

    I use TeamViewer 15.22.3 (x86) with Windows 11 in clean installation, which I installed 2 days ago.

  • Kerstin_PO
    Kerstin_PO Posts: 77 Staff member 🤠

    Dear @Magzz, @skibax84, @yettisoft, @anhvip46, @Sebastien_BONNET, @ElrondIT, @sejal,

    thanks a lot for providing your feedback.

    Please be aware, that we can only give full support for the production release builds by Microsoft (currently 22000), not for developer and insider preview build versions (like the mentioned build number 22478), as we also need to do the tests and, if necessary, do some code adaptions.

    But, of course, we are very happy to already know about potential upcoming problems and will have a look into it.

    @Paulo86Lima Could you please double check, if you are using 22000 build number?



    Product Owner TeamViewer Core
  • amandhillon
    amandhillon Posts: 1 Newbie
    edited October 2021

    Hello all,

    I am having windows 11, build 22478 and I have disabled UDP in teamviewer (as suggested in previous thread) but still I am not able to login to my remote machine.

  • FredrikP
    FredrikP Posts: 2 Newbie

    Same here i cant connect to remote computers with windows build 11 pro insider preview 22478 211008-1414

    I've tried disabling UDP but this has no impact, the screen stays the same.

  • Luc_chivas
    Luc_chivas Posts: 2 ✭✭

    I Have exactly the same issue Build 22478.rs_prerelease.211008-1414 and teamviewer 15.22.3 (64 bits)

    Try to disable UDP.. same issue.

  • Greengrenadez
    Greengrenadez Posts: 2 ✭✭

    I had the same issue. After each reboot, simply sign out and sign back in and this will fix a lot of the issues with current build of Windows 11 (22478.1012)

  • Magzz
    Magzz Posts: 2 ✭✭
  • ElrondIT
    ElrondIT Posts: 3 Newbie

    Issue appears to be fixed in build 22483 dev

  • TechReality
    TechReality Posts: 5 ✭✭

    Not sure if this will help anyone, but I had some issues myself that just happened, with no real reason!

    I first did an uninstall of TeamViewer and then re-installed it, with same issues.

    Next up, uninstalled it, and then removed the TeamViewer folders from appdata\local folder and the appdata\roaming folder.

    Also double checked that there was no leftover files in c:\program files\

    Installed the same package that I downloaded previously, and bizarrely I am now connecting fine!

    At least it's another thing to try if all else fails!

  • Sebastien_BONNET
    Sebastien_BONNET Posts: 6 ✭✭

    i have install full release versoj windows 11 21H2 22000.282 and TV fresh installed works fine

  • buckowski
    buckowski Posts: 6 ✭✭

    I had issue with Windows 11 builds 22478.1000 and newer. After successful connecting to remote PC I can see only glitched "connecting window" not the remote PC screen.

    To solve this issue you have to revert back to Windows 11 build 21xxx.xxxx.

    Second option on AMD processor and graphics was install latest AMD drivers. Now it works again. But I have similar issue on second computer with Intel and Nvidia.

  • I would like to prevent my users from upgrading on their own, how can we leverage your patch management and build a policy that doesn't allow this to happen? I work for a smaller company which never implemented active directory. Literally just deployed computers as needed where ever without any infrastructure.. about 50 to 60 pcs/laptops. Thanks for the help on this.

  • kamboh
    kamboh Posts: 1 Newbie
    edited November 2021

    Several windows 7, 8, and 10 users ask how to fix it: windows can’t find one of the files in this theme. The users with the error said that it occurs at that time when they aren’t using the computer for a while. So if you are facing this issue as well, we are here to provide you the quick solutions.

    Even after clicking on the yes option from the error box, it will not disappear. The error occurs with a file named “settingsynchost.exe.” Apart from that, you will have

    an error because of the current theme that you are using.

    There are some common causes of this issue that you will know below in our guide. Read on for knowing more about it! Follow the instructions step by step to resolve the problem correctly.

  • FeedForwardTech
    FeedForwardTech Posts: 2 ✭✭

    Hoping the ability to manage Windows 11 workstations comes soon as clients are wanting to upgrade.

  • CarlZ
    CarlZ Posts: 3 ✭✭

    Can not make TeamViewer work with one of my new remote machines (Windows 11). I'm using the latest 15.24 version on both machines. All Windows 10 machines work perfectly. I can connect & see the desktop of the remote machine but have no control. "Full Access" is checked. Tried removing all AV software, still no joy. Is there some sort of security setting I'm missing?

  • user135711
    user135711 Posts: 1 Newbie
    edited December 2021

    I had teamviewer crashing on windows 11 whenever I connected to a remote and when I disabled hyper-v with "bcdedit /set hypervisorlaunchtype off" in an elevated prompt and restarted to fix vmware, teamviewer started working along with vmware. I am almost sure it was a coincidence but I can't think of anything else I changed that could have fixed it.


    I just realized I also had a windows update with the same restart. I'll bet that's what did it. Anyone trying can use "bcdedit /set hypervisorlaunchtype auto" to re-enable hyper-v

  • Teressa
    Teressa Posts: 2 ✭✭

    I seem to be experiencing the same issue as @CarlZ. From my Windows 10 computer, I am using TeamViewer 15.25.8 to connect to a new Windows 11 computer. Initially, I could connect and control the remote endpoint. All of a sudden I was unable to click on anything in the remote computer and the remote screen stopped refreshing in my TV. I tried removing the default antivirus that came on the new computer (McAfee) and I tried shutting off the Windows 11 firewall in case it was blocking. Neither helped. The only other thing I can think of is that the new Windows 11 computer might have been downloading updates as it was just recently turned on; maybe a Windows 11 update is not compatible and that broke my ability to control the remote computer with TV?

  • imb123
    imb123 Posts: 1 Newbie
    edited December 2021

    I've not read all the comments above so sorry if this is a duplicate. I've connected from a windows 10 laptop to a windows 11 desktop When I click the start button on the remote desktop computer I don't see the app dialog. There's a hint of a right edge of a window.

    Update: having gone to the trouble of connecting a monitor to the remote desktop (remote is 2m :-)) I can now see the apps dialog when I click on the start button when operating the remote machine from the windows 10 laptop. This rather defeats the object though. I usually use the desktop far from the router and use wi-fi. But, I want to download a particularly large file so brought it down to connect to the router by wire. I hoped to avoid bringing down a monitor, keyboard and mouse.

  • Kerstin_PO
    Kerstin_PO Posts: 77 Staff member 🤠

    Hi @CarlZ , @Teressa ,

    thanks a lot for your feedback and sorry for the inconveniences.

    Could you maybe check the Windows build number that is installed on your Win11 computer? Are you using the Windows Insider Program?

    Thanks a lot for your help.

    Best, Kerstin

    Product Owner TeamViewer Core
  • CarlZ
    CarlZ Posts: 3 ✭✭

    Thanks Kerstin. I should have physical access to the remote machine in a couple of days. Not an insider build for sure. It's a brand new Dell machine for Grandpa. My details are almost exactly like @Teressa. Uninstalled the factory shipped McAfee. My first attempt was using TV Host on that machine. Exactly as described by @Teressa "Initially, I could connect and control the remote endpoint. All of a sudden I was unable to click on anything in the remote computer and the remote screen stopped refreshing in my TV." Control lasted less than 10 seconds. I then had them install the full version. No control ever at that point. I can connect & see the screen (black screen though, no wallpaper showing) but that's it. Will update you when I gain physical access.

  • CarlZ
    CarlZ Posts: 3 ✭✭

    Windows 11 Home 21H2 22000.376

    Well, it's working now. Not sure what fixed it though. Updated TeamViewer to latest 15.25.8 version. Didn't work for @Teressa so I doubt that's it. Cleaned out all the Dell crapware (10+ programs). Also found a second McAfee entry & deleted that as well. @Teressa, happen to be working with a new Dell?

  • Teressa
    Teressa Posts: 2 ✭✭

    I am also working with a new Dell, Inspiron 5510. I removed the McAfee Antivirus but I did let the McAfee Webroot program stay. My version is Windows 11 Home, 21H2, OS Build 22000.376. Windows Feature Experience Pack 1000.22000.376.0. Not an Insider build.

    After the first issue occurred, I left it during the next day and tried again after work that night. It was miraculously working. I suspected that a Windows update might have fixed the problem. However, over the next few days as I continued to use TeamViewer to access the remote computer to finish setting it up, I encountered the issue several more times. Usually a reboot of the remote Windows 11 computer would fix it. Once I had to reboot both my Windows 10 computer and the remotely controlled new Windows 11 computer to fix the issue.

    While TeamViewer is more flaky on Windows 11 than it had been on Windows 10, it's still an invaluable tool for helping my mother with her computer issues when we're in different states. Thank you so much!

    @CarlZ If you can recall what other Dell nuisances you removed, I'd welcome the info. Did you remove their My Dell, Support Assist software? Thanks.

  • fmartinn
    fmartinn Posts: 1 Newbie
    edited January 2022

    Same thing here.

    We are able to connect on PC's with W11. The icons that allows remote control are ON but we can't control mouse neither keyboard.

    Source Team Viewer PC OS version: W10 v. 21H1 ( compile 19043.1415)

    Source Team Viewer version: 15.25.8 (32 bits)

    Source Team Viewer License: Corporate (3 channels)

    Remote Team Viewer PC OS version: W11

    Remote Team Viewer version: Most Recents from December 21 until today.

    I hope I've helped you to find a solution for this.

    Ps.: We are literally installing **Third Party Product** to give support to our clients with W11. This is a very bad situation from the marketing's and sales' perspective. But as i am seeing here, I am not the only one and I know that you are working to fix this.

    Best Regards.

  • Kerstin_PO
    Kerstin_PO Posts: 77 Staff member 🤠

    Hi @Teressa , @CarlZ , @fmartinn ,

    thanks a lot for all your feedback.

    We will try to reproduce the issue. If we are not successful, we might come back to you with further questions to find and fix the problem.



    Product Owner TeamViewer Core
  • seltzdesign
    seltzdesign Posts: 1

    Just trying out TeamViewer with Windows 11 that I just freshly installed on another machine.

    Things I noticed:

    1 - Taskbar Icons don't seem to be updating. I change the position to center, but icons stay on the left. This happens even if I close the connection and reopen.

    2 - the windows menu is shifted and not fully visible if I have taskbar buttons on the left3

    3 - I cant scroll inside settings windows. Or rather I can see the vertical bar on the right go up and down, but not the contents of the settings menu.

    Everything else works fine, it just seems to be around the taskbar, home menu and settings that things are not updating.

    Using latest version of TeamViewer. Connecting from a Win10 PC to a Win11 PC.

  • okjasone
    okjasone Posts: 1

    In my experience, this issue is still occurring if the monitor on the remote device is powered off. When the monitor is powered on, or if 'Use UDP' is unchecked, Team Viewer works as expected.

    Connecting from Team Viewer 15.27.3 on Mac OS Monterey 12.3 to Team Viewer 15.22.3 on Windows 11 build 22000.493.

    Was also testing from Team Viewer 15.22.3 on Win 10.

  • Dtra0627h
    Dtra0627h Posts: 2
    edited May 2022

    Teamviewer - Please stop with the rhetoric and fix this already!!!!!!!!!!!!!

    Follow every comments with sound and solid "suggestions" including your very own attempt on "Advanced" UPD

    And YES we have been using PLUS remain loyal to Teamviewer since 2006, so NO LOW-Balling us on DEVs **bleep**!

    We are using everything legit per Teamviewer and Microsoft for Commercial

    PLEASE fix this or we will take our 700+ clients elsewhere, to be polite and professional?!

    Read us Teamviewer, as this will mount into a dive - the rest of us, been very helpful with all your inputs! TYSM guys...

  • JeanK
    JeanK Posts: 6,582 Community Manager 🌍

    Hello @Dtra0627h,

    Thank you for posting here.

    Could you explain to us a little more about the issues you are experiencing, so we can understand the situation better?

    Thanks in advance.


    Community Manager