State of Wayland & TeamViewer



  • jelabarre59
    jelabarre59 Posts: 25 ✭✭

    The problem is Wayland isn't even close to being feature-compatible, yet it gets shoved out as a replacement, and any complaint that it is missing something gets a hostile response of "well, no one uses taht anyway".  Really???  So if *I'M* asking for some function to be in place, something that existed in X11, that means the Wayland-fanboys imply that *I'M* nobody. 

    SystemD merely tries to do tto much.  It's trying to be the entire OS in itself, rather than a minimal, specific-purpose service to load other services.  And in shoehorning itself into every corner of your system, it breaks cross-platform support (when projects like GTK or Gnome build in SystemD dependencies, it means those become BROKEN everyplace else).  It's doing TOO much, too many things it shouldn't be touching.  It's the difference between "do one thing and do it well" vs "jack of all trades, master of NONE".

  • archesys
    archesys Posts: 1

    I'm using Gnome on Manjaro (based on Archlinux) and i get a message concerning Wayland, if you need help..




  • gssemeon
    gssemeon Posts: 1

    Thanks. It works. But at Debian 4.19.37-5 i used command :

    sudo nano /etc/gdm3/daemon.conf

  • stefanbc
    stefanbc Posts: 2 ✭✭

    Hello Daniel,

    as much as I appreciate the efforts the teamviewer team takes to build a native linux client, to me as a professional linux user (yes, also on the desktop!) the decision to only publish the native client, for me is a constant nuissance (and even more). As I am using presentation mode on a daily basis, am stuck with the last installer, delivering TV13 WIN, wrapped with wine.(works perfectly, btw!)

    I do not use the native client because it lacks a major feature, so I will not be of any help when testing it, unfortunately. But in my daily work life I have to annoy my communication partners constantly to download old quickjoin of quicksupport versions, even if they have recent teamviewer installed, to collaborate with my colleagues. Of I am running TV on a WIn Terminalserver, which can be a pain.

    Is there solution in sight, either getting a recent version based on wine (will be greatfull to request it via support), or even better, a Linux native client sporting the ole' presentation mode?

    Thank you and best wishes


  • Ketterer
    Ketterer Posts: 7 ✭✭

    Had there been any headway with Wayland, its been over 2 years since this post was created. 


    I just saw that pipewire 0.3 was released and would love to see this move forward

  • modzilla
    modzilla Posts: 1

    I don't think so! At least not now.

    Does anyone else have the same problem with wayland. I can't log in to my account and am unable to connect to any machine. I use my phone to test as I know that this works on a windows machine at least.

    I'm on 20.04 but on 19.10 the same problem occured

    EDIT: Okay it seems to be a problem with phone connections. It works with a Windows server. Logging in also works after reinstalling so that's good.

  • kode54
    kode54 Posts: 17 ✭✭

    Meanwhile. Now there is pipewire for Gnome and KDE, and there are capture interfaces for wlroots compositors as well, as documented by such apps as wf-recorder. Still no word from TeamViewer central, who are probably not going to change this topic any time soon, if ever.

  • linuxlore
    linuxlore Posts: 4 ✭✭

    I think it is safe to say that there has been progress - unfortunately backwards. It doesn't work for outgoing connections on Wayland now it seems. I have just tried Wayland on my Ubuntu 20.04 install and although it starts and warns me that it won't work for inbound connections (which I don't actually need as I am just supporting family which is out), the list of Computers and Contacts is missing (just an empty Recent Connections header) and the Chat is not clickable at all (not that I actually use that, I'm generally on the phone or there is nobody at the other end at all). Thankfully I have other options I can move to.

  • hrx
    hrx Posts: 1

    Hi linuxlore,

    I have a similar problem on Fedora 33 Workstation - empty Recent Connections and the GUI becomes unclickable after a few clicks - which is going on for a month or two (earlier it was fine).

    I would usually just logout and enter the session, work with Teamviewer, and after finishing, relogin into the normal Wayland session. After playing around, I discovered that restarting the teamviewerd daemon after logging in makes the GUI behave normally again - although it still segfaults after closing the connection.

  • Skonsoft
    Skonsoft Posts: 2 ✭✭

    We have recieved an email from TeamViewer telling us that the price of our licence will be increased by 4,4% and for argument, they have made a newer versions that takes MacOs, Android and Windows... Ok we can undrestand this augmentation if Linux was included on these newer versions... Is it legal that they force us to pay extra for no real service ?


  • abdulhakeem
    abdulhakeem Posts: 3 ✭✭

    Hi it's now 2021 have you guys made any progress lol

  • drwolf
    drwolf Posts: 1

    Newest Ubuntu 21.04 utilizes Wayland as the new standard and I can't connect to my Linux machine anymore via TeamViewer.

    Do I understand correctly that TeamViewer did not achieve any progress since now 4 years?

  • YannCé
    YannCé Posts: 1

    Same problem here with Teamviewer Host version 15.20.6 H on a Raspberry Pi 4 under Ubuntu 21.04...

    Any news, please ?

  • janbenes
    janbenes Posts: 4 ✭✭

    When I use any Wayland-based desktop on host I cannot send any extra keys to guest. When I switch to xorg-based desktop I can. Too bad.

  • FubarCoder
    FubarCoder Posts: 3 ✭✭
    edited October 2021

    Isn't it possible to use a DBUS API ([removed per Community Guidelines]) for this? It seems that it's implemented by different desktop environments already.

    [Third party product]

  • rich5851
    rich5851 Posts: 2 ✭✭

    It's been 4 years. Come April when Ubuntu 22.04 LTS is released with Wayland as default this is going to be a show stopper for me and the cancellation of a corporate subscription.

  • FubarCoder
    FubarCoder Posts: 3 ✭✭

    Funny thing (not) is, the removed links were not in violation of the forum guidelines, because they were a link to API descriptions (and not a third-party product) that TeamViewer would need to use to implement remoting.

    @DanielStm explicitly wrote the following: "By design, Wayland does not provide an interface to do remote control" and "TeamViewer would have to implement different interfaces for every desktop environment", but this isn't correct any more. The DBUS API link is standardized and already implemented by different desktop environments. They "just" have to use it, but instead the link is removed with the hint: "Third party product" ...

    This is frustrating and disappointing.

  • EzequielPartida
    EzequielPartida Posts: 6 ✭✭

    OBS Studio has Wayland support since around a year or so. it´s opensource so I guess checking their source code could give you an idea on how to make Teamviewer Wayland compatible.

    Or just make Teamviewer OpenSource.. LOL :-D

  • cespinos
    cespinos Posts: 1
    edited January 2022

    Good morning, I would like to know if there is a date for the launch of teamviewer running on wayland completely, since it is the future of linux and teamviewer is lagging behind other tools that already offer it. In my case, I am waiting for it to be released to make a purchase of the license. while I continue with the competition

  • pkapetsonis
    pkapetsonis Posts: 1

    don't do this make your pc not boot!!! the best solution is to press the gear icon before login to your account on account list and select boot on xorg restart and your done

  • alshdavid
    alshdavid Posts: 1

    Hi 2022, any progress on this?

    At worst, can you have a toggle that forces the host to logout and back into an xorg session?

  • Subnet_Zero
    Subnet_Zero Posts: 1

    I'm glad to see that I'm not the only one visiting this post in 2022! I understand that it takes time to implement complex features such as this, so it would be greatly appreciated if someone could give a status update on the state of Wayland support for Linux - whether or not it's being actively developed still and maybe even a soft timeline of what to expect (i.e. later this year / next year / never / etc.)

    Thank you 🙏

  • JeanK
    JeanK Posts: 6,999 Community Manager 🌍
    Answer ✓

    Hello dear Community friends,

    I have quite some news for you...

    We started working on supporting Wayland! 🚀

    Please find more information in our Blogpost here:

    I hope you will be able to try it out.

    We would appreciate any feedback! 🙏

    All the best,


    Community Manager

  • Hrakason
    Hrakason Posts: 1

    Can someone provide a correct repo address for RPM preview or development version of Teamviewer.

    I can't find it anywhere, I tried to filled it myself but no luck so far.

    On my PoP Os - DEB version - I can go into Extras - Option and pick a version I want - or I can change it in sources.list.d.

    But I want to test it on Fedora - no luck there.


  • Kerstin_PO
    Kerstin_PO Posts: 78 Staff member 🤠

    Hi @Hrakason,

    so far it's only available in the preview version, which - unfortunately - is only supported on Debian based systems in general.

    As soon as the public release 15.29 will finally be available (please be patient for some more days), you can also test the Wayland support on Fedora.

    If you are using a Debian based version, the easiest way to update to the preview is as follows:

    sudo teamviewer repo preview
    sudo apt update
    sudo apt upgrade



    Product Owner TeamViewer Core
  • SilviuC
    SilviuC Posts: 2 ✭✭


    If using the 15.28.* client, is it normal not to see Groups and computers that belong to those groups?

    I can see the via browser in the management console and also if I log in using Xorg. I also noticed that my own ID changes betweeen the Xorg and Wayland sessions.