"The entered license is invalid"

theturnlab Posts: 1 Newbie
edited April 2021 in General questions

Incredibly frustrated with TeamViewer's service or lack thereof. I purchased a license weeks ago, received my confirmation email as well as the email with activation link however when I login it says I'm on a free subscription. I have my receipt and confirmation to prove that I did indeed purchase a license. When clicking the "Activate" button, a TeamViewer window opens in my browser with the notification, "the entered license is invalid". I've tried calling but apparently phone support isn't included. I've tried chatting but it's just a robot providing a link to the activation help, which does nothing for me. Would love some help so we can actually use this product, otherwise we may switch providers.


  • JoshP
    JoshP Posts: 866 Senior Moderator

    Hello @theturnlab

    Thank you for your post, and welcome to the TeamViewer community!

    I can confirm that no license is currently activated to your account.

    It appears, however, that you purchased a Business License, which does include phone support as well as the ticket support.

    If you could please PM me your order number, I am happy to take a closer look at your case.

    Thanks in advance!

    Josh P.

    Senior Community Moderator


  • I am having this very same issue. Please Help. Thank you.

  • CDrage
    CDrage Posts: 3 Newbie

    I've been a paying user for years but just this morning I got this same message saying my license is invalid.


  • Gsmi865
    Gsmi865 Posts: 1 Newbie

    I also purchased the business license and I too am getting "invalid License" I need this fixed asap. How can this be accomplished?

  • Also having the same issues. Did anyone get help with this? I need to log in.

  • Justin
    Justin Posts: 802 [Former Staff]

    Hello @Jleao1,

    Please check your inbox again now.



    German Community Moderator

  • Kenduro
    Kenduro Posts: 1
    edited July 2022

    Hello, also has the same issue, when extending Business license by one year. After purchasing the first attempt to activate has been failed. I asked a new activation link. The result was the same second time also: The entered license is invalid. Checking my profile it contains only free license.

  • Akiho
    Akiho Posts: 1,064 Moderator

    Hi @Kenduro,

    Thank you for your comment and welcome to the Community🎉

    In this case, could you please contact our customer support team via chat?

    You can initiate the chat from this page: https://www.teamviewer.com/

    *Please use the chat feature at the right bottom corner of the page😊

    Hope you find this helpful🍀



    Japanese Community Moderator / コミュニティモデレーター