Program startup

Options

When Windows starts, the program starts in a maximized window and does not minimize to tray. Have to constantly close the window with your hands. This is terribly annoying. In the advanced settings of check, the box "close to tray menu" is always inactive. How to make sure that when starting Windows program minimized to tray? Clipboard 2.jpg

Best Answers

  • Freitas229
    Freitas229 Posts: 1
    Answer ✓
    Options

    Hello everyone I managed to fixed buy uninstall the new version, and downgraded to the old version 11 https://www.teamviewer.com/en/download/previous-versions/previous-version-11x/

    and then I updated using the software not downloading the new version from the Internet.

    And now is working fine.

  • Frabinstein
    Frabinstein Posts: 3 ✭✭
    edited September 2023 Answer ✓
    Options

    I was able to fix this by editing the following registry entry:

    [HKEY_CURRENT_USER\SOFTWARE\TeamViewer]

    "MainWindowMaximized"=dword:00000000

    It had a value of "1" assigned. I switched it to "0".

Answers

  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    Options

    Hello @Dron007

    Thank you for your message. ?

    Unfortunately, we could not reproduce this issue.

    If you have ticket the box Start with Windows and the box Close to tray menu, it should work normally.

    Have you tried to reinstall the program and see if it works again?

    Best,

    Jean

    Community Manager

  • HexerPsy
    HexerPsy Posts: 1
    Options

    Hello @JeanK

    The issue is caused by the removal of the start minimized to tray feature in the new update. Is this a big or really a feature......?

    A reinstall does not resolve this issue.


  • HexerPsy
    HexerPsy Posts: 1
    Options

    Hello TeamViewer,

    In the recent update (V15.13.6) the option to start TeamViewer on boot while minimized seems to be removed...

    Terrible! Please fix this!


  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    Options

    Hello @HexerPsy,

    1) Go to the General settings (as on your screenshot) and untick Start TeamViewer with Windows

    2) Go to the Advanced settings and tick Close to tray menu

    3) Go back to the General settings and tick Start TeamViewer with Windows back again.

    With this, TeamViewer should start automatically and close to tray menu.

    Community Manager

  • Pavel_Penkava
    Pavel_Penkava Posts: 2 ✭✭
    Options

    Same problem here. It starts up maximized automatically even if the "Close to tray" is ticked and the checkbox is disabled :(

  • Pavel_Penkava
    Pavel_Penkava Posts: 2 ✭✭
    Options

    I have the same concern - TeamViewer starts maximized each time the computer reboots. It is pretty annoying and makes me wanting to disable the "Start TeamViewer with Windows" :(

  • Micha13
    Micha13 Posts: 1
    Options

    We have the same problem on all of our devices with the full client, the host is working fine and starts minimized to the tray:


    Please fix it, our users are already complaining.

  • Stephan_Ehret
    Stephan_Ehret Posts: 3 ✭✭
    Options

    I'm running 15.21.8 and I also have this very annoying problem.

    One interesting detail: this problem started as TeamViewer was installed using Intune / PatchMyPC. Before, wenn I was installing / updating the software myself, I'd never had it...

  • Zahne
    Zahne Posts: 1
    Options

    Hi,

    I was able to fix this for myself, by keeping the 'Start TeamViewer with Windows' checked in the TV app, while disabling TeamViewer in the Startup Apps setting.

    Search 'Startup Apps' to find this setting.


  • JeanK
    JeanK Posts: 6,993 Community Manager 🌍
    Options

    Thank you so much, @Zahne, for sharing your solution! 🙏

    Community Manager

  • dioshy
    dioshy Posts: 9 ✭✭
    Options

    Hello... Same issue here. None of the above solutions have worked for me.

    The app doesn't show up in the Startup of Windows, the checkbox for "Close to tray menu" is checked but grayed out. I have uninstalled and reinstalled the app 4 times; no luck. I am running version 15.36.8 (64 bit).

  • mdca1960
    mdca1960 Posts: 1
    Options

    Hi, same issue on my Win 11 computer. None of the above solutions worked. I have version 15.37.3 (64 bits)

    This is very frustrating. How come the solutions don't work on some systems?

  • GiuseppeCioce
    Options

    Hello, 2023 here ver. 15.45.3, but this problem is still here. I don't have option for the try... For me the issue started after the new UI. Please, is really annoing...


  • kqmaverick
    kqmaverick Posts: 2 ✭✭
    Options

    Same just started to have teamviewer open full screen on PC login. Also seems to be preventing sleep which I really don't like.

  • Freitas229
    Freitas229 Posts: 1
    Answer ✓
    Options

    Hello everyone I managed to fixed buy uninstall the new version, and downgraded to the old version 11 https://www.teamviewer.com/en/download/previous-versions/previous-version-11x/

    and then I updated using the software not downloading the new version from the Internet.

    And now is working fine.

  • Frabinstein
    Frabinstein Posts: 3 ✭✭
    edited September 2023 Answer ✓
    Options

    I was able to fix this by editing the following registry entry:

    [HKEY_CURRENT_USER\SOFTWARE\TeamViewer]

    "MainWindowMaximized"=dword:00000000

    It had a value of "1" assigned. I switched it to "0".