link icon
Ask The Community

teamviewer 12 lost license(1x business) after upgrade to teamviewer 13 beta

Hi, ALL!


teamviewer 12 lost license(1x business) after upgrade to teamviewer 13 beta. now it says, that its "free" and trial period was ended.

reinstall TW12 did not help.

Support keep silence.




  • Reyhan
    Reyhan Posts: 270 Staff member 🤠

    Hi @AlexandrRU

    Thank you for your post. Which version have you bought? 

    If you start a trial for version 13 beta, this notification is right. TeamViewer 13 beta is free for all users, so please try all the new functions if you like. :smileyhappy:

    Otherwise I would ask you to exit TeamViewer 13 beta and for deinstallation. To use your license, please download TeamViewer 12 on our webside here

    Your license should be automatically recognized on this device.

    Please note:

    If you bought a license for version 13 you need a TeamViewer account to use your business license. Please follow this article for further information.

    Best regards.



    Did my reply answer your question? Please accept it as a solution to help others, Thanks.
  • Thanks for the reply! I had purchased a license TV 12 business. I used it about a half-year. When the notice of 13 version I paid extra for the upgrade. Programm was updated to beta 13... and several days later wrote that the trial period has expired.  I have the account already. I can log on, see my contact list, but can't connect. In the top right corner there is the inscription "Free". The removal of 13 version and install 12 version did not help. If I do check the license on the page I see the following: Your current products are: 1x TeamViewer 13 Business. By the way, after paying the upgrade to 13 version, I did not come in the mail any supporting letters. That is strange.

  • Problem solved - Teamviewer's support did connect to my computer and enter new license number manualy. Then re-send email with new invoice (incl. new TV13 license number) to me.

    Thank you!

  • My six month old license to TeamViewer 12 appears to be useless since I was forced to upgrade to TeamViewer 13..  $849 down the drain.  Apparently I have to spend even more money to actually be able to use TeamViewer 13 which is apparently the only version that will connect me to my clients?

    I really need to talk to a tech because my whole account appears to have been trashed with the update.


  • Jonathan
    Jonathan Posts: 242 [Former Staff]

    Hi @eisinc,

    Thanks for your message!

    I am glad to hear that you were able to reach our support center and get help with your licensing questions.

    If you have a moment, maybe you can update with how your question was resolved.

    All the best,


  • Uninstalling TeamViewer 13 and redownloading / installing TeamViewer 12 appears to have solved my licensing issue.  Also, tested the quick connect and that should actually be easier to use on new client machines.

    Thanks again.