teamviewer.com link icon
or
Ask The Community

Mouse pointer trail on Windows 10 when using Teamviewer

Hi,

I am using teamviewer 12 to connect to a Windows 10 PC. Everytime I connect I see a mouse trail. I checked the pointer trials mouse setting, and it is unchecked. Has anyone else seen this behaviour?

I did sort of seen that when my both my remote monitors are on, I sometimes don't see the pointer trail. Please help!

 

Regards,

Van

Comments

  • Bigboss
    Bigboss Posts: 1
    Having exactly the same. Both pc with win 10.
  • Yeah, I'm experiencing the same problem as well. I recently set up Teamviewer 12 on a HP 8470p notebook with Windows 10 Pro and it's doing this as well. It's odd however that my desktop PC and another laptop with Windows 10 don't have the same issue. It's only on this particular machine/model. I've used Teamviewer on numerous other computers running Windows 10 and they haven't had the same problem so there must be something on this particular model/machine that is causing it.

  • mcfarlak
    mcfarlak Posts: 1

    I noticed the problem after the update to version 12.0.78716

  • greekgeek66
    greekgeek66 Posts: 4 ✭✭

    Mine just started yesterday! 

    I didn't even know it was called a trail, it just looks like 2 mouse pointers on my screen.  One following the other.  I am using version 12.0.83369 on my laptop running Windows 10.

    See here for demo:  [link removed]


  • same here. I'm using teamviewer through chrome though

  • JPB
    JPB Posts: 2

    I also am seeing the double mouse pointers when connecting from my Dell desktop to my Dell XPS 15 laptop. However, I discovered that this only happens when the laptop screen is closed. This is a repeatable scenario; screen (cover) closed = double mouse pointer (not really trails), open screen = problem solved. I am running TeamViewer 12.0.88438 and Windows 10 ver 1709 (FallCreatorsUpdate) on both devices. Hope this helps someone.

  • greekgeek66
    greekgeek66 Posts: 4 ✭✭

    You're right!  Just tested it now.  Laptop lid closed = trail.  Laptop lid open = no trail.


  • @JPB wrote:

    I also am seeing the double mouse pointers when connecting from my Dell desktop to my Dell XPS 15 laptop. However, I discovered that this only happens when the laptop screen is closed. This is a repeatable scenario; screen (cover) closed = double mouse pointer (not really trails), open screen = problem solved. I am running TeamViewer 12.0.88438 and Windows 10 ver 1709 (FallCreatorsUpdate) on both devices. Hope this helps someone.


    So, omg, yes, this is what it was. Excellent find JPB!! The laptop that I am having this problem on is one that is on all the time, running a few gaming server clients and I keep the lid of it closed and use Teamviewer to remote to it when needed. Ran that check on it and can confirm that when the lid is closed and you remote into it, there is the dual cursor, but when the lid of the notebook is open, it works fine with a single cursor in the remote session.

    Again, great find and thanks for posting in this thread!!

  • has anyone found a solution.  For me it's happening on a Dell e6430.  Lid up works, lid down mouse trails.

  • I have tested on confirmed this issue with your post. This is exactly how it is happening on my laptop as well (Acer Predator). Not a terrible issue but a little annoying at times. Great find!

  • coatsy35
    coatsy35 Posts: 1

    Have we got a fix for this yet? It's incredibly annoying.

  • BrGomes
    BrGomes Posts: 1
    Yaeh .... it is exactly what my problem is... Need solve this.. Please anyome fixed this ?
  • Scotty
    Scotty Posts: 494 Staff

    Hi Everyone.

    Are you guys sure this is a mouse trail?

    It sounds more like you can simply see the remote cursor. Your Computer has a cursor and the remote side also has a cursor. Normally, the software hides the remote cursor (unless selected otherwise - this is in the options under "View".)

    However if the remote screen is off, we are not always able to make the mouse transparent in this case.

    -Scotty

    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • Scotty,

    The post title is misleading, yes, it is a dual cursor as opposed to an actual mouse trail. It does appear to be acting as you describe. I can confirm that if the target machine is a laptop, but has the display closed, and the machine set not to go to sleep, the remote cursor trails behind the controlling cursor.

  • mrtnhrtn
    mrtnhrtn Posts: 2

    For me, the mouse "trail" leaves artifacts across the screen permanently. Refreshing doesn't get rid of it. Changing the screen resolution does. 

    Changing the remote cursor on/off has no effect. 

    Capture.JPG

     Like the rest of the commentors, opening the lid fixes my issue. Something I noticed was that you can't install the black screen driver with the lid shut, you can with it open. Presume windows 10 disables the device, mayb thats related. 

  • mrtnhrtn
    mrtnhrtn Posts: 2

    .

  • Dav
    Dav Posts: 1

    @Scotty wrote:

    Hi Everyone.

    Are you guys sure this is a mouse trail?

    It sounds more like you can simply see the remote cursor. Your Computer has a cursor and the remote side also has a cursor. Normally, the software hides the remote cursor (unless selected otherwise - this is in the options under "View".)

    However if the remote screen is off, we are not always able to make the mouse transparent in this case.

    -Scotty


    Are you referring to TeamViewer when you say 'View' or Windows.

    I have this problem when accessing a Desktop PC (not a Laptop)

    More detailed instructions on how/where (including whether remote of host Computer) to fix this would be useful for us 'non techies.'

  • Maruco
    Maruco Posts: 5

    It's related to the display driver. As weird as it sounds, you should uninstall/disable it.

    On systems that do not have monitors physically connected to the machine Teamviewer lags horribly and is slow. Also, mouse pointer trails can be shown. Laptops are the same since closing the lid basically disconnects the display.

    Uninstalling/disabling the display driver (or connecting monitor to a desktop computer) fixes the problem. I believe just leaving the default Microsoft display driver fixes the issue without the AMD, NVIDIA, INTEL drivers installed.

    https://www.laptopmag.com/articles/disable-automatic-driver-downloads-on-windows-10

    Cheers!

  • These options won't work for me, unfortunately.  [Removed by Moderator per Community Guidelines] is working fine, however, so I have found an alternative solution.

    Thanks, your feedback may help others with this problem.

  • Found on another site, worked perfectly.

    As a workaround, for computer with Windows 10, create the registry key “DisableDuplicationAPI” as REG_DWORD and assign value 1 under registry entry
    HKEY_LOCAL_MACHINE->SOFTWARE->WOW6432NODE->TEAMVIEWER 
    Restart of the TeamViewer service (or restart the computer). 

  • Maruco
    Maruco Posts: 5
    this works, thnx bro!
  • I'm new to Team Viewer; using a mac mini as a server for my electronic medical record.  Began having the "trail" to the point where I couldn't use Team Viewer.  Tried plugging the LCD into the mac and it disappeared!!!!

     

    December 18, 2018

  • penchun
    penchun Posts: 2

    I updated my vga driver, fixed this problem.

  • penchun
    penchun Posts: 2

    When I login again, the problem happen again. I found a tricky way to fix it: Disable VGA driver then enable it again.

  • bsalita
    bsalita Posts: 1

    Works fine but beware of copy paste error with the quotes. Make sure they're ascii quotes, not html. I made a .REG file with the following contents.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\TeamViewer]
    "DisableDuplicationAPI"=dword:00000001
Sign In or Register to comment.