link icon
Ask The Community

Can't get remote access to computer using VPN.

So I just set up Team Viewer mainly for accessing my desktop  PC's files remotely.  I'm going on a trip and would like to access files if I need to.   I setup everything correctly (So it seems) and I connected to the VPN from my Win10 laptop.  The VPN connected and I clicked "Share files via Explorer".  After some seconds, an Explorer window opened and I could see my desktop PC in the list of computers. I could go through the folders with no problem.  I disconnected and I have not been able to access the computer since.  Now when I click "Share files via Explorer" the Explorer window takes me directly to the My Documents folder on the laptop (The computer Im using, not the one Im connected to). VPN connects with no problem. Remote desktop and wake on lan works perfectly.  Ive tried changing sharing features on Win10. I even turned off the firewall to see if that helps. I had a network drive setup on the laptop for the drive on the desktop and deleted that thinking there maybe some sort of conflict. Nothing. Hopefully someone has a solution.


Surface Book 2 Win 10 (64-bit)

Custom built PC Win 10 (64-bit)


  • Giovanni
    Giovanni Posts: 49 Staff member 🤠

    Dear @bfletcher6147

    thank you for your inquiry.

    On your local Pc please go to "Network and Sharing center", then go to "Change adapted settings", right-click on the TeamViewer VPN adapter and select Properties.

    In the first tab de-select "Internet Protocol Version 6 (TCP/IPv6)" and then click on OK.

    Once done that try again the VPN, tell me if it's working fine, thanks.


    Senior Enterprise Solutions Engineer

  • Thank you for responding. That option was already deselected. Still nothing.

  • Giovanni
    Giovanni Posts: 49 Staff member 🤠

    Hi @bfletcher6147

    did you already try to perform a full uninstall and reinstall of TeamViewer on the remote PC?

    After that reinstall the VPN drivers on the remote machine, disable IPv6 on the TeamViewer VPN on your local machine as explained and try again.

    Let me know,


    Senior Enterprise Solutions Engineer

  • Just to add... I had the same issue and removing the IPv6 protocol from the VPN adapter did the job! Thanks
  • FWIW, none of those suggestions worked for me. The base problem is that the TV VPN shows up as an unidentified network and Windows 10 classifies unidentified networks as public. On my systems, sharing is disabled for public networks and there is no way via the Windows gui to reclassify an unidentified network as private. The only solution for me has been to use PowerShell to manually reclassify the TV VPN every time I connect. PIA, but it works. My previous post on this with no responses to date

  • mikeshick
    mikeshick Posts: 6 ✭✭

    I've got the same problem.  Windows 10 source to Windows 7 target doesn't work for me.  Windows 7 source to windows 10 target (same two machines) works fine.  Can you please advise why?

    Same versions of TV on both.

  • tkutay
    tkutay Posts: 1

    I know this is a pretty old post, but I have been having this problem for some time and finally found a fix and wanted to share it here as well.  The problem was Windows cannot identify the Teamviewer network and unidentified networks are automatically set as public.  This disables file sharing and I cannot access my computer through Teamviewer VPN.  The solution suggested here fixed the problem for me:

    Hope this helps somebody.

  • martincg
    martincg Posts: 1

    Every now and then, the VPN icon vanishes. If i use TV to connect to the remote PC then I find that the File option to connect usig VPN is disabled.

    For me, I have always been able to fix this by -

    • Close TV
    • Use Task Manager to close all instances of Teamviewer. The last time I did this there were about 5 instances running.
    • When you are sure you have killed all the Teamviewer programs then start TV again and the problem has probably been fixed.
Sign In or Register to comment.