Num Lock Issue

I have one remote computer that the Num-Lock function works opposite to the controller's keyboard. Example: If I want to use the 10-Key pad in the remote session I have to turn off Num-Lock on my PC.

This is only happening with one remote. How can I change this behavior?




  • Chiron
    Chiron Posts: 229 ✭✭

    I have this problem all the time.

    Not just with TeamViewer. Any remote session (Hyper-V,  Remote Desktop, vSphere) my num lock is constantly toggling.

    I don't work for TeamViewer. I'm just a user.
  • not usually an issue with other remote software for me - just TeamViewer

  • MDC
    MDC Posts: 11

    Have had that problem for a long time, but recently discovered if I immediately disconnect my TV connection then reconnect it again the problem goes away.   I have no idea why this works, but it has worked repeatedly now for several days.  Here is additional detail.

    I now follow a simple and fairly quick procedure.  First, I connect to my remote.  Second, I open Command Prompt to see if it will accept numbers from my 10-key pad.  ( I always have the num lock on at my computer)  Third, if it will not accept my numbers I immediately disconnect by closing TV.  Fourth, I reconnect immediately using TV (and usually I have to sign in again with the remote user ID and Password)   Fifth, I try to input numbers into Command Prompt again and it seems to always work.  Sixth, I just start doing my work without ever even touching my Num Lock key.

    If it works with Command Prompt it will always seem to work with the Quick Books sign on box and other input fields in QB that I am using at the remote computer.

      The odd thing is if even a few minutes have passed since using the connection if I need to connect again the same issue happens as if there clock watching to start the issue again..  The good news is that it can be fixed quickly using the steps I have outlined above. 

      Hope this works for everyone who tries it.  Note:  Both computers are Windows 10 using the same latest version of TV.


  • MDC
    MDC Posts: 11

    See my "solution" in my post a few minute earlier on this topid.

  • Fratotec
    Fratotec Posts: 2 ✭✭

    I´m using this from Virtual Box, works fine for me:

    In Regedit, 

    HKEY_USERS\.DEFAULT\Control Panel\Keyboard

    change the "InitialKeyboardIndicators" from the default number ending in 48 to 50

    The forums doen´t let me post the complete numbers, they are identifided as Teamviewer IDs. :(

  • I just recently had this problem occur.  I closed the connection with the remote computer and immediately reconnected and the problem was resolved.  Give it a shot !

  • Most of the TeamViewer user's have reported this issue of num- lock key toggling, you could try to disconnect and reconnect your system and see if the problem is resolved or not.

  • Tolqua
    Tolqua Posts: 3

    I've been having this issue recently, but only from one remote machine.

    Kudos to MDC for noticing that the immediate sign out/in does, indeed, correct the erroneous Num Lock status on the remote machine.  

    Unfortunately, whilst it lasts for multiple sessions (subsequent sign out/in does not toggle the Num Lock again), the 'fix' only lasts up until the remote machine is restarted.  So it's great if you're regularly signing into a machine that's left running, but if, like me, you power down your remote machine after the day's session (it's started automatically each weekday morning), then this isn't really much use.  If I have to remember to do the 'fix' at the start of each day's session, then I can remember to press the Num Lock key when I disconnect at the end of a day's session and correct the situation on my local machine with just one key-stroke.  The only real advantage to MDC's fix is I'm switching between local and remote machines during a session.  This does happen, so I may end up adopting this way of working anyway, but wouldn't it be if TV was able to take care of this so we din't have the situation in the first place? 


  • I have this problem randomly. If I open multiple sessions to different clients, some have the problem and some do not.

    Reading other messages from the community I tried to close and reopen the session and the problem is solved but it happens very often and it is unthinkable to have to close and reopen a session dozens of times a day.

    Since I am paying for a service I expect the problem to be resolved, I have been using TV since version 6 and have never had this problem.

    I have had the problem for several months now and it is now becoming really frustrating.

  • I've had this problem since I can remember and it's still an issue in late 2020.

    I think what's happening is that when you connect to a session, the num lock defaults to an off state regarless of the status of your local PC. So you have to hit the num lock button to turn it on in the remote session meaning you'll turn it off locally.

    I've tested this: I turn num lock off locally prior to connecting to a Teamviewer session. After connecting I hit the num lock button it's turned on for both locally and the remote session.

    So it will be really nice if Teamviewer can see the real num lock state of the local PC and match it in the remote session. Rather than defaulting it to off when connecting.





  • Thanks pepesci for emphasising the significance of this ludicrous bug. 

    As you say it’s absolutely infuiriating to have to work with this issue.  There’s no doubt that it’s a fault and it can’t be argued that this behaviour is ‘by design’.  It’s been present for years and has been reported numerous times by many different users. 

    The ‘workarounds’ are interesting and give some extra detail as to the way this bug behaves, but they aren’t really much help and the point is it shouldn’t be happening.  TeamViewer is one of the most popular and mature remote control solutions so having such a glaring and intrusive bug still present after so many years is truly scandalous. 

    The only reson the fault persists is because nobody has taken them to task over it and pushed for a resolution.  I can’t do this because I’m not a paying customer, but you are so why don’t you raise a ticket and escalate it until it gets resolved?  If necessary, submit a formal complaint. 

  • Thanks Cougie, for noticing that TV is ignoring the Num-Lock state of both source and target machines, but it’s worse that that; it defaults to the ‘off’ state.  Who ever even uses a keyboard in this state?  I only ever have to hit that key to switch it back on when some other process has swithced it off (Chiron commented that other sessions such as Hyper-V, also disable Num-Lock).  So TV doesn’t need to be aware of the Num-Lock on either end – it just needs to leave it as it is!

    It’s all very well saying how ‘nice’ it would be if TeamViewer fixed it, but as I mentioned in my reply to pepesci, it needs someone who’s a paying subscriber to raise this issue, escalate it and, if necessary submit a complaint to get the matter resolved.

  • Thanks @Tolqua,

    just opened a ticket, and now waiting...

  • roykgraves
    roykgraves Posts: 3 ✭✭
    edited March 2021

    A good solution is found at Num Lock — TeamViewer Support which suggest using the Ctrl-Win-O shortcut to bring up the virtual keypad and turn off the Num Lock on the host PC which solved this problem for me. Good luck.