teamviewer.com link icon
or
Ask The Community

TeamViewer 14 mac on El Capitan???

TeamViewer 14 does not work on mac os El Capitan?? can't start. constantly crashes.

Best Answer

«1

Answers

  • pipo-unix
    pipo-unix Posts: 2 ✭✭
    edited November 2021
    [removed per Community Guidelines
  • Esther
    Esther Posts: 4,110 Former Community Manager

    Hi @MYST2002

    Thanks for the feedback.

    We are looking into this.

    Best, Esther

    Former Community Manager

  • Same issue for me too.
    TW Beta 14 won't open and crash continously on iMac (20' early 09) and Macbook Pro (15' mid 2009) both with El Capitan v10.11.6
    V13 works perfectly, instead.
    Tried to uninstall, wipe cache with CCleaner (or similar) and reinstall but I had always same issue.
    I reinstalled the old version.

    P.S. Win version (on other PC) works fine.

  • pipo-unix
    pipo-unix Posts: 2 ✭✭
    the problem is that if your client friend the second team if you want to have teamviewer 14 you can not connect from 13 and you are not going to change the version to a group of clients just because your computer does not work in **Third Party Product** this does not happen
  • DAVELUTE
    DAVELUTE Posts: 6 ✭✭

    STILL NO SOLUTION?....

    TV 14 on El Capitan crashes constantly.. And from another computer with TV 14  i can not remote control my imac with the old TV13 (which is the only version still working on Capitan.

     

    This is not good at all!

    Switching to **Third Party Product**® now, Cause those versions work well in cross-over environments old and new macs with different OS en all **Third Party Product** versions.

  • SOLVED!!:smileylol:

    - Remove TV13 with AppCleaner. 

    - Restart mac

    - Download TV14

    - Install

    ------------

    it works!!!

  • DAVELUTE
    DAVELUTE Posts: 6 ✭✭
    edited November 2021

    I would guess your solution should work. I know.

     But No. I have run appcleaner and deleted all files. and even looked in library/prefs etc. manually to delete everything.
    Restarted several times and made a clean install with the TV 14  dmg.

    The app keeps crashing right away after installation and keeps crashing every 2 seconds.

    It's pure horror for me now.




    [removed per Community Guidelines]

  • DAVELUTE
    DAVELUTE Posts: 6 ✭✭

    I would guess your solution should work.

     But Not for me.
    I have run appcleaners and deleted all files. and even looked in library/prefs etc. manually to delete everything.
    Restarted several times and made a clean install with the TV 14  dmg.

    The app keeps crashing right away after installation and keeps crashing every 2 seconds.
    It's pure horror for me now.

  • I have the same problem
  • Same here... Would appreciate a solution for a clean install that removes whatever file(s) cause this problem

  • use appcleaner. its free. (The URL link has been removed by a moderator)

  • NO TV13 on my machine V14 does not work
  • DAVELUTE
    DAVELUTE Posts: 6 ✭✭

    I just downgraded to TeamViewer 13  on all computers again.

    TV14 does not work on El Capitan and lower, and is not compatible with TV 14 or vice versa.

    So no more tv14 for me.

  • Об этом Mac 2018-12-16 14-06-09.png

  • DAVELUTE
    DAVELUTE Posts: 6 ✭✭

    Well, really nice it works for you. But for the rest of el capitan users it does not..

  • Same over here!  Unabable to get TV 14.1.3399 working onmy iMac with El Capitan 10.11.6

    Have try and buy App Cleaner & Unninstaller, no succes... Then buy the PRO of App Cleaner and same result  :(

  • Same problem here. TV 14 crashes instantly upon attempting to launch on El Capitan.

    I downloaded today's version (14.1.3399) since there was some release notes from a couple of days ago but still same problem.

    I manually deleted previous version (including Library files) but it didn't help.

    I get the dreaded error message EXC_BAD_INSTRUCTION (SIGILL)

  • Dear Esther,

    Thanks for your support! This version works at my as you classified, rather old hardware. I have had this problem on my Mac Pro 2,1. Now, this 14.1.5819 version works flawlessly.

    I suppose, you will include this patch also in the next upcoming releases.

     

    I was able to log in, connect to my family's TeamViewers running version 14.

     

    Shall I check/test anything else for you?

     

    Please, keep up the good work,

    Thanks for your support,

    Sincerely,

    Balázs

  • Esther
    Esther Posts: 4,110 Former Community Manager

    Hi @LordBBK

    Thanks for your feedback! It is great to hear that the version fixed the issue for you!

    I informed the devs immediately about it to share the good news, and they are looking forward to receiving some more feedback from the others.

    Thanks again and happy holidays,

    Esther

    Former Community Manager

  • Hi everyone.

    It's work for me!!

    I have an IMAC middle 2007 (core2 4GB) with El Capitan 10.11.6

    I reinstalled MAC OSX (erasing every things), I installed TV 14.0.13880 and doesn't work. After that, I reinstalled  the Tv from de LINK (without remove previously), an every things work fine.

    Thanks!!

    Regards

  • Hi Esther,

    Thank you very much. Considering the other responses in this thread, I think this might solve my problem as well. The iMac I am using is also a 2007 model, so very old (though still functioning very well).

    I will try this solution over the christmas holidays and report back to you if it fixed the issue.

    regards,

    Hein

  • Esther
    Esther Posts: 4,110 Former Community Manager

    @Ivan_Leon Thanks for your feedback! I am glad to hear that the version works for you as well :-) Enjoy it!

    @HeinAmersfoort Yes - from the feedback we got the chances are looking good that the version will solve the issue on your mac as well. We are looking forward to receiving your feedback after your tests.

    All the best, Esther

    Former Community Manager

  • Confirmed this version now works for me as well running El Capitan 10.11.6

  • Hello Esther,

    I confirm this fix of TeamViewer 14.1.5819 worked on my iMac (mid 2007) running Mac OS X El Capitan 10.11.6

    Thank you for supporting older hardware!

  • DAVELUTE
    DAVELUTE Posts: 6 ✭✭

    Works well. On 2007 imac with El Capitan.
    Thank you so very much!  

    Schermafbeelding 2018-12-23 om 14.10.15.png

  • Hi Esther,

    The new build (14.1.5819) definitely works for me!

    Teamviewer is now up and running smoothly on my old iMac (20-inch, mid 2007), running on El Capitan (10.11.6).

    Thanks very much! Great that you support older machines like this - after all it is still working fine for me :-)

    Regards, Hein

  • Esther
    Esther Posts: 4,110 Former Community Manager

    Hi @GodzFire @zefhar @DAVELUTE @HeinAmersfoort

    Happy New Year!

    Thanks a lot for testing and confirming that the fixed version is working well and solving the issues you described before. This means a lot to us :-) I honestly love this teamwork. 

    I hope we can release the fixed version asap to everyone.

    All the best and enjoy working with TeamViewer :-)

    Esther

     

    Former Community Manager

  • @Esther wrote:

    Hi all,

    Thanks for all your reports and help in identifying this issue.

    Our developers created a fix for it and we would need your help to test it. It would be great if you could download the fixed version from this link and test whether it solves the issue for you.

    We would appreciate your feedback so that we can publish the version as soon as possible to everyone.

    One of our findings is, that the issue appears on old hardware. Can you confirm?

    Thanks, and we are looking forward to your feedback,

    Esther



    The test version provided in the link worked!  Just to be safe, I removed all remnants of TeamViewer on my system using AppCleaner, rebooted then installed the test version and it worked.

  • This fixed the issue. Thank you