teamviewer.com link icon
or
Ask The Community

14.1.3399 UI not working in Ubuntu 14.04

Since the new version came out, my TV ist not working anymore. It is running, but I'm unable to open the GUI. I already did a complete reinstall, but nothing changed.

Here is the full log: [log removed]



 

[10:45 [email protected] dellwing] > teamviewer daemon status

initctl status teamviewerd
teamviewerd start/running, process 19675 

 

I do think the main issue is this one?

GX0!! QML load error: qrc:/ui/MainWindow/MainWindowFull.qml:1:1: a component declaration requires two or three arguments, but 1 were provided, Errorcode=11

 

Comments

  • Me Too: Just wanted to say that v13.2 still works for me.

    (I would like to add that I HATE having to do Captcha and TFA (I use VPN so OMG new device) just to log onto a discussion forum.)

  • I also downgraded to TV13, but that sadly means I cannot connect to any of my other devices, because they are running TV14.

  • Yes. It was easy for me because I only use TV on two devices, so I downgraded both. All I do is remote desktop with my laptop from the couch to the HTPC across the room. Having spent the afternoon hassling with 14.1 breaking on one computer, I can't imagine why I would ever want to upgrade.

  • Do you have qt5 on your machine ? try 'ls /usr/share/ | grep qt' from your filesystem root. If you only have qt4 or older, you may be stuck on versions older than 14.1...

    14.0.14470 works for me. I am on Mint 17.3, which I believe is based on Ubuntu 14.04. I did::

    apt install teamviewer=14.0.14470

    then

    sudo teamviewer repo disable

    and now I have a working tv14 installation...

    JT:

  • Pretty much same here on Debian 8. Downgrading to previoius v14 does make the GUI work again ....

    $ sudo apt-get install teamviewer=14.0.14470

  • Thank you for that code snippet. I actually had a scrolling issue with v13 but I couldn't find an install file for the earlier v14.

  • I upgraded my OS and had to reinstall. That version is no longer available. Nice.

     

  • >> That version is no longer available. Nice.

    Which version are you talking about ? 14.0.14470 or 13.something ?

    Apparently 14.0.14470 was available very recently, and works on Ubuntu 14.04. More to the point, it does not appear to depend on QT5. I only have QT4 and it is working for me. Did you try the command line option described by berni42 ?

    $ sudo apt-get install teamviewer=14.0.14470

     
  • Yes. I was able to get v14 a few days ago but not today.

  • You probably do not have the .list file anymore. Add it again and you should by able to run the command.
  • Yeah, tried that. Before TV installed the command did not recognize "teamviewer". I installed v13 and then it said v14.0.14470 was not found

  • Edit the file /etc/apt/sources.list.d/teamviewer.list and change the tv13 in it to tv14 :)

    (In the file is also a readme)
  • Thanks. I'm not having the scrolling issue with v13 and the new OS, so I'm standing pat.  If it breaks again I'll try that.

  • TV-Rene
    TV-Rene Posts: 30

    Hello everyone,

    please beware that Ubuntu 14.04 is not supported for TV14. The last supported version for that version of Ubuntu is TV13.

    For more information please see here: https://community.teamviewer.com/t5/Knowledge-Base/Which-operating-systems-are-supported/ta-p/24141

    Regards,

    Rene

    Rene - 2nd Level Support
  • No one wants TV13, it's ugly. You provided `qt56-teamviewer` to us, to run TV14 if `libqt5core5a` is below 5.6 and it works perfectly fine with 14.0. It stopped working with 14.1 without a notice.

    Would have been fine with this if it didn't break down on an auto update. I have currently locked the installed version and have no further problems.

  • Rene, excelent!! Thanks to you we can solve the problem knowing what to do: for example, to install a vm whith a supported operating system.

  • Rene, excelent!! Thanks to you we can solve the problem knowing what to do: for example, to install a vm whith a supported operating system.

  • It's true, 14.1.3399 UI not working in Ubuntu 14.04, but v14.0.14470 does work, and works quite well. Granted some people have reported suffering crashes, but I presume this to be the app, not the system. I have v14.0.14470 working very nicely, and have not suffered any misbehaviour.

    PLEASE can you make v14.0.14470 available again for those of us either unable or unwilling to upgrade to newer versions.

    Linux Mint 17.3 (based un Ubuntu 14.04) on Intel core2quad with 8gb ram and an old radeon graphics card.

  • Nman
    Nman Posts: 1
    Do you know how i can get the 14.0.14470 version that one that you say works?
  • TV-Rene
    TV-Rene Posts: 30

    Hello everyone,

    apologies about the delay, but I am able to make the 14.0.14470 available to you.

    Please follow this link to find the matching files.

    Best regards,

    Rene

    Rene - 2nd Level Support
  • Thank you, I already have 14.0.14470 on my desktop (mint 17.3), but I will take a copy of the files I need in case I need to re-install tv before I can upgrade to a newer version of mint.

    I am curious to know if anyone of the other people reporting problems with 14.1.3399 have taken advantage of these files.

    JT:

  • I simply did:

    teamviewer repo main
    apt upgrade
    apt install teamviewer=14.0.14470
    apt-mark hold teamviewer
  • Thank you, berni42, this worked for me. 14.1.9025 was not working, and is 14.0.14470 working now.

  • I found by deleting this file everything worked fine for me, I am using Linux Mint 19.1

    ~/.config/teamviewer/client.confi

    Once I deleted ths file everything worked fine. I did exit Teamvewer and restart.

     

  • JohnTrav
    JohnTrav Posts: 13

    If, as you say, you are running Mint 19.1 then you are on Ubuntu 18.04 codebase, not 14.04, so TV14.1.3399 (and later) should run without problems.

    This topic was raised to discuss the problems people on Ubuntu 14.04 (or Mint 17.*) suffered when TV14.1.* came out. TV13 still worked, but would not talk to a TV14 instance, TV14.0 worked well for most people, but people running the older Linux versions could not get 14.1.* working. The current version appears to be 14.2.2558.

  • Is the current version working OK? I have been using 13.2 since these issues came up. It freezes about 1 of 4 times I use it. I'm now at Mint 19.1

  • Janis2
    Janis2 Posts: 3

    14.6 is working fine for me on Linux Mint 19.1.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

This Week's Leaders