Can't install Add-On: Samsung



  • Hacker26
    Hacker26 Posts: 8 ✭✭
    Excellent!! How did you get this modified APK file?!
  • Mellie_d1
    Mellie_d1 Posts: 2

    the link doesn't work

  • Hacker26
    Hacker26 Posts: 8 ✭✭
    edited May 2022

    [Expired link removed per Community Guidelines]

  • strangel
    strangel Posts: 1

    I have tried it and so far it works well :)

    It seems to not play well when minimized (i mean, it IS the Host app, it should work all the time) but I will continue playing with it, maybe it is my fault.

    I have a Samsung Galaxy S10+, Android 9, by the way.

  • I'm attempting to install and configure QuickSupport on the first of a few work phones - Samsung Galaxy A70 - but the mandatory QuickSupport Add-on refuses to install after download - rendering remote support on the phone impossible.

    What's the solution here?

  • ashdroid
    ashdroid Posts: 8

    Is there any indication of when this add-on is likely to be published to the Play Store?  We are currently unable to supersede our existing installation as that the beta version shares the same version code 3086.

  • Hacker26
    Hacker26 Posts: 8 ✭✭

    It's a general problem with Android 9 on samsung and the update is not yet published on playstore. Click here in order to download the updated apk that works with Samsung android 9. Enjoy!

  • timrsfo
    timrsfo Posts: 5

    New to Teamviewer and just got my S10 yesterday.

    What needs to be installed on the phone prior to this apk?
    How are you suggesting the install of this add-on apk?

    I downloaded apk to my linux box and attempted to load it via appium, but it fails

    BTW: My pc is running linux Ubuntu 16.04 with TeamViewer: 14.2.8352, FREE

  • timrsfo
    timrsfo Posts: 5

    Ok, I downloaded apk from url above. 
    Then clicked on it and allowed install 
    If I goto downloads and attempt to install it again, says already installed
    However, when I open TeamViewer it still says I need to install Quicksupport to allow Remote Control. This seems like a catch 22, what is the correst order of operation?

  • timrsfo
    timrsfo Posts: 5

    I have TeamViewer, QuickSupport and the addon from url installed on my phone
    I have TeamViewer installed on my Linux Box

    Start QuickSupport on the phone, and TeamViewer on the Linux Box
    insert the ID from the phone on the TeamViewer Partner ID
    Remote Control selected

    Select Connect,  Authenticating ...
    On the Phone: Allow remote Support: Allow
    Teamviewer indicates Authentication Accepted
    Phone spins  for a while ...
    Both go back to original screen
    Ready to connect(secure connection) displayed on both

    Tried the same installs on my old S4, same result. Does this work on linux?

  • timrsfo
    timrsfo Posts: 5

    Appears to be a linux issue: 
    I downloaded/installed Teamviewer on an old Win7 box and it works for both of my devices
    S4 & S10

    Are you aware of the Linux issue and is there a work-around?

  • I cannot install on my Samsung Note 9, just fails with Can't install Add-On: Samsing

  • JonGa
    JonGa Posts: 7

    Can you upload the apk again? the link is broken.

    I am configuring 700 new Samsung mobile and I need it!! Thank you!

  • JonGa
    JonGa Posts: 7

    can you upload the apk please?

  • Hacker26
    Hacker26 Posts: 8 ✭✭
    edited May 2022

    [removed per Community Guidelines]

  • JonGa
    JonGa Posts: 7

    The link is broken, can you upload to other site?

  • Hacker26
    Hacker26 Posts: 8 ✭✭
    edited May 2022

    [removed per Community Guidelines]

  • JonGa
    JonGa Posts: 7

    I have tried it several times... i cant download it, can you upload to other site? google drive, mega, etc


  • JonGa
    JonGa Posts: 7

    Thanks Julia!!

  • Can confirm this works on my A70.

    you have to reinstall both the add-on AND the quicksupport app itself

  • copazo
    copazo Posts: 1

    Dear Julia, I have reviewed the version of the Add on of team viewer for samsung and it is the same version. When trying to connect to a device it tells me that the add-on is obsolete, since it is the latest version.

    I wait your answer.

    regards, Claudio

  • TungDH2
    TungDH2 Posts: 1

    I could not install Add on Samsung for Android 9 devices (SamSung tablet T295) 

    Anyone help me this case? :((( I really need for install it

  • ThaiNA3
    ThaiNA3 Posts: 1

    I have faced the same issue as not able to install Add on Samsung  with model of Samsung Tab A8 T295.

    Hopefully teamviewer technical team can help me solve it, I need to access this device for work.



  • I got a note 9 and I downloaded teamviewer host, teamviewer for remote support, and teamviewer quick support. None seem to work, stays forever on login for teamviewer host, quicksupport is forever on activating id?


    Can someone please reupload the beta versions that dont use knox? I really need to get teamviewer host working



  • i joined the telegram room, there are no apks and not available to chat, can you post the apks in there please for teamviewer host for note 9 that don't use knox?

  • Hi, it works on my S9+ and Tab S3.

    But I still can´t install the Addon on the Galaxy M20. Latest Team Viewer and QuickSupport are installed.

    The M20 is for my mother and it is important that I can do a remote maintenance there.

    Thanks in advance for help

  • Manolo
    Manolo Posts: 17 ✭✭
    @Viewer0815 can I ask?
    In your S9+ TeamViewer Host work fine?
    I can't connect from another device (Windows, Android...) because S9+ (Android 9.0, July Patch) go Offline after 10 sec. if I don't keep open TeamViewer Host App.
    Can your try for me please?

  • where is the mod links? someone please reupload the modified apk. since the addons still not work on android 9 on samsung tab A. it only support sharing and view only!! developer you should ashame to not fix this issue !!!

  • JackB
    JackB Posts: 2

    I'm having the same issue on a Samsung Galaxy Tablet A8. If any TeamViewer devs could get back to us on this that would be amazing.