Teamviewer is running an old version which is out of date / no connection anymore !!



  • keyreel
    keyreel Posts: 5
    Same here. They don't care until you pay. Otherwise enjoy your new computers (please!) Only
    That is a trend, unfortunately. I can't update my parents' Mac mini 2008, which is 6000 miles away from me.
    Cynically they have a button "learn how!" (To update). I love it! Also I like the reason for denied connection is Unknown ?
  • efect2000
    efect2000 Posts: 5

    I have updated to versions 10, 11, 12, as it works on a xp sp3 pc, and always says that the version is old, Why are availabñe to download and install, if they don't work? version 14 does not work on xp sp3.

  • Hy
  • turbomac
    turbomac Posts: 2

    Free version user here trying to connect on the same network from a MacPro to an iMac, both running the latest version of Mojave and Teamviewer (14.3.4730). Still, I get the "Version out-of-date" pop up message every time I try to connect plus another "Unable to connect, Reason unknown" message.

    I have read this entire thread and no one seems to mention any fix or update on their issue with Macs. I understand there is a widespread issue among Linux users not being able to update, but it would be helpful to know how is it working for other Mac users?

    I reallly appreaciate any help.

  • Fratotec
    Fratotec Posts: 2 ✭✭


    on the same network you should be able to connect to the TV IP address ( if incoming LAN connections are allowed in the settings ). As far as I realized from previous posts, this should work ... 

  • roony94
    roony94 Posts: 2

    Can t connect to my remote computer that is running version 12..... Please, we need a fix, so we can update our clients to version 14. Cant update teamviewer remotely :(

  • turbomac
    turbomac Posts: 2
    Thanks all for continuing the discussion. I want to give an update from my previous post and explain how I was able to connect my other computer on the same network NOT by initiating a connection through the Remote Control menu (entering the partner ID and then clicking on connect) BUT by first going into the Computers & Contact menu and assigning my other computer to my account. To do this, I had to
    1. enter my ID and password on my second computer,
    2. on the gear icon at top right corner click on assign to account.
    3. then from computer 1 I entetered the ID and password of computer 2 and was able to connect.

    You should NOTICE that there the ID numer starts with a 1 followed by 9 digits but this 1 is NOT part of the ID, which can be very confusing and I was able to find out after hours of trying to troubleshoot. Your ID should only be the last nine digits of your ID.

    Hope this helps.
  • chiara-m
    chiara-m Posts: 1

    HI, I have the same problem. I have two machines both running Team viewer 14 and I'm not able to have a connection. How can I solve?

  • roony94
    roony94 Posts: 2
    Its a shame the no one from the team provide a solution for this serious problem until now...
  • hhc
    hhc Posts: 4 ✭✭

    I am a paying customer, i have bought version 11 Premium, and i can tell you that they will not fixed anything because is not a "problem" for them, is a consequence from a commercial decision that they have made to get more money, that's all. A bad one in my opinion..

    They have changed the limitations on the Free Version, they do not let free users to connect to computers with older versions, if you do not have a license you can only can connect to a computer that has the last version.

    I have open a ticket with Teamviewer support and this was their answer:

    "It is not possible to use older version of TeamViewer without a license, if you connect to them using your version 11 license you will be able to do it, but if they don't have a license they are not going to be able to establish the connection"

    I am not guessing about the source of the inconvenience, what i really do not know is to whom they are aiming to get more money, the current customers?, the free customers? (they can download the free version and install it again, but... what will happend when they change to version 15 the next year?, all 14 version will be "older versions" and again the free customers will not be able to connect.

    I think they do not care about customer relationship anymore.

    Hope this help for the one that are waiting some fix that will never arrive

    Best regards


  • kokkeong
    kokkeong Posts: 1

    I am using TV 10 free version and previously I am still able to remote in other PCs but recently it show "remtoe teamviewer is running an old version which is out of date.Therefore you cannot connect to this version anymore".

    Any solution to this?

    And why the sudden error when previously both are running TV10 free version.


    Kok Keong



  • snjui
    snjui Posts: 1

    "Please make sure, that you are using the latest TeamViewer version if you are not a license holder. You may update the remote TeamViewer with a policy"

    - This information is misleading. You can not use teamviewer policy in a free version. I've started a 14 days Trial - but still can't apply a policy to older (ver. 12) hosts - they are appear offline from the teamviewer website. But they are online actually, and if I try to connect to them - "the remote version is running old" is displayed.
    So there is no option to remotely upgrade those (v.12) hosts, in any case you have to buy 1-year subscription at lease once, or move to another solution.

  • StephenD
    StephenD Posts: 6

    Well I'm still getting the TeamViewer nag that the remote TV version on my Android phone is out of date but now it will no longer connect to the phone ("reason unknown").

    It would appear that Host for Samsung no longer works and there is now no solution for devices running Android 4.1.2.  I hate it when systems that once worked perfectly become useless because because software companies make an arbitary decision to make it so. 


  • wroshon
    wroshon Posts: 6 ✭✭

    This is quite disturbing. I have a paid commerical PERPETUAL license for Teamview 12. I paid to upgrade to 12 from version 9. I and many other owners of version 12 chose not to go with the subscription license for version 13 and cannot legally upgrade to 13. Last week, everything worked fine. This week, I can't connect to anything. What has Teamviewer done to disable connections to older versions? This needs to be corrected immediately.

  • Yuri_T
    Yuri_T Posts: 2,256 [Former Staff]

    Hi @wroshon ,

    Thank you for your post.

    If you have a perpetual license for an older version, please make sure that you are using your license for these connections and if you still have problems, please contact our support team.

    All the best,

    Former Japanese Community Moderator
  • AlenaC
    AlenaC Posts: 918 Moderator

    Hi @roony94 ,

    have you tried to set up a policy in the management console?
    Please read: How to add a new settings policy 

    Hope this helps. Let me know if I can assist you with more information

    Best, Alena

    Spanish Community Moderator :)

  • khawk973
    khawk973 Posts: 1

    I'm running newest version on both pc's, v14.3.4730.  Am being told that I can't connect since the pc I'm connecting to is running an older version of TeamViewer.  Not sure how that's possible, but it refuses to connect for that reason.  If I use the remote version from the store, it loads immediately.  Why won't the full version run when the Store app will?

  • com-fri
    com-fri Posts: 1

    There are plenty of other fish in the sea

  • skofod
    skofod Posts: 1

    Same thing happened here. since today.

    I cant access remote computer. I cant update it either.

    And I am 3.300 km away, so no update posibble.

    Maybe its time to look for alternatives. :-(

  • What bug was introduced by Microsoft to create this problem on previously wokring TVs?

  • It should not be necessary to install the latest version, unless Microsoft created this bug intentionally to force everybody to update to a "backdoor version" of TV.  Am I correct?

  • I agree.  This is Microsoft strategy.  Either that, or their programming team is not very good at programming.  Sorry, but it is true.  Not everybody can program code.


  • The "version out of date" message is a joke.  To test this, I used an older version to try to connect to a newer version, and still got the "out of date" message.  How can an old version (written before the new version), legitimatley claim that the new version is out of date?

    This sure looks like a Microsoft "scam" of sorts to me.

    Let's all look for another solution instead of using TeamViewer,  and then let's all cancel any subscriptions that we may have with TeamViewer.

  • JeanK
    JeanK Posts: 6,981 Community Manager 🌍

    Hello @GarryAnderson,

    Thank you for your message.

    Considering that Microsoft created intentionally a bug in order to influence which version of TeamViewer people are using is extremely unlikely. This would be pure speculation and we do not support this 

    We always stick to the facts and try to act accordingly. We noticed through the feedback of many users that this kind of bug exists at the moment and that updating the versions to the latest one on both sides of the connection seem to be a stable fix.

    I hope this could help. If not, do not hesitate to ask your questions here.



    Community Manager

  • allanlee
    allanlee Posts: 1

    Having the same problem. My situation prevents me from upgrading my remote computers because they are located "Remotely". Teamviewer needs to enable backwards compatibility...

  • Support:

    Updating my TV to the latest version did not help.  The problem began suddenly without my doing anything, about 6 months ago.  I think TV changed something somewhere.  I have tried TV with Mac OSX and Win7, and both have the same issue.

    The message about upgrading the remote TV is a total fabrication.  I proved this by using an old TV to communicate with a new TV, and the message from the old TV said that the new TV is "old" and therefor needs upgrading.  Of course this is total rubbish because at the time the old TV was written, it did not even know the new TV existed.

    Clearly, somebody does not know what to do.

    Please recommend something that works, or else, revert the changes from 6 months ago when this first happened.

    Sorry to be so blunt, but lets get some people onto this situation who understands what is going on.



  • wroshon
    wroshon Posts: 6 ✭✭

    This all came of TeamViewer shutting down access on their servers to all but the latest version of the "Free" unlicensed client without any notice and providing unhelpful error messages. I got the surprise suddendly after they threw the switch on the servers. TeamViewer on my new work laptop hadn't been activated and suddenly denied access with a misleading error message. Spent a lot of time and energy getting to the bottom of this that could have been avoided with a helpful error message and a link with details as to why the connection was not permitted. As soon as I activated my v12 client, I was back in business.

    I can access any supported backlevel host with an Activated client. I don't believe that TeamViewer has ever supported connecting to a host at a version newer than the client. 

  • wroshon
    wroshon Posts: 6 ✭✭

    @JeanK wrote:

    Hello @allitsolutions,
    Hello @mspl,
    Hello @ashwathn,

    Thank you for your messages.

    Our goal is to provide you with the best service. Therefore, depending on your localization, we will ask you to update your TeamViewer client.

    You will find all the information you need in our official announcement here: Updating to the latest and greatest version of TeamViewer

    I hope this could help. If not, do not hesitate to ask your questions here.



    You get that link with the error message. It's not helpful because it doesn't attend to the actual reason the connection is denied.