link icon
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳

Please find more information here.

TeamViewer on iPhone not connecting over mobile data on the T-Mobile network



  • sbertram
    sbertram Posts: 2

    Working again for me

    @acot wrote:

    Hey everyone, everythings been working for me all weekend and today over LTE.

    How about the rest of you? we all fixed?


  • wsloan
    wsloan Posts: 8
    It is working for me on LTE as well.

    A big thanks for whom ever got that fixed!!!
  • Julia
    Julia Posts: 290 Staff member 🤠

    Hi all,

    The issue should be fixed - I could already read, that most of you do not have the problem anymore.

    Is here someone who still has problems with the connection?

    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • Anovil
    Anovil Posts: 2

    Working here as well! 

    Thank you.

  • Borgholio
    Borgholio Posts: 2

    Just wanted to add my 2 cents that it's not working for me either.  The workaround of turning off LTE does indeed work, as does going to WiFi.  It just doesn't work on T-mobile LTE.

  • Hello. Just read thru all threads and I am still having the same problem. I am on T-Mobile and have a Samsung S8+.
  • randall
    randall Posts: 2

    It worked for a few weeks on T-Mobile in the Los Angeles area for me but then stopped working again about the end of June 2017 and still isn't working as of now (end of July 2017). The app just keeps trying to connect to partner if on cellular network, but on wifi it works just fine. Is there a solution to this or what was changed since May 2017 that has caused it to crash again?

  • randall
    randall Posts: 2

    The issue was resolved temporarily for May 2017, but it is not working on cellular network for those of us on T-Mobile once again as of about the end of June 2017. Can you look into what you did in May to get it working?

  • elfuego
    elfuego Posts: 2


    This issue is still ongoing. I just got off the phone with T-mobile support and they have confirmed that * is whitelisted. The issue first appeared for me when I got my new Galaxy S8 so I thought it was a device issue. However when I saw that it was happening for both Android and IOS, I knew this was something bigger. Here are the troubleshooting steps I've taken:

    • Uninstalled/reinstalled the application
    • Reviewed and granted the teamviewer app all permissions it can possibly have
    • Disabled/Enabled 4G/LTE
    • Verified that I can access and within my S8 browser. 

    Lastly I emailed a copy of the event log from my phone to [email protected] Please have your developers review this. The app keeps stating to check the Internet connection but the teamviewer app is the only application I have installed that can't seem to detect the mobile network.

  • elfuego
    elfuego Posts: 2

    Just to follow-up on this situation. I contacted both Teamviewer and Tmobile. The application logs state that Tmobile is blocking port 5938 which was confirmed by Teamviewer support. I passed this information along to Tmobile and they escalated it with a ticket. However I receive a voicemail 2 days ago stating they would not be unblocking the port with no explanation as to why it was blocked in the first place.

    I don't know how many people on Tmobile use Teamviewer but unless a large number of people start screaming, the app will become almost useless. :manmad:

  • I fixed my problem by cellular data not working for my iPhone , because I moved to Fido before a week. I found a online guide about the cellular data not working and it worked for me. 


  • Teamviewer doesn't work for Android too (over t-mobile). It only doesn't connect when running over 4 LTE. The solution is to get rid of 4G LTE connection.
    I did change the network connection settings to connect only to 3G-4G connection. Worked fine.
  • sankafola
    sankafola Posts: 2 ✭✭

    in setting you need to put data for teamviewer ON 

    ONTIME Posts: 1
    Hi, This solution is for the users who are using teamviewer in windows OS.
    1. Open up teamviewer, click on 'Connection' link in the, then click on 'Exit Team Viewer'
    2. Click windows key on keyboard and type 'Services'
    3. In services window, search for 'TeamViewer' and double clik on 'TeamViewer'.
    4. Click on 'Stop' button.
    5. Now, click on windows key in the keyboard and type 'Team Viewer' and open it. Now, you will be able to connect without any issues
  • davidlan
    davidlan Posts: 1

    I used it last night at my house on my wifi network and it worked fine. I just tried it right now over mobile data on the T-Mobile network and it is not working. When I try to sign in, I get the message "sign in failed. Please check your internet connection". Obviously my internet is working just fine....

    thank you