link icon
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?

Download the new version and let us know what you think about it! 👉 Please click here 👈

TeamViewer windows service causing delay of LAN conectivity after logon

Hello Comunity,

I am facing the issue on my two machines. Both are running Windows 7 Pro 64bit. One is based on Z270 chipset and i7700k CPU, second is HP 290 G1 machine also with some Intel Pentium CPU.

The problem has occurred most probably since the last TW update as I had not this problem before. I have spotted that when I log in to Windows 7, programs Zoiper and Skype seems to not have an issue with the internet connection, while the blue ring on LAN icon is shown. If I try to open Firefox and browse internet, I have no connection. After 1-2 minutes the blue ring is replaced by a yellow triangle for a few seconds and then LAN connectivity starts work normally.

As first, I considered some problems with LAN driver or NIC itself. As my Mobo has also Wifi card, I disabled LAN NIC in BIOS and tried WiFi, but the problem was exactly the same. Then I tried to labor with msconfig.exe where I disabled all startup programs (no luck) then also all non-Microsoft services. After disabling these services problem disappeared. By sequential enabling services, I found out that the problem is back when I enable TeamViewer 14 service. I enabled all services and programs again and disabled TW service only. Now I have not any delay on windows startup but TW application is not automatically started at windows startup, but as I do not need the remote control for this PC is no problem.

Same I tried this also on HP machine. behavior was exactly the same. But as I am using this machine remotely in combination with WOL I cannot permanently disable TW 14 service.

I have checked several forums where a similar problem was discussed but there were different root causes.

Please let me know if anybody has similar problems and if disabling TW 14 service helps.

Thank you in advance.



  • JohnyWheel
    JohnyWheel Posts: 3

    I have finally solved this problem by downgrading to version 13. It is still possible to download older versions of TeamViewer directly from their website. I do not see any problem when using version 13. I only disabled automatic updates and checking for updates.

  • Same here. Windows 7 Pro, 64-bit. If I don't have the service set to start Automatically, it's fine. Manually launching it doesn't cause any problems. I think think Automatic (delayed) works, too.

    The problem with that is that the service appears to alter its own startup setting back to Automatic, so the next time you reboot, it happens again!